Announcement

Collapse
No announcement yet.

ATI fglrx 8.29.6 Discussion

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI fglrx 8.29.6 Discussion

    ATI fglrx 8.29.6
    - Linux 2.6.18 Kernel Support - Radeon R200 Support Removed - Various Fixes
    Phoronix 8.29.6 Review
    Once again, it is the time of the month when new ATI display drivers are presented and it's now the task of Phoronix to evaluate this latest package. Over the past several months, we have seen a horde of improvements reach the proprietary drivers from the Radeon X1000 support earlier this year to X.Org 7.1 support. Other recent changes include a combined i386/x86_64 installer, new distribution packaging support, Radeon X1000 TV-out support, ATI Events Daemon, dynamic displays, and many aticonfig changes. Today with the release of the 8.29.6 fglrx drivers there have not been many changes that affect the end-user, but still there are some items worth mentioning. After several drivers of heated changes, it looks as if we have now reached a slowdown in their development cycle as ATI prepares for the next arsenal of features and fixes. Hitting this month's 8.29.6 driver is Linux 2.6.18 support, removal of R200 product support, and a few resolved issues.
    http://www.phoronix.com/vr.php?view=7375
    Michael Larabel
    http://www.michaellarabel.com/

  • #2
    I finally got last months drivers working with gentoo and now a release that supports 2.6.18 which makes me very happy. Now to see if it installs nicely and plays well with xgl.

    Comment


    • #3
      It should play very well with XGL now. Be sure to report back on how it works for you with Gentoo.
      Michael Larabel
      http://www.michaellarabel.com/

      Comment


      • #4
        Originally posted by Michael View Post
        It should play very well with XGL now. Be sure to report back on how it works for you with Gentoo.
        the drivers work fine on gentoo for me.

        i fing one thing strange...ati claims avivo for xv is not supported yet on xorg 7.1

        well check this out
        lspci
        Code:
        05:00.0 VGA compatible controller: ATI Technologies Inc RV515 [Radeon X1300]
        05:00.1 Display controller: ATI Technologies Inc RV515 [Radeon X1300] (Secondary)
        xvinfo
        Code:
        X-Video Extension version 2.2
        screen #0
          Adaptor #0: "ATI Radeon AVIVO Video"
            number of ports: 4
            port base: 115
            operations supported: PutImage 
            supported visuals:
        (snip)
            Number of image formats: 3
              id: 0x32315659 (YV12)
                guid: 59563132-0000-0010-8000-00aa00389b71
                bits per pixel: 12
                number of planes: 3
                type: YUV (planar)
              id: 0x30323449 (I420)
                guid: 49343230-0000-0010-8000-00aa00389b71
                bits per pixel: 12
                number of planes: 3
                type: YUV (planar)
              id: 0x41424752 (RGBA)
                guid: 52474241-0000-0010-8000-00aa00389b71
                bits per pixel: 32
                number of planes: 1
                type: RGB (packed)
                depth: 32
                red, green, blue masks: 0xff, 0xff, 0xff
        so i HAVE xv available now. hmm....

        not mentioning i can properly play videos using xv with those drivers on my x1300pro card. yay!

        Comment


        • #5
          Very interesting about xv... I haven't tried it yet, but will give it a go on a few X1k machines to see how it stands. I'll also see if ATI has any comments about that matter.
          Michael Larabel
          http://www.michaellarabel.com/

          Comment


          • #6
            Originally posted by yoshi314 View Post
            the drivers work fine on gentoo for me.

            i fing one thing strange...ati claims avivo for xv is not supported yet on xorg 7.1

            well check this out
            lspci
            Code:
            05:00.0 VGA compatible controller: ATI Technologies Inc RV515 [Radeon X1300]
            05:00.1 Display controller: ATI Technologies Inc RV515 [Radeon X1300] (Secondary)
            xvinfo
            Code:
            X-Video Extension version 2.2
            screen #0
              Adaptor #0: "ATI Radeon AVIVO Video"
                number of ports: 4
                port base: 115
                operations supported: PutImage 
                supported visuals:
            (snip)
                Number of image formats: 3
                  id: 0x32315659 (YV12)
                    guid: 59563132-0000-0010-8000-00aa00389b71
                    bits per pixel: 12
                    number of planes: 3
                    type: YUV (planar)
                  id: 0x30323449 (I420)
                    guid: 49343230-0000-0010-8000-00aa00389b71
                    bits per pixel: 12
                    number of planes: 3
                    type: YUV (planar)
                  id: 0x41424752 (RGBA)
                    guid: 52474241-0000-0010-8000-00aa00389b71
                    bits per pixel: 32
                    number of planes: 1
                    type: RGB (packed)
                    depth: 32
                    red, green, blue masks: 0xff, 0xff, 0xff
            so i HAVE xv available now. hmm....

            not mentioning i can properly play videos using xv with those drivers on my x1300pro card. yay!
            x86_64 bug on X.Org 6.9+ systems with X-Video still seems to be present
            Michael Larabel
            http://www.michaellarabel.com/

            Comment


            • #7
              Drivers on an HP dv8000 laptop

              Originally posted by Michael View Post
              ATI fglrx 8.29.6 Phoronix 8.29.6 Review http://www.phoronix.com/vr.php?view=7375
              Have you guys ever tested these drivers on a laptop? I was wondering, because I recently purchased an HP dv8000 (AMD Turion 64). The ATI drivers have never worked at all, at least not without changing the Xorg.conf considerably. With this release of the drivers, I have actually managed to get them to work to some extent. The first issue was that GDM wouldn't come up, and the workaround I found was to change the BIOS setting to used shared memory for the card (Radeon Xpress 200M PCI-Express). That got GDM to come up, and after logging in rendering of the screen was horrible, and eventually X would just hang. It turns out that DRI was the culprit. After turning DRI off, I now have a stable environment. When turning DRI off, I also could go back to normal BIOS settings, without the shared memory. I have been completely unsuccessful with turning in tickets around these issues, as the ATI response is always that they don't support laptops. This seems a little absurd, considering this chipset, which is supported by the driver is a laptop specific chipset, and their Windows drivers work with it just fine. Anyway, I'm looking for any avenue possible to see if ATI can fix the issues around my laptop. There are many others with this laptop and other HP/Compaq laptops that are having the same problem. Some actually get DRI working with the BIOS workaround, but for me that didn't work.

              Comment


              • #8
                Yes, we perform tests with the ATI Linux Display Drivers on a very frequent basis. In fact, for personal use my laptop has Radeon graphics.

                The Xpress 200/200M is notorious for troubles with the fglrx Linux display drivers... I have heard nothing about ATI's intentions on fixing the issue.
                Michael Larabel
                http://www.michaellarabel.com/

                Comment


                • #9
                  Do you know if when you put in a ticket through the ATI support website, if the Linux developers actually get the information? Since they always send me an automated reply that says they don't support laptops, I'm never sure. It does say in the automated reply that the information is still forwarded to development.

                  Comment


                  • #10
                    Yes, the appropriate developers will receive the information. I can tell you definitively that ATI Linux developers are very aware of the Xpress 200/200M problems.
                    Michael Larabel
                    http://www.michaellarabel.com/

                    Comment


                    • #11
                      Thanks, I appreciate knowing that they know the issues.

                      Comment


                      • #12
                        I have incorrect Xv video display on TV-out (S-video), and have to use video through OpenGL with flabby appearence. In combination with no TV-out support from the open source drivers, an ati card is a non-starter if you want to use your TV, or your TV hasn't got digital input. I run fglrx 8.29.6 on Ubuntu Dapper, Radeon 9600 AGP on Intel 845. On XP everything works fine. I tried every major distro with the same result. It's also been confirmed as a Bugzilla Bug 309 from february 2006 with no fix yet. Somebody elses sample of the bug at http://folk.uio.no/henger/htpc/ati-pal-tvout.jpg
                        Last edited by giorgosts; 10-12-2006, 04:06 AM.

                        Comment


                        • #13
                          giorgosts,

                          Had you tried to enable TexturedVideo? Did that make any difference with TV-out?
                          Michael Larabel
                          http://www.michaellarabel.com/

                          Comment


                          • #14
                            Originally posted by Michael View Post
                            giorgosts,

                            Had you tried to enable TexturedVideo? Did that make any difference with TV-out?
                            Thanks for the suggestion. Video displays fine, but the performance is the same as with OpenGL overlay, nowhere near Xv video output. Video is displayed as if there is some form of liquid between you and the tv. They have to fix the bug. In the meantime, I can always dual-boot and see the movie and then back to linux.

                            On the other hand, I have a GEEXBOX liveCD which works amazingly fine. Xv simultaneously on monitor and tv. Performance, colors, contrast better than MSwindows with the new catalyst and everything. It even works on an old Radeon 7500 PCI that ATI doesn't support. How do these guys do it?
                            Last edited by giorgosts; 10-12-2006, 04:43 PM.

                            Comment


                            • #15
                              Working Nicely

                              Everything is working nicely on 2.6.18 on gentoo. Xgl works nicely as well as X. Does anyone know if there is an AVIVO converter for linux? I'm really likeing how easy the drivers are to install and they just work now. Always had problems with my 9700 and now everything plays nicely, even with my 1900xt

                              Comment

                              Working...
                              X