Announcement

Collapse
No announcement yet.

Sampling info about that mouse freeze bug

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sampling info about that mouse freeze bug

    Ticket on the unofficial bugzilla: http://ati.cchtml.com/show_bug.cgi?id=141

    I'd like to make a thread a bit more structured than the comments gathered here and there on this forum, in order to pin down possible causes.

    Could anyone using fglrx in here please post the following info:
    Affected by the bug: Yes/No
    Graphics card:
    Number of displays:
    Distribution (name, version, architecture):
    Desktop environment:
    Compositing: On/Off
    fglrx version(s) I've used on that distribution, with that bug:
    fglrx version(s) I've used on that distribution, without that bug:
    ATI Catalyst Control Center settings:
    Things I've tried to solved it (if affected):
    Affected by the bug: No
    Graphics card: HD4670 512MB
    Number of displays: 1
    Distribution (name, version, architecture): openSUSE 11.4 64bit
    Desktop environment: KDE
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: none
    fglrx version(s) I've used on that distribution, without that bug: 11.3 through 11.7 (from AMD's website)
    ATI Catalyst Control Center settings: Default
    Things I've tried to solved it (if affected): obviously none, though my first thought would be to try using SWCursor
    Last edited by PsynoKhi0; 07-30-2011, 06:37 PM.

  • #2
    Affected by the bug: Yes
    Graphics card: ATI 5770 1GB
    Number of displays: 1
    Distribution (name, version, architecture): Ubuntu 11.04 64bit
    Desktop environment: Gnome
    Compositing: Off
    fglrx version(s) I've used on that distribution, with that bug: 11.5 - 11.7
    fglrx version(s) I've used on that distribution, without that bug: 11.4
    ATI Catalyst Control Center settings: Default
    Things I've tried to solved it (if affected): SWCursor will fix it, but it doesn't work very well, the cursor disappears, playing games you can't even see the cursor... Tried turning v-sync off, tear free off, doesn't fix it.
    Last edited by tcv90; 07-30-2011, 06:56 PM.

    Comment


    • #3
      Affected by the bug: No
      Graphics card: HD4200 and HD6650M 1024MB (on my HP Pavilion dv6-6030er)
      Number of displays: 1, 2 (using only my notebook display, but tried to combine it with my external monitor via VGA)
      Distribution (name, version, architecture): Debain GNU/Linux testing+unstable 64bit
      Desktop environment: KDE
      Compositing: On
      fglrx version(s) I've used on that distribution, with that bug: none
      fglrx version(s) I've used on that distribution, without that bug: 11.4 through 11.7 (from Debian testing and unstable repositories)
      ATI Catalyst Control Center settings: Default
      Things I've tried to solved it (if affected): none, I hadn't experienced the bug

      Comment


      • #4
        Thanks for the replies so far!
        BTW if anyone thinks something should be added (e.g. motherboard chipset maybe), feel free.

        Affected by the bug: No
        Graphics card: HD4670 512MB
        Number of displays: 1
        Distribution (name, version, architecture): PCLinuxOS 2011.6 (from liveCD, fglrx activated out-of-the-box)
        Desktop environment: KDE and LXDE
        Compositing: On & Off in KDE, Off in LXDE
        fglrx version(s) I've used on that distribution, with that bug: none
        fglrx version(s) I've used on that distribution, without that bug: 11.6
        ATI Catalyst Control Center settings: Defaults
        Things I've tried to solve it (if affected): N/A

        (BTW typo on the last line of the original post, "solve" shouldn't be in past participle)

        Comment


        • #5
          Affected by the bug: No
          Graphics card: 5850M
          Number of displays: 1
          Distribution (name, version, architecture): Kubuntu 11.04 x86_64
          Desktop environment: KDE
          Compositing: On
          fglrx version(s) I've used on that distribution, without that bug: Catalyst 10.9, 10.10, 11.1-11.7
          ATI Catalyst Control Center settings: TearFreeDesktop Enabled.

          Comment


          • #6
            Affected by the bug: Yes
            Graphics card: HD 5770 1GB
            Number of displays: 1
            Distribution (name, version, architecture): Linux Mint 11 x86_64
            Desktop environment: Gnome 2.x
            Compositing: On and Off
            fglrx version(s) I've used on that distribution, with that bug: 11.5, 11.6, 11.7
            fglrx version(s) I've used on that distribution, without that bug: 11.4
            ATI Catalyst Control Center settings: default and modified without tearfree and vsync
            Things I've tried to solved it (if affected): tryed compiz on and off, disabled tearfree and vsync.
            Last edited by xpander; 08-02-2011, 05:12 PM. Reason: typo

            Comment


            • #7
              Affected by the bug: Yes
              Graphics card: hd5770
              Number of displays: 1
              Distribution (name, version, architecture): gentoo and64
              Desktop environment: openbox
              Compositing: Off
              fglrx version(s) I've used on that distribution, with that bug: 11.05-11.07
              fglrx version(s) I've used on that distribution, without that bug: <= 11.04
              ATI Catalyst Control Center settings: default
              Things I've tried to solved it (if affected): I haven't tried something, just rolled back to 11.04.
              Last edited by lexek; 08-03-2011, 04:35 AM.

              Comment


              • #8
                Originally posted by lexek View Post
                fglrx version(s) I've used on that distribution, with that bug: <= 11.04
                fglrx version(s) I've used on that distribution, without that bug: 11.05-11.07
                Maybe you mean that?
                fglrx version(s) I've used on that distribution, with that bug: 11.05-11.07
                fglrx version(s) I've used on that distribution, without that bug: <= 11.04

                Comment


                • #9
                  Affected by the bug: No
                  Graphics card: Radeon 4850 / Radeon 6870
                  Number of displays: 1
                  Distribution (name, version, architecture): Gentoo, 2.6.32, 2.6.36, XOrg 1.8 - 1.10
                  Desktop environment: KDE 4.4.4, KDE 4.6.3
                  Compositing: On
                  fglrx version(s) I've used on that distribution, with that bug: None
                  fglrx version(s) I've used on that distribution, without that bug: 10.x upto 11.6
                  ATI Catalyst Control Center settings: Defaults
                  Things I've tried to solved it (if affected): Not affected

                  Comment


                  • #10
                    Originally posted by RussianNeuroMancer View Post
                    Maybe you mean that?
                    fglrx version(s) I've used on that distribution, with that bug: 11.05-11.07
                    fglrx version(s) I've used on that distribution, without that bug: <= 11.04
                    Yes, thanks)

                    Comment


                    • #11
                      Originally posted by tcv90 View Post
                      Affected by the bug: Yes
                      Graphics card: ATI 5770 1GB
                      Number of displays: 1
                      Distribution (name, version, architecture): Ubuntu 11.04 64bit
                      Desktop environment: Gnome
                      Compositing: Off
                      fglrx version(s) I've used on that distribution, with that bug: 11.5 - 11.7
                      fglrx version(s) I've used on that distribution, without that bug: 11.4
                      ATI Catalyst Control Center settings: Default
                      Things I've tried to solved it (if affected): SWCursor will fix it, but it doesn't work very well, the cursor disappears, playing games you can't even see the cursor... Tried turning v-sync off, tear free off, doesn't fix it.
                      Mine is very similar:
                      Graphics card: ATI 5770 1GB
                      Number of displays: 1
                      Distribution (name, version, architecture): Ubuntu 10.10 64-bit, Ubuntu 11.04 64bit
                      Desktop environment: Gnome 2.x, Unity
                      Compositing: Off
                      fglrx version(s) I've used on that distribution, with that bug: 11.5 - 11.6
                      fglrx version(s) I've used on that distribution, without that bug: 11.4
                      ATI Catalyst Control Center settings: Default

                      I did not install the drivers outside of X. I downloaded the ATI drivers and then followed these steps in Ubuntu:
                      1. Open terminal
                      2. sudo bash (enter password)
                      3. cd /home/(my account)/Downloads
                      4. chmod 744 ati-driver-installer-11-6-x86.x86_64.run
                      5. ./ati-driver-installer-11-6-x86.x86_64.run
                      Follow prompts, restart.

                      If anyone can seriously suggest that installing the new driver outside of X is better, I'll give it a go. I'm not sure how to shut down X in Ubuntu. In Debian I go to a tty and do "init 3". Anyone know the Ubuntu equivalent off hand?

                      I didn't try 11.7 because I see no reason to do it when other people are still reporting the bug.

                      Comment


                      • #12
                        Code:
                        Affected by the bug: Yes
                        Graphics card: ATI HD 5750
                        Number of displays: 2 or 1
                        Distribution (name, version, architecture): Fedora 15; kernel 2.6.38 - 3.0
                        Desktop environment: XFCE
                        Compositing: On
                        fglrx version(s) I've used on that distribution, with that bug: 1.5+
                        fglrx version(s) I've used on that distribution, without that bug: 1.4-
                        ATI Catalyst Control Center settings: default
                        Things I've tried to solved it (if affected): SWCursor set to true (breaks certain games), Downgrading to 1.4
                        Fortunately, RPMFusion provides a downgraded package for the Catalyst driver at 1.4.
                        Unfortunately, Fedora 15 now uses Linux 3.0 as of August 4, 2011. The earliest known catalyst driver able to handle that is 1.7 which contains the bug.
                        Thankfully, Fedora keeps several fallback images :3
                        Last edited by computerquip; 08-05-2011, 01:37 AM.

                        Comment


                        • #13
                          For those of you using Ubuntu Natty, could you please specify if the 11.4 version that works is the Ubuntu-repo one or from external sources? Thanks.

                          Comment


                          • #14
                            @Michael_S

                            NEVER use the installer without creating deb packages for anything newer than lucid. That kills the system, at least parts of it that you wont be able to switch back to oss drivers your way even when you install it correctly later.

                            Comment


                            • #15
                              Originally posted by PsynoKhi0 View Post
                              For those of you using Ubuntu Natty, could you please specify if the 11.4 version that works is the Ubuntu-repo one or from external sources? Thanks.
                              Both the repo version and the one from AMD's site works fine.

                              Comment

                              Working...
                              X