Announcement

Collapse
No announcement yet.

AMD Catalyst 11.6 Linux Driver Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Catalyst 11.6 Linux Driver Released

    Phoronix: AMD Catalyst 11.6 Linux Driver Released

    AMD has this afternoon released the Catalyst 11.6 Linux driver...

    http://www.phoronix.com/vr.php?view=OTU3Mg

  • #2
    Notes:

    http://www2.ati.com/relnotes/Catalys..._Installer.pdf

    Comment


    • #3
      Works Gnome Shell with this release?

      Comment


      • #4
        Crashes for me on Linux Mint 11 (based on Ubuntu, so should (almost) be supported according to the release notes (note that I also have a integrated intel in this device so PowerXpress should work) :'(

        Code:
        [    22.150] 
        X.Org X Server 1.10.1
        Release Date: 2011-04-15
        [    22.150] X Protocol Version 11, Revision 0
        [    22.150] Build Operating System: Linux 2.6.24-29-server x86_64 Ubuntu
        [    22.150] Current Operating System: Linux thomas-nb 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64
        [    22.150] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=d48ef26d-605f-46f4-a5fb-f6e042095d43 ro quiet splash vt.handoff=7
        [    22.150] Build Date: 19 April 2011  03:40:45PM
        [    22.150] xorg-server 2:1.10.1-1ubuntu1 (For technical support please see http://www.ubuntu.com/support) 
        [    22.150] Current version of pixman: 0.20.2
        [    22.150] 	Before reporting problems, check http://wiki.x.org
        	to make sure that you have the latest version.
        [    22.150] Markers: (--) probed, (**) from config file, (==) default setting,
        	(++) from command line, (!!) notice, (II) informational,
        	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
        [    22.151] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 15 23:20:47 2011
        [    22.170] (==) Using config file: "/etc/X11/xorg.conf"
        [    22.170] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
        [    22.220] (==) ServerLayout "aticonfig Layout"
        [    22.220] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
        [    22.220] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
        [    22.220] (**) |   |-->Device "aticonfig-Device[0]-0"
        [    22.221] (==) Automatically adding devices
        [    22.221] (==) Automatically enabling devices
        [    22.243] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
        [    22.243] 	Entry deleted from font path.
        [    22.243] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
        [    22.243] 	Entry deleted from font path.
        [    22.243] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
        [    22.243] 	Entry deleted from font path.
        [    22.243] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
        [    22.243] 	Entry deleted from font path.
        [    22.243] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
        [    22.243] 	Entry deleted from font path.
        [    22.264] (==) FontPath set to:
        	/usr/share/fonts/X11/misc,
        	/usr/share/fonts/X11/Type1,
        	/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
        	built-ins
        [    22.264] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
        [    22.264] (II) The server relies on udev to provide the list of input devices.
        	If no devices become available, reconfigure udev or disable AutoAddDevices.
        [    22.264] (II) Loader magic: 0x7e0280
        [    22.264] (II) Module ABI versions:
        [    22.264] 	X.Org ANSI C Emulation: 0.4
        [    22.264] 	X.Org Video Driver: 10.0
        [    22.264] 	X.Org XInput driver : 12.3
        [    22.264] 	X.Org Server Extension : 5.0
        [    22.266] (--) PCI:*(0:0:2:0) 8086:2a42:1025:027f rev 7, Mem @ 0xf0000000/4194304, 0xe0000000/268435456, I/O @ 0x00004110/8
        [    22.266] (--) PCI: (0:1:0:0) 1002:9552:1025:027f rev 0, Mem @ 0xd0000000/268435456, 0xf4400000/65536, I/O @ 0x00003000/256, BIOS @ 0x????????/131072
        [    22.266] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
        [    22.266] (II) "extmod" will be loaded by default.
        [    22.266] (II) "dbe" will be loaded by default.
        [    22.266] (II) "glx" will be loaded by default.
        [    22.266] (II) "record" will be loaded by default.
        [    22.266] (II) "dri" will be loaded by default.
        [    22.266] (II) "dri2" will be loaded by default.
        [    22.266] (II) LoadModule: "extmod"
        [    22.295] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
        [    22.304] (II) Module extmod: vendor="X.Org Foundation"
        [    22.304] 	compiled for 1.10.1, module version = 1.0.0
        [    22.304] 	Module class: X.Org Server Extension
        [    22.304] 	ABI class: X.Org Server Extension, version 5.0
        [    22.304] (II) Loading extension MIT-SCREEN-SAVER
        [    22.304] (II) Loading extension XFree86-VidModeExtension
        [    22.304] (II) Loading extension XFree86-DGA
        [    22.304] (II) Loading extension DPMS
        [    22.304] (II) Loading extension XVideo
        [    22.304] (II) Loading extension XVideo-MotionCompensation
        [    22.304] (II) Loading extension X-Resource
        [    22.304] (II) LoadModule: "dbe"
        [    22.305] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
        [    22.305] (II) Module dbe: vendor="X.Org Foundation"
        [    22.305] 	compiled for 1.10.1, module version = 1.0.0
        [    22.305] 	Module class: X.Org Server Extension
        [    22.305] 	ABI class: X.Org Server Extension, version 5.0
        [    22.305] (II) Loading extension DOUBLE-BUFFER
        [    22.305] (II) LoadModule: "glx"
        [    22.306] (II) Loading /usr/lib/xorg/extra-modules/modules/extensions/libglx.so
        [    22.349] (II) Module glx: vendor="FireGL - ATI Technologies Inc."
        [    22.350] 	compiled for 6.9.0, module version = 1.0.0
        [    22.350] (II) Loading extension GLX
        [    22.350] (II) LoadModule: "record"
        [    22.350] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
        [    22.397] (II) Module record: vendor="X.Org Foundation"
        [    22.397] 	compiled for 1.10.1, module version = 1.13.0
        [    22.397] 	Module class: X.Org Server Extension
        [    22.397] 	ABI class: X.Org Server Extension, version 5.0
        [    22.397] (II) Loading extension RECORD
        [    22.397] (II) LoadModule: "dri"
        [    22.397] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
        [    22.405] (II) Module dri: vendor="X.Org Foundation"
        [    22.405] 	compiled for 1.10.1, module version = 1.0.0
        [    22.405] 	ABI class: X.Org Server Extension, version 5.0
        [    22.405] (II) Loading extension XFree86-DRI
        [    22.405] (II) LoadModule: "dri2"
        [    22.406] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
        [    22.406] (II) Module dri2: vendor="X.Org Foundation"
        [    22.406] 	compiled for 1.10.1, module version = 1.2.0
        [    22.406] 	ABI class: X.Org Server Extension, version 5.0
        [    22.406] (II) Loading extension DRI2
        [    22.406] (II) LoadModule: "fglrx"
        [    22.406] (II) Loading /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so
        [    22.688] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        [    22.701] 	compiled for 1.4.99.906, module version = 8.86.5
        [    22.701] 	Module class: X.Org Video Driver
        [    22.702] (II) Loading sub module "fglrxdrm"
        [    22.702] (II) LoadModule: "fglrxdrm"
        [    22.702] (II) Loading /usr/lib/xorg/extra-modules/modules/linux/libfglrxdrm.so
        [    22.725] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
        [    22.725] 	compiled for 1.4.99.906, module version = 8.86.5
        [    22.725] (II) ATI Proprietary Linux Driver Version Identifier:8.86.5
        [    22.725] (II) ATI Proprietary Linux Driver Release Identifier: 8.861                                
        [    22.725] (II) ATI Proprietary Linux Driver Build Date: May 24 2011 22:46:53
        [    22.725] (++) using VT number 7
        
        [    22.725] (WW) Falling back to old probe method for fglrx
        [    22.761] (II) Loading PCS database from /etc/ati/amdpcsdb
        [    22.773] (--) Chipset Supported AMD Graphics Processor (0x9552) found
        [    22.774] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
        [    22.775] (II) AMD Video driver is running on a device belonging to a group targeted for this release
        [    22.775] (II) AMD Video driver is signed
        [    22.776] (II) Loading /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so
        [    22.776] (II) Loading /usr/lib/xorg/extra-modules/modules/linux/libfglrxdrm.so
        [    22.776] (II) fglrx(0): pEnt->device->identifier=0x16f56b0
        [    22.776] (II) fglrx(0): === [xdl_xs110_atiddxPreInit] === begin
        [    22.776] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
        [    22.776] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
        [    22.776] (==) fglrx(0): Default visual is TrueColor
        [    22.776] (**) fglrx(0): Option "DPMS" "true"
        [    22.777] (==) fglrx(0): RGB weight 888
        [    22.777] (II) fglrx(0): Using 8 bits per RGB 
        [    22.777] (==) fglrx(0): Buffer Tiling is ON
        [    22.777] (II) Loading sub module "fglrxdrm"
        [    22.778] (II) LoadModule: "fglrxdrm"
        [    22.778] (II) Loading /usr/lib/xorg/extra-modules/modules/linux/libfglrxdrm.so
        [    22.778] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
        [    22.778] 	compiled for 1.4.99.906, module version = 8.86.5
        [    22.781] ukiDynamicMajor: found major device number 251
        [    22.781] ukiDynamicMajor: found major device number 251
        [    22.781] ukiOpenByBusid: Searching for BusID PCI:1:0:0
        [    22.781] ukiOpenDevice: node name is /dev/ati/card0
        [    22.781] ukiOpenDevice: open result is 10, (OK)
        [    22.781] ukiOpenByBusid: ukiOpenMinor returns 10
        [    22.781] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
        [    22.781] (==) fglrx(0): NoAccel = NO
        [    22.781] (==) fglrx(0): ATI 2D Acceleration Architecture enabled
        [    22.781] (--) fglrx(0): Chipset: "ATI Mobility Radeon HD 4300 Series" (Chipset = 0x9552)
        [    22.781] (--) fglrx(0): (PciSubVendor = 0x1025, PciSubDevice = 0x027f)
        [    22.781] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original ATI
        [    22.781] (--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
        [    22.781] (--) fglrx(0): MMIO registers at 0xf4400000
        [    22.781] (--) fglrx(0): I/O port at 0x00003000
        [    22.781] (==) fglrx(0): ROM-BIOS at 0x000c0000
        [    22.813] (II) fglrx(0): AC Adapter is used
        [    23.784] (II) fglrx(0): ATI Video BIOS revision 9 or later detected
        [    23.784] (--) fglrx(0): Video RAM: 524288 kByte, Type: DDR3
        [    23.784] (II) fglrx(0): PCIE card detected
        [    23.784] (--) fglrx(0): Using per-process page tables (PPPT) as GART.
        [    23.784] (WW) fglrx(0): board is an unknown third party board, chipset is supported
        [    23.787] 
        Backtrace:
        [    23.830] 0: /usr/bin/X (xorg_backtrace+0x26) [0x4a2626]
        [    23.830] 1: /usr/bin/X (0x400000+0x6219a) [0x46219a]
        [    23.830] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f5f80b74000+0xfc60) [0x7f5f80b83c60]
        [    23.830] 3: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xdl_xs110_atiddxPxPreInit+0x8e) [0x7f5f7d54524e]
        [    23.830] 4: /usr/lib/xorg/extra-modules/modules/drivers/fglrx_drv.so (xdl_xs110_atiddxPreInit+0x122c) [0x7f5f7d51ab9c]
        [    23.830] 5: /usr/bin/X (InitOutput+0x809) [0x4705d9]
        [    23.830] 6: /usr/bin/X (0x400000+0x218c3) [0x4218c3]
        [    23.830] 7: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xff) [0x7f5f7fabdeff]
        [    23.830] 8: /usr/bin/X (0x400000+0x21629) [0x421629]
        [    23.831] Segmentation fault at address (nil)
        [    23.831] 
        Caught signal 11 (Segmentation fault). Server aborting
        [    23.831] 
        Please consult the The X.Org Foundation support 
        	 at http://wiki.x.org
         for help. 
        [    23.831] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
        [    23.831] 
        [    23.854]  ddxSigGiveUp: Closing log

        Comment


        • #5
          Still the "corner-bug"

          As I can see, this annoying bug is not resolved. When the mouse is moved at the low right screen, the system "hangs" for 1 second. And as I have read, this bug was fixed for Windows with a hotfix driver some days ago (11.5a I think).

          Comment


          • #6
            What about AMD Steady Video? Is it implemented on Linux too or is it Windows exclusive?

            Comment


            • #7
              Originally posted by Khudsa View Post
              Works Gnome Shell with this release?
              No.
              Still "VESA: CAPILANO".
              = horrible performance and graphics corruption in the panel and in the icons.

              Comment


              • #8
                how about firefox graphic corruption?

                Comment


                • #9
                  I wish ATI would post download checksums..

                  anyone have md5 or sha1?

                  Comment


                  • #10
                    Originally posted by SkyHiRider View Post
                    What about AMD Steady Video? Is it implemented on Linux too or is it Windows exclusive?
                    You're joking, right?

                    Comment


                    • #11
                      Still no support for kernel 2.6.39 and/or X server 1.10.2 on Arch Linux, so continuing to use Radeon driver.

                      Comment


                      • #12
                        You mean no support for KMS? I was using Catalyst 11.5, and since yesterday 11.6 in Arch with no problems, no hang-ups, and nice performance (much better than xf86-video-ati for sure). But since there is no KMS support, I had to accept large font in ctrl-Fx console, but it's still the only bigger drawback.

                        Comment


                        • #13
                          If they ever install the new Catalyst driver on that Llano system that you have remote access to, would you care to re-benchmark with the new driver?

                          Comment


                          • #14
                            Originally posted by Reloaded211 View Post
                            Still no support for kernel 2.6.39 and/or X server 1.10.2 on Arch Linux, so continuing to use Radeon driver.
                            What?
                            Code:
                            chris@chrisl ~ % pacman -Q xorg-server
                            xorg-server 1.10.2-1
                            chris@chrisl ~ % uname -a
                            Linux chrisl 3.0.0-rc3-mainline #1 SMP PREEMPT Tue Jun 14 12:32:26 UTC 2011 x86_64 Intel(R) Core(TM) i5 CPU M 480 @ 2.67GHz GenuineIntel GNU/Linux
                            chris@chrisl ~ % pacman -Q catalyst-3.0.0-rc3-mainline
                            catalyst-3.0.0-rc3-mainline 11.6-1
                            chris@chrisl ~ % fglrxinfo
                            display: :0.0  screen: 0
                            OpenGL vendor string: ATI Technologies Inc.
                            OpenGL renderer string: AMD Radeon HD 6500M/5600/5700 Series
                            OpenGL version string: 4.1.10834 Compatibility Profile Context
                            chris@chrisl ~ %
                            Not more problems than usually encountered with fglrx.

                            Comment


                            • #15
                              Originally posted by ChrisXY View Post
                              No.
                              Still "VESA: CAPILANO".
                              = horrible performance and graphics corruption in the panel and in the icons.
                              thx for pointing that out, i guess i'll wait a little longer with this

                              Comment

                              Working...
                              X