Announcement

Collapse
No announcement yet.

AMD Puts Out Catalyst 11.4 With X Server 1.10 Support

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    where can i find the full changelog? (on their homepage "release notes" points to old 11.3 installation pdf)
    and what was "one wine bug fix included"?

    Comment


    • #32
      Just tried today with Ubuntu 11.04, result: slow as hell.

      Comment


      • #33
        Maybe you did not install it correctly. I tested my fglrx with u 11.04 and it worked (if fglrx was installed already use -z option and reboot then).

        Comment


        • #34
          It was perfectly installed (but the catalyst installer gui didn't work, terminal way). FPS were a little low (about 400 with fgl_glxears, while 10.10 gives me about 900-1000) and while moving windows, I didn't feel smooth as in 10.10 (nothing relative to fragmentation).

          Comment


          • #35
            If you didnt use the option to create debs then you killed your install.

            Comment


            • #36
              Maybe, but I used to create debs in 10.10 and the information section on amdcccle doesn't show that I updated the catalyst. Also, I updated to Catalyst 11.1, 11.2 and 11.3 following that method and there was always a bug that freezes my system. When I chose direct install, the information section updated succesfully and the bug gone.

              Comment


              • #37
                That has nothing to do with it. When fglrx is active and you replace it then /etc/ati is still written on shutdown. When you reboot then you can see the old version. In order to see the new version you have to stop X, remove the file that stores the config and start X again. Also thats just an opticial thing with amdcccle, fglrxinfo reports the correct opengl version.

                Comment


                • #38
                  I'll make a 10gb partition and test it again with debs, hope there is better performance.

                  Comment


                  • #39
                    Well you can try my script first. Use -z option, i uninstall fglrx with it first.

                    http://kanotix.com/files/install-fglrx-debian.sh

                    fglrx usually works then, but driver switching is still broken.

                    Comment


                    • #40
                      About wine bugs, pre-release driver had fixed at least:
                      1) One Portal & Portal 2 issue. Now Portal 2 is playable and almost bug-free on fglrx. (But it also runs quite nice on r600g, though a bit slower)
                      2) One Bulletstorm issue: game doesn't crash just after intro vids. But it's still miscoroled or grayed out and very laggy - unplayable.

                      Comment


                      • #41
                        @alazar
                        If You use standard instalation method (so without debs generation) remember that You have to install manually some stuff eg: dkms and qt4-gui (and some others qt4 packages). Safer method is generate debs and install it with all depedencies.

                        Comment


                        • #42
                          I just tried 11.4 out. My impressions:

                          Desktop tears like ****.

                          After I enabled the "Tear Free Desktop" option, the desktop lags like ****

                          AMD is battling with this issue for years now, and they still can't get it right.

                          Comment


                          • #43
                            Originally posted by Kano View Post
                            Well you can try my script first. Use -z option, i uninstall fglrx with it first.

                            http://kanotix.com/files/install-fglrx-debian.sh

                            fglrx usually works then, but driver switching is still broken.
                            That script works amazing well, thanks for sharing. 11.4 now works better, the "not so smothing sensation" I had was due to some refreshing options in compiz, now it's smooth as always.

                            Also, if I run glxgears without the free fragmentation option in amdcccle, desktop freezes time to time. However, glxgears reports more than 2000 FPS, fgl_glxgears is not affected, reporting about 900 FPS.

                            Comment


                            • #44
                              Originally posted by RealNC View Post
                              I just tried 11.4 out. My impressions:

                              Desktop tears like ****.

                              After I enabled the "Tear Free Desktop" option, the desktop lags like ****

                              AMD is battling with this issue for years now, and they still can't get it right.
                              after weeks of hacking and fighting mainboardchipset bugs vs 64bit linux i now do have a catalyst 11.4 working on an 32bit linux..

                              and... i can not see tearing if i use tear free desktop

                              but the desktop is very slow but its also slow if i don'T use the tear free desktop...

                              but yes on this agp system the radeon is slower than the catalyst...

                              Comment


                              • #45
                                Today i tested a hd 4550 card with a full hd tv. I disabled onboard sound and first used pulse audio, but trine had very bad sound with it, therefore i used a .asoundrc to set hw:0,3 as default.

                                a) fglrx 11-4 activates underscan even inside X (amdcccle can configure it per device to overscan 0, but why is that not default)

                                when i swiched a few times fullscreen + window mode with xbmc then fullscreen worked, but window mode was unuseable (forget that crap...)

                                b) r600

                                With xbmc i the menu (of the default theme) on the left side was just white. I could play live video via vdr streamdev however. But who wants a white menu?

                                c) r600g

                                The menu was fine, but i could not active live video, must be related to hdmi, because i did not change the driver, just activated onboard sound again and removed the .asoundrc then it worked (with a tft connected via dvi).

                                All in all ati as htpc failed today... As kernel i had to use 2.6.38 because 39 git seems to have wrong channeltuning for dvb. Did anybody notice that too?

                                Comment

                                Working...
                                X