Announcement

Collapse
No announcement yet.

HELP!!! FGLRX causing screen hardlocks

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP!!! FGLRX causing screen hardlocks

    My problem is unique, and no one has been of any help so far. I have tried posting in fedora forum as well as other linux forums. I own a MSI X1800 XT (Model RX1800XT-VT-2D-512E) 512 MB graphics card. Versions upto 8.32.5 of fglrx run without a hitch on it. Versions from 8.33.6 onwards always result in a black screen upon reboot, and the system hangs. I cant even press Ctrl+Alt+F4/F1 etc. to get in to the console. I have tried all versions till the latest 8.37.6. The problem is not unique to fedora alone, as the same problem creeps up even if I use OpenSuse, Ubuntu or any other distro. The problem is newer kernels require newer fglrx versions, and so I am unable to get hardware acceleration in any of the new kernel ( 2.6.19 onwards) based distros.

    My configuration is as follows:

    AMD Athlon 64 3200+ Venice
    Gigabyte GA-K8N51-GMF9 Motherboard (Nforce 430/Geforce 6100)
    1 GB DDR400 RAM
    MSI X1800XT 512 MB graphics
    Cooler master 600W PSU
    Samsung Syncmaster 793s 17" CRT display
    OS: Fedora core 6 x86, Ubuntu Feisty fawn x64

    I have tried doing the following:-

    1. Manually running the .run file, building rpms/debs with the --Fedora/FC6 option and then editing xorg.conf and disabling composite extension to get DRI.
    2. Downloading pre-built kernel modules from livna using yum
    3. Using apt to download restricted drivers in ubuntu feisty fawn

    All drivers from 8.33.6 to 8.37.6 just cause the same problem on restart. The xorg.0.log shows some DRM module error. Please help me.

    Regards,

    Karthik Ramgopal
    India

  • #2
    You should check the /var/log for kernel logs. I think fglrx may have caused a kernel panic.

    That's probably the only thing I can surmise from this.

    Comment


    • #3
      It may be that your X Server crashes without restoring your display. It should return to the console even though you can't see it, so try for example "shutdown -r now" or ssh from a different computer. You may also want to try "RSEISUB" (hold alt+sysrq while typing rseisub) if your kernel is compiled with Magic SysRq support (which, as far as I know, doesn't work after a kernel panic).

      Even is this is not the case, you'll have to post your whole Xorg.log, and check that syslog like niniendowarrior said.
      Last edited by Xipeos; 06-20-2007, 01:32 AM.

      Comment


      • #4
        here i am attaching part of my xorg log where the error occurs.. its on ubuntu 7.04 with the apt restricted fglrx drivers... and yes i hav tried ssh/telnet/ftp etc.. the computer does not respond at all and the connection times out..

        drmOpenDevice: node name is /dev/dri/card0
        drmOpenDevice: open result is -1, (No such device or address)
        drmOpenDevice: open result is -1, (No such device or address)
        drmOpenDevice: Open failed
        drmOpenDevice: node name is /dev/dri/card0
        drmOpenDevice: open result is 7, (OK)
        drmOpenDevice: node name is /dev/dri/card0
        drmOpenDevice: open result is 7, (OK)
        drmGetBusid returned ''

        please help..

        regards,

        Karthik

        Comment


        • #5
          Originally posted by karthikrg View Post
          drmOpenDevice: node name is /dev/dri/card0
          drmOpenDevice: open result is -1, (No such device or address)
          drmOpenDevice: open result is -1, (No such device or address)
          drmOpenDevice: Open failed
          drmOpenDevice: node name is /dev/dri/card0
          drmOpenDevice: open result is 7, (OK)
          drmOpenDevice: node name is /dev/dri/card0
          drmOpenDevice: open result is 7, (OK)
          drmGetBusid returned ''
          That's not an error, just DRM pooling all ports for a video card (noticed that it says OK?)

          I doubt anyone can help you unless you give more info (as before, post or check the logs yourself). Try "grep EE Xorg.log" for errors or WW for warnings (credits to lenrek).
          Last edited by Xipeos; 06-20-2007, 03:47 AM.

          Comment


          • #6
            But there is no option to attach files.. []

            I have tarred my xorg.conf as well as xorg.0.log as one file. The problem is how to send it 2 u?

            Comment


            • #7
              Originally posted by karthikrg View Post
              But there is no option to attach files.. []

              I have tarred my xorg.conf as well as xorg.0.log as one file. The problem is how to send it 2 u?
              You can paste them on something like pastebin.com and then paste the link here.

              LATER EDIT:
              Your Xorg.log kinda ends abruptly. If that's everything, then the kernel panic that niniendowarrior suggested is likely the cause. The kernel panic trace should be somewhere in /var/log
              Last edited by Xipeos; 06-20-2007, 04:20 AM.

              Comment


              • #8
                Here is the link to an attachment of the same i posted on fedora forums..

                http://www.fedoraforum.org/forum/att...chmentid=11964

                save it as a tar.gz file and open it..

                Regards,

                Karthik

                Comment


                • #9
                  http://pastebin.com/932446 --> xorg.conf
                  http://pastebin.com/932444 --> xorg.0.log

                  Links to the conf files.

                  Regards,
                  Karthik

                  Comment


                  • #10
                    I had the same problem before, I manage to solve it after reading from somewhere about how to set device section. Below is my setup:

                    Code:
                    Section "Device"
                            Identifier  "Card0"
                            Driver      "fglrx"
                            VendorName  "ATI Technologies Inc"
                            BoardName   "ATI Radeon XPRESS 200M 5955 (PCIE)"
                            Option      "DesktopSetup" "single"
                            Option      "ScreenOverlap" "0"
                            Option      "GammaCorrectionI" "0x06419064"
                            Option      "GammaCorrectionII" "0x06419064"
                    # === OpenGL specific profiles/settings ===
                            Option      "Capabilities" "0x00000000"
                            Option      "CapabilitiesEx" "0x00000000"
                    # === Video Overlay for the Xv extension ===
                            Option      "VideoOverlay" "on"
                    # === OpenGL Overlay ===
                            Option      "OpenGLOverlay" "off"
                    # === Center Mode (Laptops only) ===
                            Option      "Centermode" "off"
                    # === Pseudo Color Visuals (8-bit visuals) ===
                            Option      "PseudoColorVisuals" "off"
                    # === QBS Management ===
                            Option      "Stereo" "off"
                            Option      "StereoSyncEnable" "1"
                    # === FSAA Management ===
                            Option      "FSAAEnable" "on"
                            Option      "FSAAScale" "1"
                            Option      "FSAADisableGamma" "no"
                            Option      "FSAACustomizeMSPos" "no"
                            Option      "FSAAMSPosX0" "0.000000"
                            Option      "FSAAMSPosY0" "0.000000"
                            Option      "FSAAMSPosX1" "0.000000"
                            Option      "FSAAMSPosY1" "0.000000"
                            Option      "FSAAMSPosX2" "0.000000"
                            Option      "FSAAMSPosY2" "0.000000"
                            Option      "FSAAMSPosX3" "0.000000"
                            Option      "FSAAMSPosY3" "0.000000"
                            Option      "FSAAMSPosX4" "0.000000"
                            Option      "FSAAMSPosY4" "0.000000"
                            Option      "FSAAMSPosX5" "0.000000"
                            Option      "FSAAMSPosY5" "0.000000"
                    # === Misc Options ===
                            Option      "UseFastTLS" "2"
                            Option      "BlockSignalsOnLock" "on"
                            Option      "UseInternalAGPGART" "yes"
                            Option      "ForceGenericCPU" "no"
                            Option      "ForceMonitors" "notv"
                            Option      "TexturedVideo" "on"
                            Option      "no_accel" "no"
                            Option      "no_dri" "no"
                            BusID       "PCI:1:5:0"
                    EndSection
                    I also found from here where its setup looks almost like mine, and also reported as able to solve the hard lock issue.

                    Code:
                    Section "Device"
                       Identifier  "card0"
                       Driver      "fglrx"
                       Option       "no_accel" "no"
                       Option       "no_dri" "no"
                       Option       "DynamicClocks" "on"
                       Option       "mtrr" "on"
                       Option       "DesktopSetup" "Single"
                       Option       "ScreenOverlap" "0"
                       Option       "Capabilities" "0x00000000"
                       Option       "CapabilitiesEx" "0x00000000"
                       Option       "VideoOverlay" "on"
                       Option       "OpenGLOverlay" "off"
                       Option       "CenterMode" "off"
                       Option       "PseudoColorVisuals" "off"
                       Option       "Stereo" "off"
                       Option       "StereoSyncEnable" "1"
                       Option       "FSAAEnable" "no"
                       Option       "FSAAScale" "1"
                       Option       "FSAADisableGamma" "no"
                       Option       "FSAACustomizeMSPos" "no"
                       Option       "FSAAMSPosX0" "0.000000"
                       Option       "FSAAMSPosY0" "0.000000"
                       Option       "FSAAMSPosX1" "0.000000"
                       Option       "FSAAMSPosY1" "0.000000"
                       Option       "FSAAMSPosX2" "0.000000"
                       Option       "FSAAMSPosY2" "0.000000"
                       Option       "FSAAMSPosX3" "0.000000"
                       Option       "FSAAMSPosY3" "0.000000"
                       Option       "FSAAMSPosX4" "0.000000"
                       Option       "FSAAMSPosY4" "0.000000"
                       Option       "FSAAMSPosX5" "0.000000"
                       Option       "FSAAMSPosY5" "0.000000"
                       Option       "UseFastTLS" "0"
                       Option       "BlockSignalsOnLock" "on"
                       Option       "UseInternalAGPGART" "no"
                       Option       "ForceGenericCPU" "no"
                       Option       "KernelModuleParm" "agplock=0"
                       Option       "PowerState" "1"
                       BusID       "PCI:1:0:0"
                    EndSection
                    You may want to use both of our configurations as references, and try if they can solve your problem.

                    Good luck!
                    Last edited by lenrek; 06-20-2007, 05:25 AM.

                    Comment


                    • #11
                      Originally posted by Xipeos View Post
                      ... Try "grep EE Xorg.log" for errors or WW for warnings (credits to lenrek).
                      LOL...

                      If we do

                      Code:
                      # head -20 /var/log/Xorg.0.log
                       Window System Version 6.9.0
                      Release Date: 21 December 2005
                      X Protocol Version 11, Revision 0, Release 6.9
                      Build Operating System: Linux 2.6.18.8-smp i686 [ELF] 
                      Current Operating System: Linux virgo 2.6.22-rc4 #1 Wed Jun 6 12:09:39 SGT 2007 i686
                      Build Date: 19 April 2007
                              Before reporting problems, check http://wiki.X.Org
                              to make sure that you have the latest version.
                      Module Loader present
                      Markers: (--) probed, (**) from config file, (==) default setting,
                              (++) from command line, (!!) notice, (II) informational,
                              (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
                      (==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 20 11:50:06 2007
                      (==) Using config file: "/etc/X11/xorg.conf"
                      (==) ServerLayout "X.org Configured"
                      (**) |-->Screen "aticonfig-Screen[0]" (0)
                      (**) |   |-->Monitor "Monitor0"
                      (**) |   |-->Device "Card0"
                      (**) |-->Input Device "Mouse0"
                      The "Markers" information already stated there. I don't think I can claim credits for that...

                      Comment


                      • #12
                        Originally posted by lenrek View Post
                        I had the same problem before, I manage to solve it after reading from somewhere about how to set device section. Below is my setup
                        I see few things in both configs that would have an impact. Probably directly specifying the card port with BusID "PCI:1:5:0" fixes the problem (as the problem seems to be with libfglrxdrm - the Xorg.log ends as it's loading).

                        "Option "UseInternalAGPGART" "yes" " may be the solution if karthikrg doesn't have the agpgart module built (I doubt it though).

                        Comment


                        • #13
                          Originally posted by Xipeos View Post
                          ...

                          "Option "UseInternalAGPGART" "yes" " may be the solution if karthikrg doesn't have the agpgart module built (I doubt it though).
                          Yes, I forgot to mention. I do not use the agp module that comes with the kernel. In my experience, it seems to cause a lot of problem to me (at least for my system).

                          ETA: Just to clarify, I do build the kernel modules. However, since I enabled this option, I had assumed even though modules are load into the system, they are not being used by fglrx. However, I am using this same setup since I first successfully configured my ATI card (it was sometime around Dec2005/Jan2006). Since then, every upgrade/updates from ATI, I only update the fglrx portion, and did not change this option in xorg.conf. So, maybe now, this option no longer needed.
                          Last edited by lenrek; 06-20-2007, 08:11 AM.

                          Comment


                          • #14
                            Originally posted by Xipeos View Post
                            I see few things in both configs that would have an impact. Probably directly specifying the card port with BusID "PCI:1:5:0" fixes the problem (as the problem seems to be with libfglrxdrm - the Xorg.log ends as it's loading).

                            "Option "UseInternalAGPGART" "yes" " may be the solution if karthikrg doesn't have the agpgart module built (I doubt it though).
                            AGP gart for a PCI-E card??? I am not sure of this.. jus asking.. and yaa how to manually specify the BUS ID in xorg.conf.. pls tell me

                            Comment


                            • #15
                              Originally posted by karthikrg View Post
                              AGP gart for a PCI-E card??? I am not sure of this.. jus asking.. and yaa how to manually specify the BUS ID in xorg.conf.. pls tell me
                              Yes, I believe you still need agpgart because it handles memory allocation for 2d/3d.

                              As for the BusID, run "lspci |grep VGA" to get it. For example on my system:
                              Code:
                              # lspci |grep VGA
                              01:00.0 VGA compatible controller: ATI Technologies Inc R481 [Radeon X850XT-PE]
                              01:00:0 is the BusID. Combine it with PCI and you get BusID "PCI:1:0:0" (even if you're on AGP).

                              Comment

                              Working...
                              X