Announcement

Collapse
No announcement yet.

NVIDIA still supports TNT2 while my Radeon9000 is not supported by ATI anymore!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • NVIDIA still supports TNT2 while my Radeon9000 is not supported by ATI anymore!!

    It seems that the article talking about ati/amd linux drivers is very unfair: he says "ok, nvidia has been ahead for long time but now ati is going to get it!"
    I personally think that every user needs good drivers, and that you can not leave the people with a buggy version (8.28 for the Mobility Radeon 9000) of the drivers only to proceed faster in the competition. That's not fair. I don't care to have monthly updated drivers if they continue to have bugs and instabilities (distorted overlay on tv, buggy xgl, no aiglx, etc...).
    Nvidia demonstrates to care about linux user providing support for newer and for older card (legacy drivers) too. Few releases but good.
    I will never buy any ati card in the future.

  • #2
    Ati supports your card by releasing the specs for the gpu to the x.org project. There are open source drivers for your card

    Comment


    • #3
      Originally posted by Raven3x7 View Post
      Ati supports your card by releasing the specs for the gpu to the x.org project. There are open source drivers for your card
      This is partially true: only few specs are released and this is why xorg drivers performance are about ONE HALF of proprietary ones. Another example of bad support is that tv-out (that needs precise specs and is hard to reverse-enginering) is possible only with fglrx, as in new like as in older cards.

      Comment


      • #4
        i hope they drop support for r500 and release the specs as soon as possible

        that's the best thing that could happen :]

        tv-out is not supported on open drivers, because it employs certain signal scrambling protections or so (think Macrovision), and that could not have been described in the specs.

        Comment

        Working...
        X