No announcement yet.

AMD 8.37.6 -- The no R600 or AIGLX Support Version

  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    If you update to latest xserver-xorg-core in debian sid you can now install the 8.37.6 driver without using hacks.

    Hopefully users will be able to enjoy at least one functioning driver now, finally, after all this time of nothing.

    ATI continues to be the driver of choice for all serious masochists and fans of low quality software and development processes, and seems firmly committed to maintaining that position.


    • #52
      Originally posted by d2kx View Post
      curzondax, this is because the new OpenGL driver isn't integrated yet.
      Heh... How do you come by that info- not that it's at all wrong, mind...


      • #53
        Well. That was another useless driver release for me (and for most people).

        But hey, AMD/ATI development cycle shows that a driver version takes 11 weeks, due to testing and bla bla bla.

        I guess they have about 4 developers there:
        The first develops the "to-be-realeased" driver.
        The second developes the "next" version.
        The third pretends to test the drivers.
        And finally the fourth is on it's own on the "incredible new OpenGL driver".

        Jokes apart, I'm deeply disappointed, but I kind of expected this.

        I guess we just got confirmation that we will continue to receive monthly useless driver updates.

        By the time they implement AIGLX support, I really hope I have already updated my notebook, and I definitelly won't buy ATI anymore. I don't have any hope anymore, and I use Linux about 10 hours per day.

        I'm a developer and I really fail to understand why does it take SO LONG to solve the common problems that people have been pointing out for MONTHS already (if not years?). AIGLX can't be that hard to take months for them to start doing something. nVidia solved this problem quickly. My friend's running integrated Intel cards use AIGLX with no problems AND DECENT performance. I bet even with the ultra-slow performance of the AMD/ATI Linux OpenGL implementation, my X700 Mobility must have better performance then an Intel Integrated Video Card.

        I don't care about CCC and anisotropic/antialiasing options. Performance is bad as it is. Anti-aliasing/Aniso would just make things worse.

        Someone posted that AIGLX was useless. I don't think so. User Interface is very important.

        I'll check back when 8.53.6 is released with initial buggy betta AIGLX support...


        • #54
          ati really needs to get it together. i find it hard to believe in what is written in development cycle article.

          maybe the monthly release cycle is too frequent for linux team to actually implement *something* within the drivers.


          • #55
            Personally I find these drivers to be better than any since the 8.28.8's.. glxgears went from 125 to over 2k
            Flatout under Cedega is smoother fps dipped to 44 but hovered around 70+ for the most part, although there is still plenty of pop-ups and missing textures. PPracer was a steady 125 fps aa enabled.. I haven't tried vid playback yet..

            For me these are keepers
            Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
            Ben Franklin 1755


            • #56
              Originally posted by fanATic View Post
              You're completely right gfxdrone.ATI or AMD had enough time,don't care for merging.It's their tradition,lousy linux support.They already had their punch with detonators and this wake them up from dreams for making catalyst drivers.First of all, I don't even like name of drivers "frgl" (it reminds me of fireGL and Quadro line).Second, on their driver page, on linux driver's, Radeon X1950 (pro)is not listed, unlike on Windows tm's driver page.Again no AIGLX and,yes Michael no Xorg 7.2 support
              .I already try it.I will install FC7.Now I will sell my X1950pro and buy some nVIDIA instead (it seems now,no use of my 975XBX2 crossfire support ),maybe some 7100,7200 or something turbocache(no hypermemory warp speed) crap.At least I will have AIGLX and 3D support.I can run beryl on my noFX5200(Dawn)-64 MB card.So what is use of my powerful RV570? Only on XP,Vista? No thanks.Maybe improvement around folding@home, nice job ATi or maybe AMD, M$ is proud of you.
              And by the way nVIDIA drivers are some 13 MB's comparing to whoping 50 ATI's.So what's the problem CLI kind of driving.No problem for me.
              The fglrx driver DOES support 7.2 and the installer should work without problems. For pre 8.37.6 drivers, you just had to "export X_VERSION=x710" before running the installer (doesn't anyone read those output messages?!), but the new one detects " 7.1 or later"

              This, of course, only if you're not too lazy or incapable of departing from your distro setup tools.


              • #57
                Originally posted by Xipeos View Post
                This, of course, only if you're not too lazy or incapable of departing from your distro setup tools.
                He is talking about FC7, and it is a known problem, at least for now.



                • #58
                  Originally posted by lenrek View Post
                  He is talking about FC7, and it is a known problem, at least for now.

                  Originally posted by Michael
                  They are not X.Org related and I will explain more in the very near future
                  Then perhaps it's a kernel problem? If that's the case then you can probably use the vanilla kernel (unless it breaks some drivers/features specific to fedora).


                  • #59
                    Originally posted by Xipeos View Post
                    Then perhaps it's a kernel problem? If that's the case then you can probably use the vanilla kernel (unless it breaks some drivers/features specific to fedora).
                    Not a kernel problem.
                    Michael Larabel


                    • #60

                      truely odd behaviour of PCIE based AGP card in linux

                      Michael: Direct question for the ATI folks if you could

                      Given a working and functional setup that gets my ATI X1650Pro AGP 512Mb card up and running with opengl and fglrx drivers in xorg,
                      WHY is it that although glxgears and fgl_glxgears indicate the x1660pro card is producing 1.5 to 1.75 times the framerate of my 9600 agp card in default size, when I am playing World Of Warcraft in full screen on 1440x900 screen the x1650Pro agp card runs at about 1/2 to 1/4 the framerate of my ATI 9600 card?

                      I will note that the framerates in wow **when in small enclosed areas** or when ** looking straight up at the sky ** on the x1650Pro are 1.3 to 1.5 times faster. I am using the configuration (bios agp gart=512, video vram=256 in boot command line and xorg.conf maxgartsize=256) that works to get opengl working on the 1650pro to run the the 9600 --

                      I've got AGP 8x mode enabled on the x1650pro but somehow I get the idea that areas with lots of textures or texture work to be done are the cause of the dropoff in framerate. I am currently running the 8.37.6 drivers - and in fact have reasonable confidence in them as they have subtly improved the quality of my 2D rendered objects (my desktop fonts are clearly smoother and sharper than on 8.35, although fonts in things like Konsole and kwrite dont appear to have benefitted as much as fonts on webpages and on kicker components)

                      not that I'm whining (much) but I'm suspecting that this is a code path issue and likely fairly easy to resolve.