Announcement

Collapse
No announcement yet.

Latest 11.2 freezes my computer when display goes to sleep (Radeon HD 5830)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Latest 11.2 freezes my computer when display goes to sleep (Radeon HD 5830)

    Hello everyone,

    I've installed the latest 11.2 from ATI package (I've built .debs for Ubuntu Maverick), and when the screen goes to sleep (after the time set in gnome-power.preferences) the computer totally freezes.

    Is this happening to anyone else? It's a same because it's the first version that removes the vertical flickering while watching videos.

    Thanks in advance!

    PS: My card is a Radeon HD 5830 Mobility.

  • #2
    I've forgot to say that the "Tear Free Desktop" option is enabled.

    Comment


    • #3
      You mean 11.1 right? My desktop computer also freezes when going into hibernation sometimes, but not always. I still couldn't find what could be causing it, but disabling desktop effects might help. HD4200 here.

      Comment


      • #4
        Hi!
        A while back I had occasional freezes when waking up from suspend. That freeze actually was not complete freeze. I have learned to try to ssh to freezed box since "good and trouble-free " nvidia days So Ihave a habbit to leave ssh server opend on my laptop, which basically is rarely needed.
        It was possible to ssh and it turned out that acpid actually is the cause for freeze, Xorg froze because acpid was stuck. Nothing worked, no keyboard no nothing computer appears to be dead, but sticking network cable in worked When I killed acpid process with -9 computer woke up instantly... Everything worked again.
        Since I discovered that, I have no acpid on my system and it's not neccessary for me as well...
        My suggestion is to install ssh and when it freezes try to ssh into it and see what happens there, kill acpid and see whether it helps

        regards
        Kirurgs

        Comment


        • #5
          Damned one minute
          I tried to add: HD3650, 2.6.37 (custom), cat 11.1, x86_64

          Comment


          • #6
            @Kirurgs When I ssh into my system I actually see xorg with 100% cpu usage. Never noticed acpid though. I could swear I disabled acpid some time ago, but I'm not really sure. I'll try that tomorrow and see if it helps. Thanks for the tip.

            Comment


            • #7
              Please make sure you kill only acpid process, killall -9 acpid...
              But, I don't get xorg consuming 100% CPU with acpid stuck, that was at nvidia time and then it meant - kaput I could only shutdown system properly...
              So killing acpid might not help and you'll have to revert to last working fglrx...

              P.S. I must say that as opposite to my quadro nvidia card I had previously, I have never encountered PM problems with Radeons, whether it's clock freqs, suspend, hibernate - everything worked with every catalyst version I tried.

              Comment


              • #8
                First thing, I meant 11.1. Sorry for the mistake.

                Now, when I said "sleep" I meant the sleep in gnome-power-preferences (see attached screenshot). That's the "screen goes to black after some minutes" functionality.

                And I don't have acpid installed on my computer.

                Any ideas? Anyone with the same problem? It's a shame, because it's the first driver that seems to draw everything correctly on screen.

                Comment


                • #9
                  I'm using KDE with an intel GPU and what happens is that when the laptop's screen turns itself off (xset dpms force off maybe?) it doesn't come back up by itself. What I have to do is close the lid and open it again, and then (after the pc suspends and resumes) the scren is back again. I always thought that was due to my messing around with the acpi scripts. Any chance you got the same problem?

                  On my desktop with Radeon HD4200 I get the freezes only from time to time after resuming from hibernation. It's not all the time. I already tried killing acpid but it didn't help, just like Kirurgs predicted. The thing is I only started using hibernation recently, so I have no idea if there is even a fglrx version that works, or if it's fglrx's fault to begin with. I'll have to try the OSS drivers first.

                  Comment


                  • #10
                    Same here. I think the problem is connect to the screen being locked. Go to alt-f2 , gconf-editor, and gnome-desktop, should be an option to disable screen lock. Also make sure suspend/hiberate are checked there. After I disabled the screen lock the problem went away.

                    Comment


                    • #11
                      I also have this problem with latest 11.2 (not 11.1) drivers on Ubuntu Maverick. My laptop (Dell Studio 1558 with Mobility Radeon 5470) is configured to not do anything when the lid is closed - I am used to lock my screen and close the lid when going away, close the lid while I'm downloading something, etc.

                      Upon locking the screen (starting the screensaver) and closing the lid, after about half a minute the system fan speeds up, indicating a heavy load, and after opening the lid, the screen does not turn back on.

                      Logging in through ssh shows Xorg on 100% CPU load, and what's even more interesting, killing -9 it doesn't seem to work, I mean, the process stays and continues to steal one CPU core. Only a reboot restores the system back to normal.

                      Tweaks with acpid, atieventsd and similar things didn't have any effect. I had to downgrade to 10.12, which is a pity, because 11.x's tearfree option works like a charm (finally!).

                      Maverick has somewhat broken power management overall, so maybe that's not entirely the drivers' fault. Anyway, I hope that 11.3 and/or Natty will finally bring really good, tear- and bugfree graphics experience to Ubuntu users with ATI/AMD cards.

                      Comment


                      • #12
                        I've narrowed down the problem in my laptop. Disabling screensaver seems to fix this problem. Id don't know whos culprit (fglrx, screensaver or power management), but this used to work until 11.1, and now doesn't.

                        So now I have to lock the screen myself using Ctrl+Alt+L.

                        Hope this is fixed sometime.

                        Comment


                        • #13
                          Originally posted by infinito View Post
                          Id don't know whos culprit (fglrx, screensaver or power management)
                          If you are running Compiz (OpenGL compositing manager), then you have to add it to your list. I'm running Natty with Classic Desktop on my box and Compiz crashes often. This on Xorg Radeon drivers.

                          And the screensaver is acting weird, like taking 30 to 60 seconds to react when I move the mouse or pressing a key. The display immediately turns on, but I have a black screen with working mouse pointer... And when the screensaver exits, I'll have to minimize and restore the active program in order to get working menus.

                          Comment


                          • #14
                            Originally posted by Smask View Post
                            If you are running Compiz (OpenGL compositing manager), then you have to add it to your list. I'm running Natty with Classic Desktop on my box and Compiz crashes often. This on Xorg Radeon drivers.

                            And the screensaver is acting weird, like taking 30 to 60 seconds to react when I move the mouse or pressing a key. The display immediately turns on, but I have a black screen with working mouse pointer... And when the screensaver exits, I'll have to minimize and restore the active program in order to get working menus.
                            Yep, I've forgot about Compiz. Will try later to see if disabling it fixes the problem...

                            Comment


                            • #15
                              I had the same problem. After gnome-screensaver startet, Xorg used 100% of CPU. I just uninstalled gnome-screensaver and replaced it with xscreensaver - did not have a hang since that.

                              I read the same in other threads. Also the ubuntu wiki has a note about gnome-screensaver and new fglrx version.

                              http://wiki.ubuntuusers.de/Grafikkar...roblembehebung

                              Just found a german version, where this was written.

                              Comment

                              Working...
                              X