Announcement

Collapse
No announcement yet.

Cannot disable randr in Ubuntu Maverick

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot disable randr in Ubuntu Maverick

    Code:
    sudo aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"
    After X restart:

    Code:
    aticonfig --query-monitor
    Error: option --query-monitor is not supported when RandR 1.2 is enabled!
    The option is still in /etc/ati/amdpcsdb file even after reboot, but aticonfig still complains about RandR 1.2:
    Code:
    [AMDPCSROOT/SYSTEM/DDX]
    OGLFMTA2R10G10B10Enable=V1
    DisableLoadBalancing=V1
    DisablePassiveStereo=V0
    RequestMSI=STRUE
    EnableRandR12=SFALSE
    [AMDPCSROOT/SYSTEM/DDX/RECENTMODE]
    EnableRestore=V1
    Xorg.0.log randr messages:
    Code:
    [    16.124] (**) Option "RandR" "off"
    [    16.391] (II) fglrx(0): RandR 1.2 support is enabled!
    [    16.391] (II) fglrx(0): RandR 1.2 rotation support is enabled!
    [    16.628] (WW) fglrx(0): Option "EnableRandR12" is not used
    [    16.628] (II) fglrx(0): Disabling in-server RandR and enabling in-driver RandR 1.2.
    [    16.649] (II) fglrx(0): User Preference Output DFP2 using refresh rate 60.0 Hz.
    [    16.836] (--) RandR disabled
    [    16.836] (II) Initializing built-in extension RANDR
    [    17.067] (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments
    Drivers were installed via this ppa:
    https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

    edit: seems like I am not the only one with this problem http://ubuntu-ky.ubuntuforums.org/sh....php?t=1642449
    Last edited by Not so pretty now; 12-26-2010, 10:28 AM. Reason: found more info

  • #2
    But why do you want to disable it? It is very useful - can't use the built in gnome monitor settings without it.
    Just asking. No idea how to fix your problem. Sorry.

    Comment


    • #3
      Maybe you need something like disable ... true?

      Comment


      • #4
        Originally posted by Mr James View Post
        But why do you want to disable it? It is very useful - can't use the built in gnome monitor settings without it.
        Just asking. No idea how to fix your problem. Sorry.
        Warsow r_mode function is broken. I want to use 1280x960 resolution, but it defaults to 1280x1024. So only way I can have my 1280x960 r_mode is if I disable 1280x1024.

        Comment


        • #5
          Did you take a look at your "/etc/X11/xorg.conf" file?

          It might have some "interesting" lines (Randr-related) that might need to be removed, even if you explicetely disabled Randr1.2 with aticonfig... (in the past, it happened for me when I plugged my HD2600 to a multimedia projector or a secondary LCD monitor).

          Cheers

          Comment


          • #6
            my xorg.conf:

            Code:
            Section "ServerLayout"
            	Identifier     "amdcccle Layout"
            	Screen      0  "amdcccle-Screen[1]-0" 0 0
            EndSection
            
            Section "ServerFlags"
            #	Option	    "Xinerama" "off"
            #	Option	    "RandR" "off"
            EndSection
            
            Section "Module"
            	Load  "glx"
            EndSection
            
            Section "Monitor"
            	Identifier   "0-DFP2"
            	Option	    "VendorName" "ATI Proprietary Driver"
            	Option	    "ModelName" "Generic Autodetecting Monitor"
            	Option	    "DPMS" "true"
            	Option	    "PreferredMode" "1920x1080"
            	Option	    "TargetRefresh" "60"
            	Option	    "Position" "0 0"
            	Option	    "Rotate" "normal"
            	Option	    "Disable" "false"
            EndSection
            
            Section "Device"
            	Identifier  "amdcccle-Device[1]-0"
            	Driver      "fglrx"
            	Option	    "Monitor-DFP2" "0-DFP2"
            	BusID       "PCI:1:0:0"
            #       Option      "EnableRandR12" "false"
            EndSection
            
            Section "Screen"
            	Identifier "amdcccle-Screen[1]-0"
            	Device     "amdcccle-Device[1]-0"
            	DefaultDepth     24
            	SubSection "Display"
            		Viewport   0 0
            		Depth     24
                            Modes    "1920x1080" "1280x960" "800x600" "960x540" "640x480"
            	EndSubSection
            EndSection

            Comment


            • #7
              You seem to have all Randr / Multi-Monitor related lines commented... Try to uncomment them... Then restart your Xorg server.
              If there's a problem and you can't get your monitor(s) to work remove your xorg.conf file and do a "aticonfig --initial" (in another words, "reset" your xorg.conf file)... (both operations using sudo, OC )

              Cheers

              Comment


              • #8
                Read my first post, they were commented out for a reason:

                Code:
                [    16.124] (**) Option "RandR" "off"
                [    16.391] (II) fglrx(0): RandR 1.2 support is enabled!
                [    16.391] (II) fglrx(0): RandR 1.2 rotation support is enabled!
                [    16.628] (WW) fglrx(0): Option "EnableRandR12" is not used
                [    16.628] (II) fglrx(0): Disabling in-server RandR and enabling in-driver RandR 1.2.

                Comment


                • #9
                  Yep, looking at what you've got there it seems Catalyst is forcing RandR in-driver...
                  That's really an odd thing... normally, fglrx auto-generates a RandR config only if you've booted your computer with a secondary monitor plugged...
                  But I still think your xorg.conf seems to not be OK... It has the RandR-disable lines commented, which shouldn't happen, btw...
                  Otherwise, try like I said: do a "sudo aticonfig --initial" and restart Xorg (your RandR configured file will be auto-saved by the aticonfig command ).

                  Cheers

                  Comment


                  • #10
                    You still didn't get it -- all randr stuff was added by me and commented out because none of it had no effect.

                    Comment

                    Working...
                    X