Announcement

Collapse
No announcement yet.

Help me with Radeon X1650 please?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help me with Radeon X1650 please?

    Ok, so my video card is quite old and there's probably no support left for it. I downloaded the drivers from the ATI site and tried to install them I got an error after it extracted the files and started to install.

    It may seem like I'm asking alot but could anybody help me by explaining step by step how to get the drivers installed, I don't know how to uninstall the old drivers, which is probably the problem in the first place, I didn't install the drivers they were default with Ubuntu 10.10.

    I'm a newb to Linux so I have pretty well no idea what I'm doing, I've found the terminal which I assume is like Windows CMD/DOS.

  • #2
    Your GFX card is supported, just not with the drivers you can download from AMD's website if you run Ubuntu 10.10.

    The last Catalyst version for your X1650 is 9.3
    In any version of Ubuntu released after that (i.e. from 9.04), your video card will run on the opensource driver. So any news related to the "r500" opensource driver will be of interest to you.

    If you downloaded the drivers from AMD's website, either you got 9.3 with is incompatible with your version of Ubuntu, or you downloaded e.g. 10.11 with is incompatible with your card.

    Actually, Ubuntu should automatically prompt you to install Catalyst if it detects a compatible video card.

    Hope that clear things up!

    Comment


    • #3
      Well I tested out WoW with Wine, it was really bad, a lot of the models would load and despawn over and over. And I haven't been able to see any of the fancy 3D features of the GUI besides the jelly like windows an when I go to youtube any video I play no mater the resolution it's really laggy.

      Comment


      • #4
        I don't mean to dubble post, sorry, but where can I find this "r500" driver and instructions on how to install it?

        Comment


        • #5
          Simple: You don't download it It ships with Ubuntu and the OS will pick it up at boot time.

          As for your rendering issues:
          - Out of the box, Ubuntu doesn't give much in the way of playing around with the desktop effects options. If you want more fancy stuff such as the famous cube, you'll need to download the Compiz Settings Manager from the software center. If you get the wobbly windows from the start, that at least means the drivers are working.

          - That said, usually "Desktop effects on + Wine = pain". Start with that. Also check the AppDB entry for WoW on WINE's website for aditional tips.

          - Regarding your Flash issues I'm not sure really, sorry.

          Comment


          • #6
            Thank you so much for all your help, I have found a tip for running WoW, I haven't got to try it out quite yet but I will give it a go.

            Comment


            • #7
              Anytime! Just take it slow A lot will seem very confusing at first.

              Comment


              • #8
                Originally posted by Reaver76 View Post
                Thank you so much for all your help, I have found a tip for running WoW, I haven't got to try it out quite yet but I will give it a go.
                Here is a good start:
                https://help.ubuntu.com/community/WorldofWarcraft
                Configuration, troubleshooting, tweaking...

                ...but to be honest, I doubt, you will be able to get playable fps. 3D performance of the radeon driver is quiet behind fglrx.
                If you still have Windows installed, you should boot it up for gaming...

                Comment


                • #9
                  Originally posted by bongmaster2
                  dont forget to activate xorg-edgers ppa and check with glxinfo wheter ur using the gallium3d driver.then check if color tiling hyperz pageflip etc is enbaled.
                  that will improve performance
                  i think for all that features kernel 2.6.37 is required

                  means kernel+edgers

                  Comment


                  • #10
                    Originally posted by PsynoKhi0 View Post
                    So any news related to the "r500" opensource driver will be of interest to you.
                    Well no one seems to have catched my blooper, dunno if it's a good or bad thing
                    The driver is called "r300" ("radeon" being a wrapper) but runs on your X1650 with belongs to the R500-series of GPU. Hope I got it right now :P

                    Comment

                    Working...
                    X