Announcement

Collapse
No announcement yet.

GlakkeClock - ATI GPU Utility

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Things should be working better now.
    I have two executables available with a few tweaks:
    x64 (FAN_PERCENT tweak)
    http://dl.dropbox.com/u/2053182/Glak....26.02_PERCENT

    x64 (FAN_RPM tweak)
    http://dl.dropbox.com/u/2053182/Glak...0.10.26.02_RPM

    Please try:
    --get-info --device 0 --adapter 0
    and
    --get-info --device 0 --adapter 1

    On both executables, hopefully it'll work correctly on both.

    Comment


    • #12
      Seems to be the RPM reading...
      Code:
      $ ./glakkeclock_x86_64_0.10.26.02_PERCENT --get-info --device 0 --adapter 0
      Device Name: ATI Radeon HD 5700 Series
      UDID: 768:26808:4098:5252:5963
      Number: 0
      Adapters: 4
      Current Performance Level: 0
      Performance levels: 3
      GPU (MHz): 400 [200-960]
      Memory (MHz): 1200 [600-1445]
      VDDC Volt (mV): 1000 [950-1125]
      Temperature (C): 42
      Fan Speed (RPM): 30 (-2147483648%) [0-0]
      GPU Activity (%): 0
      Current Bus Lanes: 16/16
      Current Bus Speed: 5000
      Code:
      $ ./glakkeclock_x86_64_0.10.26.02_PERCENT --get-info --device 0 --adapter 1
      Device Name: ATI Radeon HD 5700 Series
      UDID: 768:26808:4098:5252:5963
      Number: 0
      Adapters: 4
      Current Performance Level: 0
      Performance levels: 3
      GPU (MHz): 400 [200-960]
      Memory (MHz): 1200 [600-1445]
      VDDC Volt (mV): 1000 [950-1125]
      Temperature (C): 42
      Fan Speed (RPM): 30 (-2147483648%) [0-0]
      GPU Activity (%): 7
      Current Bus Lanes: 16/16
      Current Bus Speed: 5000
      Code:
      $ ./glakkeclock_x86_64_0.10.26.02_RPM --get-info --device 0 --adapter 0
      Function not supported by the driver.
      Error: ADL_Overdrive5_FanSpeed_Get
      Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Function not supported by the driver.
      Error: ADL_Overdrive5_FanSpeed_Get
      Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Function not supported by the driver.
      Error: ADL_Overdrive5_FanSpeed_Get
      Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Function not supported by the driver.
      Error: ADL_Overdrive5_FanSpeed_Get
      Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Device Name: ATI Radeon HD 5700 Series
      UDID: 768:26808:4098:5252:5963
      Number: 0
      Adapters: 4
      Current Performance Level: 0
      Performance levels: 3
      GPU (MHz): 400 [200-960]
      Memory (MHz): 1200 [600-1445]
      VDDC Volt (mV): 1000 [950-1125]
      Temperature (C): 42
      Fan Speed (RPM): 0 (-2147483648%) [0-0]
      GPU Activity (%): 0
      Current Bus Lanes: 16/16
      Current Bus Speed: 5000
      Code:
      $ ./glakkeclock_x86_64_0.10.26.02_RPM --get-info --device 0 --adapter 1
      Function not supported by the driver.
      Error: ADL_Overdrive5_FanSpeed_Get
      Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Function not supported by the driver.
      Error: ADL_Overdrive5_FanSpeed_Get
      Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Function not supported by the driver.
      Error: ADL_Overdrive5_FanSpeed_Get
      Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Function not supported by the driver.
      Error: ADL_Overdrive5_FanSpeed_Get
      Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
      Device Name: ATI Radeon HD 5700 Series
      UDID: 768:26808:4098:5252:5963
      Number: 0
      Adapters: 4
      Current Performance Level: 0
      Performance levels: 3
      GPU (MHz): 400 [200-960]
      Memory (MHz): 1200 [600-1445]
      VDDC Volt (mV): 1000 [950-1125]
      Temperature (C): 42
      Fan Speed (RPM): 0 (-2147483648%) [0-0]
      GPU Activity (%): 0
      Current Bus Lanes: 16/16
      Current Bus Speed: 5000
      I did not exactly understand what you are trying to find out querying different adapters, my Card says it has 4 of them, three are connected but the output remains the same for 3 and 4 also.

      Comment


      • #13
        Wanted to make sure that different adapters on the same card didn't return different information. And the good thing is that on your card I can see when it fails to read RPM (Function not supported by the driver.), and just switch to percent reading.

        But on my card RPM works, but when using percent it just gives me screwed up values, but ADL library doesn't give me any errors.

        I'll soon upload a version which should work better.

        Comment


        • #14
          This version:
          - cerr changed to cout, can now use ./glakkeclock --get-version > output.log, to log Errors as well.
          - Should now recognize if the GPU supports RPM or PERCENT, and use the correct one. Getting PERCENT should always work, but might have a slight offset when used with RPM reading.

          So all I need here is --get-info.

          x64
          http://dl.dropbox.com/u/2053182/Glak..._64_0.10.27.17

          Comment


          • #15
            Mh, no more error massages, but fan speed reading is still MIN_INT...
            Code:
            $ ./glakkeclock_x86_64_0.10.27.17 --get-info
            Version: 0.10.27.17
            Device Name: ATI Radeon HD 5700 Series
            UDID: 768:26808:4098:5252:5963
            Number: 0
            Adapters: 4
            Current Performance Level: 0
            Performance levels: 3
            GPU (MHz): 400 [200-960]
            Memory (MHz): 1200 [600-1445]
            VDDC Volt (mV): 1000 [950-1125]
            Temperature (C): 42
            Fan type: RPM
            Fan Speed (RPM): 0 (-2147483648%) [0-0] (-2147483648-100)
            GPU Activity (%): 0
            Current Bus Lanes: 16/16
            Current Bus Speed: 5000
            Code:
            $ ./glakkeclock_x86_64_0.10.27.17 --get-version > output.log
            $ cat output.log 
            Version: 0.10.27.17
            My hair is a bird. Your argument is invalid: --get-version
            See --help

            Comment


            • #16
              Originally posted by nerval View Post
              Mh, no more error massages, but fan speed reading is still MIN_INT...
              Thanks, I found the problem, was a problem with my error checking.
              Internally there are errors while getting the fan speed, but these should be correctly handled, and from the errors choose the fan type.

              I've added so that errors are back, and the program will output how these are handled. It should be working now.

              x64
              http://dl.dropbox.com/u/2053182/Glak..._64_0.10.29.13

              Comment


              • #17
                Seems fine to me...

                Code:
                $ ./glakkeclock_x86_64_0.10.29.13 --get-info
                Testing RPM..
                Error: Function not supported by the driver.
                Error: ADL_Overdrive5_FanSpeed_Get
                Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
                Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
                RPM did not work, trying PERCENT..
                Using PERCENT.
                Testing RPM..
                Error: Function not supported by the driver.
                Error: ADL_Overdrive5_FanSpeed_Get
                Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
                Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
                RPM did not work, trying PERCENT..
                Using PERCENT.
                Testing RPM..
                Error: Function not supported by the driver.
                Error: ADL_Overdrive5_FanSpeed_Get
                Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
                Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
                RPM did not work, trying PERCENT..
                Using PERCENT.
                Testing RPM..
                Error: Function not supported by the driver.
                Error: ADL_Overdrive5_FanSpeed_Get
                Error: iSpeedType Input: ADL_DL_FANCTRL_SPEED_TYPE_RPM
                Error: iSpeedType Output: ADL_DL_FANCTRL_SPEED_TYPE_RPM
                RPM did not work, trying PERCENT..
                Using PERCENT.
                GlakkeClock - ATI/AMD GPU Utility. Version: 0.10.29.13
                By Andr��e 'Glaucous' Ekroth, 2010
                Device Name: ATI Radeon HD 5700 Series
                UDID: 768:26808:4098:5252:5963
                Number: 0
                Adapters: 4
                Current Performance Level: 0
                Performance levels: 3
                GPU (MHz): 400 [200-960]
                Memory (MHz): 1200 [600-1445]
                VDDC Volt (mV): 1000 [950-1125]
                Temperature (C): 40
                Fan type: PERCENT
                Fan Speed (%): 30 (0-100)
                GPU Activity (%): 0
                Current Bus Lanes: 16/16
                Current Bus Speed: 5000

                Comment


                • #18
                  Originally posted by nerval View Post
                  Seems fine to me...
                  Yes it all seems fine now. Everything else is working good for me at least, so I doubt I need testing on changing clocks, but I'd be happy if you tried them out with safe numbers (i.e. one MHz up or down).
                  --set-clocks-gpu 401
                  --set-clocks-mem 1201
                  --set-clocks-vddc 1001
                  And finish with --get-info.
                  Reset:
                  --set-clocks-default or --set-all-default.

                  Do this only if you feel comfortable clocking, and realizing that this is an unfinished software. But with my testing it's working fine, and the rest is pretty much up to the AMD/ATI drivers.

                  What I also need testing is fan speed changing. The problem here is that there are two approaches, setting with RPM or PERCENT. RPM doesn't seem to work well on my card (which uses RPM reading). I'm pretty sure that there aren't many cards that support changing with RPM.

                  Percent:
                  --set-fan 0-100
                  And to reset:
                  --set-fan-default or --set-all-default.

                  Here's a version without the fan errors and so on. Note that previous version doesn't work with fan speed changing.
                  x64
                  http://dl.dropbox.com/u/2053182/Glak..._64_0.10.29.20

                  Comment


                  • #19
                    Ok, tried all the parameters you mention, everything is working (double-checked with aticonfig) as it should with one exception:

                    Code:
                    $ ./glakkeclock_x86_64_0.10.29.20 --set-clocks-gpu 961
                    GlakkeClock - ATI/AMD GPU Utility. Version: 0.10.29.20
                    By Andr��e 'Glaucous' Ekroth, 2010
                    Error: Generic Error. Most likely one or more of the Escape calls to the driver failed!
                    Error: ADL_Overdrive5_ODPerformanceLevels_Set
                    Error: Generic Error. Most likely one or more of the Escape calls to the driver failed!
                    Error: ADL_Overdrive5_ODPerformanceLevels_Set
                    Error: Generic Error. Most likely one or more of the Escape calls to the driver failed!
                    Error: ADL_Overdrive5_ODPerformanceLevels_Set
                    Error: Generic Error. Most likely one or more of the Escape calls to the driver failed!
                    Error: ADL_Overdrive5_ODPerformanceLevels_Set
                    (The cards limit is 960, it would be really great if we could bypass that...)

                    Would love to see a panel applet version of this tool...

                    Comment


                    • #20
                      Originally posted by nerval View Post
                      (The cards limit is 960, it would be really great if we could bypass that...)

                      Would love to see a panel applet version of this tool...
                      Yes I'd like to be able to bypass the limits as well. Multiple programs (such as ATI Tray Tools) on Windows are able to bypass the limits, but I'm not sure which library they use.

                      A gnome panel applet? Sure I guess that would be possible. Right now I have a concept of how a Qt GUI would look like, and that - using a system tray icon as well - would perhaps be pretty much the same as a gnome panel applet? A Qt GUI would be especially nice since it'll work on more distributions.

                      Comment

                      Working...
                      X