Announcement

Collapse
No announcement yet.

AMD Catalyst 10.10 For Linux Officially Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Catalyst 10.10 For Linux Officially Released

    Phoronix: AMD Catalyst 10.10 For Linux Officially Released

    While users of Ubuntu 10.10 "Maverick Meerkat" have had access to an early release of the Catalyst 10.10 Linux driver that AMD had sent over to Canonical in advance in order to provide X.Org Server 1.9 support, the rest of the Linux-using public now finally has access to the official Catalyst 10.10 build. Those that have already used Catalyst 10.10 in the Ubuntu Maverick release have been rather excited for its changes...

    http://www.phoronix.com/vr.php?view=ODcwNA

  • #2
    Installation went without a hitch. This does not resolve the "Catalyst Control Center" Information bug:

    http://ubuntuforums.org/showthread.p...4#post10002704

    I "think" this bug is purely cosmetic.

    Frank

    Comment


    • #3
      Originally posted by russofris View Post
      Installation went without a hitch. This does not resolve the "Catalyst Control Center" Information bug:

      http://ubuntuforums.org/showthread.p...4#post10002704

      I "think" this bug is purely cosmetic.

      Frank
      From a similar issue (can't really call it a problem) this is just some leftover files (in /etc/ati) from a previous driver version that do nothing more than report a version number.
      To fix this, remove driver, empty out /etc/ati (or wherever ubuntu puts it) and install driver. Should be all good after that.

      Comment


      • #4
        Originally posted by russofris View Post
        Installation went without a hitch. This does not resolve the "Catalyst Control Center" Information bug:
        I "think" this bug is purely cosmetic.
        AFAIK if the 2D driver and openGL versions are correct everything is fine.

        Comment


        • #5
          @mirv

          you dont remove the driver, you stop kdm/gdm or whatever then you can delete the file without .default ending in /etc/ati and then you start kdm/gdm again.

          Comment


          • #6
            This driver doesn't seem to work on Kubuntu 10.10:

            Code:
            sudo ./ati-driver-installer-10-10-x86.x86_64.run --buildpkg Ubuntu/maverick
            This leaves a few *.deb packages. Installed all of them. Rebooted. Nothing happens; the system is still running the "radeon" driver.

            What's wrong?

            Comment


            • #7
              Originally posted by Kano View Post
              @mirv

              you dont remove the driver, you stop kdm/gdm or whatever then you can delete the file without .default ending in /etc/ati and then you start kdm/gdm again.
              Ah, a better way, cheers!

              Comment


              • #8
                Originally posted by RealNC View Post
                This leaves a few *.deb packages. Installed all of them. Rebooted. Nothing happens; the system is still running the "radeon" driver. What's wrong?
                Did you run aticonfig --initial -f

                Comment


                • #9
                  Kaffeine interlace bug persists

                  This driver works very well for me with Ubuntu 10.10 and an integrated HD4290. No black box issues, no workarounds.

                  The kaffeine interlace bug still exists, so avoid pressing "I" when Kaffeine is running.

                  Comment


                  • #10
                    I am running latest kernel 2.6.36.

                    ATI driver does not compile.

                    > cd /lib/modules/fglrx/build_mod
                    > ./make.sh


                    CC [M] /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
                    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
                    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
                    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:410: error: unknown field ‘ioctl’ specified in initializer
                    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:410: warning: initialization from incompatible pointer type
                    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_MapPageToPfn’:
                    /lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1636: warning: unused variable ‘bus_addr’
                    CC [M] /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
                    make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
                    make[2]: *** Waiting for unfinished jobs....
                    /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.c:51: warning: ‘struct tty_struct’ declared inside parameter list
                    /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.c:51: warning: its scope is only this definition or declaration, which is probably not what you want
                    /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.c:60: warning: ‘struct tty_struct’ declared inside parameter list
                    /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.c:67: warning: initialization from incompatible pointer type
                    /lib/modules/fglrx/build_mod/2.6.x/kcl_debug.c:74: warning: initialization from incompatible pointer type

                    Any clue?

                    Comment

                    Working...
                    X