Announcement

Collapse
No announcement yet.

How do I install Catalyst for Ubuntu 10.04 64-bit?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do I install Catalyst for Ubuntu 10.04 64-bit?

    Hi everybody. I just got a new laptop with an ATI Mobility 5650. I want to install the catalyst drivers but I'm having trouble. I tried installing the drivers from the restricted hardware drivers pop up, but when I rebooted, my screen was blank. What is the best way to install Catalyst, and if something goes wrong, how do I remove it without having to reinstall Ubuntu?

    Thanks for all the help.

    PS: I think I read two different ways of installing the drivers, but I can't find it. One was using some kind of script and another was installing the drivers provided by Ubuntu and then installing the official ATI drivers in that directory.

  • #2
    When you already tried installing fglrx it should have blacklisted the radeon module already, but i would still recommend using -z option and then reboot. the cleanest way is

    login into vt1 (ctrl+alt+f1)

    wget -N http://kanotix.com/files/install-fglrx-debian.sh
    sudo /etc/init.d/gdm stop
    [in case of kubuntu:]
    sudo /etc/init.d/kdm stop
    sudo rm -f /etc/X11/xorg.conf*
    sudo sh install-fglrx-debian.sh -z
    sudo reboot

    In theory it works with -z option even inside X, but then amdcccle can report a wrong version when fglrx was installed before. in that case you would not stop gdm/kdm and use a DISPLAY= override.

    Comment


    • #3
      I should mention that I completely reinstalled Ubuntu after getting a blank screen.

      So to follow your instructions, I should have already tried installing using the proprietary drivers? If I get an error saying that fglrx was installed before I login into vt1 and use the Display=override command?

      Sorry, I'm really new at installing drivers and stuff. I really appreciate your help.

      Comment


      • #4
        EDIT: There's something wrong. I can't get into xterm with ctrl alt f1 and I can't boot into recovery mode. This prevents my from using the script, so unless I can some how find a way to get into xterm, it looks like I can't use the ATI drivers. Thanks anyways for the help.

        Comment


        • #5
          thats the 2nd way:

          wget -N http://kanotix.com/files/install-fglrx-debian.sh
          DISPLAY= sudo sh install-fglrx-debian.sh -z

          then reboot.

          Comment


          • #6
            Ok, I ran the script and most things seemed to work well. I now have the ATI Catalyst link in my menu, but when I try and launch it I get this message:

            "There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

            No ATI graphics driver is installed, or the ATI driver is not functioning properly.
            Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig."

            I ran the script, rebooted, and then got a blank screen. So I had to use a live cd to delete the xorg.conf file.

            Comment


            • #7
              EDIT: Ok, I re-ran the script again and then rebooted. I got a blank screen again, so I used the "nomodeset" option in Grub2 and received a couple errors:

              (EE) fglrx(0): Please disable switchable-graphics feature and configure the discrete card as the default adapter
              (EE) fglrx (0): GetBiosParamter failed
              (EE) fglrx (0): PreInitAdapter failed
              (EE) fglrx (0): PreInit failed
              (EE) Screen (s) found, but none have a usable configuration.

              Comment


              • #8
                You can switch to the other BusID using

                sed -i /BusID/s/head/tail/ install-fglrx-debian.sh

                in my script or disable one card in the bios completely. Of course you can manully change the /etc/X11/xorg.conf too, the output can be guessed by

                lspci -nn

                Comment


                • #9
                  Ok, I was able to successfully switch the BusID. However, I still get a blank screen. Here's the log file:

                  The following error was encountered you may need to update your configuration to solve this.
                  (EE) Problem parsing the config file
                  (EE) Error parsing the config file

                  Data incomplete in file /etc/X11/xorg.conf
                  Undefined Screen "aticonfig-Screen[0]-0" referred by ServerLayout "aticonfig Layout"

                  Fatal server error:
                  no screens found

                  (WW) xf86CLoseConsole:KDSETMODE failed: Bad file description
                  (WW) xf86CLoseConsole:VT_GETMODE failed: Bad file description
                  (WW) xf86CLoseConsole:VT_GETSTATE failed: Bad file description

                  Will posting the xorg.conf file help?

                  Thanks for all the help again!

                  Comment


                  • #10
                    sudo rm -f /etc/X11/xorg.conf
                    sudo aticonfig --initial --nobackup

                    does that work? without any hacks...

                    Comment


                    • #11
                      I deleted the config files, ran the command, and restarted but I still got a blank screen. So I booted using "nomodeset" in GRUB2 and got the same error as earlier:

                      "(EE) fglrx(0): Please disable switchable-graphics feature and configure the discrete card as the default adapter
                      (EE) fglrx (0): GetBiosParamter failed
                      (EE) fglrx (0): PreInitAdapter failed
                      (EE) fglrx (0): PreInit failed
                      (EE) Screen (s) found, but none have a usable configuration. "

                      Using the low graphics mode, I was able to restore the default configuration and successfully boot. Compiz doesn't work and Catalyst Control Center doesn't start. Here's the error:

                      "Initialization Error

                      There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

                      No ATI graphics driver is installed, or the ATI driver is not functioning properly.
                      Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig."

                      Here is the working xorg.conf file:

                      "Section "Device"
                      Identifier "Configured Video Device"
                      Driver "vesa"
                      EndSection

                      Section "Monitor"
                      Identifier "Configured Monitor"
                      EndSection

                      Section "Screen"
                      Identifier "Default Screen"
                      Monitor "Configured Monitor"
                      Device "Configured Video Device"
                      EndSection"

                      and the modified one:

                      "Section "ServerLayout"
                      Identifier "aticonfig Layout"
                      Screen 0 "aticonfig-Screen[0]-0" 0 0
                      EndSection

                      Section "Module"
                      EndSection

                      Section "Monitor"
                      Identifier "aticonfig-Monitor[0]-0"
                      Option "VendorName" "ATI Proprietary Driver"
                      Option "ModelName" "Generic Autodetecting Monitor"
                      Option "DPMS" "true"
                      EndSection

                      Section "Device"
                      Identifier "aticonfig-Device[0]-0"
                      Driver "fglrx"
                      BusID "PCI:1:0:0"
                      EndSection

                      Section "Screen"
                      Identifier "aticonfig-Screen[0]-0"
                      Device "aticonfig-Device[0]-0"
                      Monitor "aticonfig-Monitor[0]-0"
                      DefaultDepth 24
                      SubSection "Display"
                      Viewport 0 0
                      Depth 24
                      EndSubSection
                      EndSection"

                      Do you think that simply changing the driver in the working config file from "vesa" to "fglrx" will work?

                      Comment


                      • #12
                        fglrx: black screen of death

                        Originally posted by Sup3r3g0 View Post
                        I deleted the config files, ran the command, and restarted but I still got a blank screen. So I booted using "nomodeset" in GRUB2 and got the same error as earlier:

                        "(EE) fglrx(0): Please disable switchable-graphics feature and configure the discrete card as the default adapter
                        (EE) fglrx (0): GetBiosParamter failed
                        (EE) fglrx (0): PreInitAdapter failed
                        (EE) fglrx (0): PreInit failed
                        (EE) Screen (s) found, but none have a usable configuration. "

                        Using the low graphics mode, I was able to restore the default configuration and successfully boot. Compiz doesn't work and Catalyst Control Center doesn't start. Here's the error:

                        "Initialization Error

                        There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.

                        No ATI graphics driver is installed, or the ATI driver is not functioning properly.
                        Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig."

                        Here is the working xorg.conf file:

                        Code:
                        ...
                        Do you think that simply changing the driver in the working config file from "vesa" to "fglrx" will work?
                        I have a very similar problem: can't get fglrx to work because I always get into a blank screen. I'm unsuccessful trying to install fglrx since Catalyst 10.3, on my new HP Pavilion DV-4 2080BR.

                        The problem in my case, and maybe yours, is that the Intel Core CPU (i3/i5/i7) have integrated graphics, and since I bought a notebook model that also have discrete ATI GPU, in a way that I have 2 GPUs at same computer, with the infamous 'switchable' option.

                        The bad thing is that Linux kernel is just starting to support switchable graphics, and worst, Xorg totally don't support it.

                        Be best (fast) solution would be to disable the switchable thing at BIOS, enabling only the ATI GPU. But to my bad luck, that's not an option to me, because there is no HP notebook with BIOS option about switchable graphics.

                        So fglrx detects something that it don't understand, and, so, I get the black screen thing.

                        I e-mailed HP asking them for a new BIOS version to disable Intel integrated GPU, so I would get only the ATI GPU detected by my favorite OS.
                        HP replied saying something that seems to be wrote by a bad-programed-robot, with all nonsense phrases, just copying and pasting my own words from the initial message.
                        So I replied their response asking for someone that understand what BIOS is. Some days later, a guy e-mailed me, he said that HP will not release a new version of BIOS, and if HP does, it will not contain the switch-off integrated graphics feature. dot.

                        The good thing is that I still can have hardware accelerated graphics from the i5's GPU. Intel have much better linux driver support than ATI. My KDE works beauty with all those transparency and animations.
                        Sad that I paid/waist $500 more on this notebook model just because of the ATI GPU and I can't use it.

                        I will have better luck on the next buying, keeping away from HP and ATI. Maybe a Dell with Ubuntu.

                        Comment


                        • #13
                          Typical ATI. You might want to follow this thread in the Ubuntu forums in case there's any updates on the problem:

                          http://ubuntuforums.org/showthread.php?t=1504816

                          Comment


                          • #14
                            Originally posted by Panix View Post
                            Typical ATI. You might want to follow this thread in the Ubuntu forums in case there's any updates on the problem:

                            http://ubuntuforums.org/showthread.php?t=1504816
                            Typical Panix response blaming ATI for something thats clearly HP's fault.
                            One that they seems disinterested in fixing at that.
                            Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
                            Ben Franklin 1755

                            Comment


                            • #15
                              If I'm wrong, fine. I just assumed it worked in Windows.

                              http://www.phoronix.com/scan.php?pag...item&px=Nzk0OQ

                              Is this useful to the problem?:

                              http://linux-hybrid-graphics.blogspo...nd-atiati.html

                              Comment

                              Working...
                              X