Announcement

Collapse
No announcement yet.

Video reproduction isn't good with ATI Catalyst drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Video reproduction isn't good with ATI Catalyst drivers

    Hi everyone.
    I'm an Italian user (therefore sorry if my English is bad) who uses Kubuntu 10.04 with an ATI Radeon HD 4650.

    Before I used open source driver and video reproduction went well.
    The only problem was that this driver causes high temperature and the fan speed was too high on my notebook.
    In fact, since I've installed proprietary driver I haven't this issue, so temperature is normal and fan speed is like on Windows 7.

    But unfortunately proprietary driver is buggy and I can't reproduce video well. Has someone the same problem?
    Is there a solution?

    Please, help me. Fell free to ask whichever information about my system.

  • #2
    Make sure you select GLX video output(xcb) from the video settings drop down box.
    Open the Catalyst Control Center and under 3D>more settings make sure
    vertical refresh is set to Quality-always on.

    I have little to no tearing using VLC,Mplayer,XBMC,Dragon Player,Fluendo DVD Player that way..can't comment about other player since I don't use'em or have them installed.
    Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
    Ben Franklin 1755

    Comment


    • #3
      First of all, thanks for answering...

      I've just set GLX as video output in VLC and "always-on" to vertical refresh. It's better than before, I see tearing artifacts, but they seldom occurs...this happens when I have composition turned on.
      Without it, I haven't tearing problems in video reproduction, so the problem seems to be resolved.
      Result: videos works well without composition.

      But, really, I'm very disappointed with these proprietary drivers.
      I also have some other bugs, for instance this.
      Then, I see with Catalyst's that CPU usage is about 60% for the 1st core and 30% for the second. With open source driver and framebuffer output from VLC I had about 40% for the 1st, 20% for the 2nd and I could reproduce videos in a decent way with composition turned on!

      At this point, it's better fan speed too high with open source driver.
      Tomorrow I'm going to uninstall Catalyst.
      Result2: Catalyst sucks...

      Comment


      • #4
        First of all, thanks for answering...

        I've just set GLX as video output in VLC and "always-on" to vertical refresh. It's better than before, I see tearing artifacts, but they seldom occurs...this happens when I have composition turned on.
        Without it, I haven't tearing problems in video reproduction, so the problem seems to be resolved.
        Result: videos works well without composition.

        But, really, I'm very disappointed with these proprietary drivers.
        I also have some other bugs, for instance this.
        Then, I see with Catalyst's that CPU usage is about 60% for the 1st core and 30% for the second. With open source driver and framebuffer output from VLC I had about 40% for the 1st, 20% for the 2nd and I could reproduce videos in a decent way with composition turned on!

        At this point, it's better fan speed too high with open source driver.
        Tomorrow I'm going to uninstall Catalyst.
        Result2: Catalyst su**s...

        Comment


        • #5
          - Try mplayer -vo gl2
          - Try the open drivers with kernel 2.6.35 or later. You can lower the fan speed by typing "echo low > /sys/class/drm/card0/device/power_profile"

          Comment


          • #6
            Originally posted by pingufunkybeat View Post
            - Try mplayer -vo gl2
            I use VLC only.

            Originally posted by pingufunkybeat View Post
            - Try the open drivers with kernel 2.6.35 or later. You can lower the fan speed by typing "echo low > /sys/class/drm/card0/device/power_profile"
            I already have 2.6.35 kernel. What does this command do?
            After giving it, I had:
            Code:
            bash: /sys/class/drm/card0/device/power_profile: Permesso negato
            Access denied, also from root.

            However, It seems that power saving isn't supported for my card, so fan speed is high. Here I find the following options:
            Option "DynamicPM" "on"
            Option "ClockGating" "on"
            From log I should have:
            Code:
                   (**) RADEON(0): Option "ClockGating" "on"
                   (**) RADEON(0): Option "DynamicPM" "on"
            But I have:
            Code:
            (WW) RADEON(0): Option "DynamicPM" is not used
            (WW) RADEON(0): Option "ClockGating" is not used
            Have you any other ideas, or I have to surrender?

            Comment


            • #7
              If tearing happens only with compositing, you can try to enable unredirect of full screen windows. That way, if the player is in fullscreen mode at least there should be no tearing.

              Comment


              • #8
                Originally posted by chithanh View Post
                If tearing happens only with compositing, you can try to enable unredirect of full screen windows. That way, if the player is in fullscreen mode at least there should be no tearing.
                I came back to open source driver. Now, I want only find something which power saving works with my graphic card.

                Comment


                • #9
                  Originally posted by Digitalone View Post
                  I use VLC only.
                  That was a suggestion for debugging, you can set VLC to use GL output too.

                  I already have 2.6.35 kernel. What does this command do?
                  After giving it, I had:
                  Code:
                  bash: /sys/class/drm/card0/device/power_profile: Permesso negato
                  Access denied, also from root.
                  Does the file "power_profile" exist in /sys/class/drm/card0/device/?

                  It should, with the kernel. All the power-saving is in the kernel now, the xorg options and X messages don't matter.

                  There are two power-saving modes in the kernel - dynamic pm and profiles. Dynamic pm reclocks dynamically and should offer maximum powersaving, but it sometimes flickers because the reclocking timings are not perfect yet. The profiles allow you to manually choose a higher or lower power-states. The low power state is sufficient for almost all desktop activities, and will reduce your temperature considerably. That's what the command does.

                  What does this return:

                  Code:
                  cat /sys/class/drm/card0/device/power_method

                  Comment


                  • #10
                    Originally posted by pingufunkybeat View Post
                    Does the file "power_profile" exist in /sys/class/drm/card0/device/?
                    Yes, it does.

                    Originally posted by pingufunkybeat View Post
                    There are two power-saving modes in the kernel - dynamic pm and profiles. Dynamic pm reclocks dynamically and should offer maximum powersaving, but it sometimes flickers because the reclocking timings are not perfect yet. The profiles allow you to manually choose a higher or lower power-states. The low power state is sufficient for almost all desktop activities, and will reduce your temperature considerably. That's what the command does.
                    Ok, but the command returns "access denied". Can you understand why?

                    Originally posted by pingufunkybeat View Post
                    What does this return:
                    Code:
                    cat /sys/class/drm/card0/device/power_method
                    It returns:
                    Code:
                    profile

                    Comment


                    • #11
                      Make sure that you are running it as root. It MUST work, the file is there.

                      Try

                      Code:
                      sudo  "echo low > /sys/class/drm/card0/device/power_profile"
                      with the quotes at exactly these places.

                      Comment


                      • #12
                        You can also use:

                        Code:
                        sudo "echo dynpm > /sys/class/drm/card0/device/power_method"
                        to switch to the dynamic powersaving. It works OK, but it sometimes flickers when changing powermodes. echo "profile" again to switch back to the profile method.

                        Comment


                        • #13
                          Originally posted by Digitalone View Post
                          I use VLC only.

                          I already have 2.6.35 kernel. What does this command do?
                          After giving it, I had:
                          Code:
                          bash: /sys/class/drm/card0/device/power_profile: Permesso negato
                          Access denied, also from root.

                          However, It seems that power saving isn't supported for my card, so fan speed is high. Here I find the following options:


                          From log I should have:
                          Code:
                                 (**) RADEON(0): Option "ClockGating" "on"
                                 (**) RADEON(0): Option "DynamicPM" "on"
                          But I have:
                          Code:
                          (WW) RADEON(0): Option "DynamicPM" is not used
                          (WW) RADEON(0): Option "ClockGating" is not used
                          Have you any other ideas, or I have to surrender?

                          With this said, this thread belongs in the open source forum.


                          anyways, which version of vlc do you use? I don't have any problems with video quality on vlc and linux. However, i'm using the proprietary driver.

                          Comment


                          • #14
                            Thanks, I've resolved.

                            The command was:
                            Code:
                            sudo bash -c "echo low > /sys/class/drm/card0/device/power_profile"
                            With open source driver I had a little of tearing, but I've resolved adding
                            Code:
                            	Option     "AccelMethod" "EXA"
                            	Option     "EXAVSync" "yes"
                            in my xorg.conf.

                            Thanks again.

                            Comment


                            • #15
                              Originally posted by DarkFoss View Post
                              Make sure you select GLX video output(xcb) from the video settings drop down box.
                              Open the Catalyst Control Center and under 3D>more settings make sure
                              vertical refresh is set to Quality-always on.

                              I have little to no tearing using VLC,Mplayer,XBMC,Dragon Player,Fluendo DVD Player that way..can't comment about other player since I don't use'em or have them installed.
                              Thanks for this information DarkFoss. This has improved my experience of Catalyst!

                              Comment

                              Working...
                              X