Announcement

Collapse
No announcement yet.

Video reproduction isn't good with ATI Catalyst drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Make sure that you are running it as root. It MUST work, the file is there.

    Try

    Code:
    sudo  "echo low > /sys/class/drm/card0/device/power_profile"
    with the quotes at exactly these places.

    Comment


    • #12
      You can also use:

      Code:
      sudo "echo dynpm > /sys/class/drm/card0/device/power_method"
      to switch to the dynamic powersaving. It works OK, but it sometimes flickers when changing powermodes. echo "profile" again to switch back to the profile method.

      Comment


      • #13
        Originally posted by Digitalone View Post
        I use VLC only.

        I already have 2.6.35 kernel. What does this command do?
        After giving it, I had:
        Code:
        bash: /sys/class/drm/card0/device/power_profile: Permesso negato
        Access denied, also from root.

        However, It seems that power saving isn't supported for my card, so fan speed is high. Here I find the following options:


        From log I should have:
        Code:
               (**) RADEON(0): Option "ClockGating" "on"
               (**) RADEON(0): Option "DynamicPM" "on"
        But I have:
        Code:
        (WW) RADEON(0): Option "DynamicPM" is not used
        (WW) RADEON(0): Option "ClockGating" is not used
        Have you any other ideas, or I have to surrender?

        With this said, this thread belongs in the open source forum.


        anyways, which version of vlc do you use? I don't have any problems with video quality on vlc and linux. However, i'm using the proprietary driver.

        Comment


        • #14
          Thanks, I've resolved.

          The command was:
          Code:
          sudo bash -c "echo low > /sys/class/drm/card0/device/power_profile"
          With open source driver I had a little of tearing, but I've resolved adding
          Code:
          	Option     "AccelMethod" "EXA"
          	Option     "EXAVSync" "yes"
          in my xorg.conf.

          Thanks again.

          Comment


          • #15
            Originally posted by DarkFoss View Post
            Make sure you select GLX video output(xcb) from the video settings drop down box.
            Open the Catalyst Control Center and under 3D>more settings make sure
            vertical refresh is set to Quality-always on.

            I have little to no tearing using VLC,Mplayer,XBMC,Dragon Player,Fluendo DVD Player that way..can't comment about other player since I don't use'em or have them installed.
            Thanks for this information DarkFoss. This has improved my experience of Catalyst!

            Comment


            • #16
              Originally posted by expectATIon View Post
              Thanks for this information DarkFoss. This has improved my experience of Catalyst!
              ++

              haven't tested it yet but thanks for the advice !

              Comment


              • #17
                your both welcome

                As an aside if your using the kde 4.5 desktop you may want to enable
                Desktop effects and under the advanced tab check the dierct rendering box and the use Vsync box too..is seems to cut down on the black screen stuff with the fglrx driver but not eliminate it in Firefox Chromium and Thunderbird.

                There is one more setting under Application Appearence>style>Fine tuning tab.. Graphical effects there are several options to pick from for my desktop @1920x1080.. I use High Display Low CPU The results can be quite dramatic on your overall responsiveness... no idea what setting would be best for a laptop.
                I suggest playing with them and finding whats best for your set-up.
                Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
                Ben Franklin 1755

                Comment

                Working...
                X