Announcement

Collapse
No announcement yet.

ATI R800 linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI R800 linux

    can anyone help me with installing the r800 driver for linux (i have a sapphire 5830 card) on ubuntu (lucid ofc)

  • #2
    Ok, first off, when you boot linux on lucid because of the r800 series graphics, you will need to boot with the parameter xforcevesa because the dri included in Ubuntu 10.04 (Lucid) does not properly support the hd 5000 series cards. However, ubuntu 10.04 will work perfectly once you finish installing the closed source drivers.

    now as for the process of installing the driver, you will need to use xforcevesa until you get the ati driver installed. There is two methods involving the ati driver installation. One method is to use the Unofficial ATI Linux driver wiki - Ubuntu 10.04 (lucid) Installation Guide

    and the other is to try the "Ubuntu X" team ppa to make keeping up to date easier... Ubuntu x-swat ppa

    Comment


    • #3
      Originally posted by Dandel View Post
      Ok, first off, when you boot linux on lucid because of the r800 series graphics, you will need to boot with the parameter xforcevesa because the dri included in Ubuntu 10.04 (Lucid) does not properly support the hd 5000 series cards. However, ubuntu 10.04 will work perfectly once you finish installing the closed source drivers.

      now as for the process of installing the driver, you will need to use xforcevesa until you get the ati driver installed. There is two methods involving the ati driver installation. One method is to use the Unofficial ATI Linux driver wiki - Ubuntu 10.04 (lucid) Installation Guide

      and the other is to try the "Ubuntu X" team ppa to make keeping up to date easier... Ubuntu x-swat ppa
      what about Debian...?

      did Galium3D or Mesa made something similar?

      Comment


      • #4
        Originally posted by Dandel View Post
        Ok, first off, when you boot linux on lucid because of the r800 series graphics, you will need to boot with the parameter xforcevesa because the dri included in Ubuntu 10.04 (Lucid) does not properly support the hd 5000 series cards. However, ubuntu 10.04 will work perfectly once you finish installing the closed source drivers.

        now as for the process of installing the driver, you will need to use xforcevesa until you get the ati driver installed. There is two methods involving the ati driver installation. One method is to use the Unofficial ATI Linux driver wiki - Ubuntu 10.04 (lucid) Installation Guide

        and the other is to try the "Ubuntu X" team ppa to make keeping up to date easier... Ubuntu x-swat ppa
        i run 10.10 and i think 10.10 do have better support for r800 cards..

        why not use 10.10 ? its a dev version yes but this isn't *satan'

        Comment


        • #5
          Still can't use an Evergreen card in Linux?

          Wow, such great ATI support (in Linux)!

          Can't use the binary drivers or the open source. Ubuntu 10.04? Nope. So much for the connections with Ubuntu... anyway, maybe in Catalyst ver. 11, they'll be supported...maybe the open source driver will work in 2015.

          Comment


          • #6
            Originally posted by Panix View Post
            Still can't use an Evergreen card in Linux?
            Uh? It works fine with the Catalyst driver, just install it.

            Comment


            • #7
              Originally posted by Agdr View Post
              Uh? It works fine with the Catalyst driver, just install it.
              NOOOOO!!!

              it works teribly i cant see no difrence between without and with the catalyst :O

              and yes i did installed the 2.6.34.1 kernel

              Comment


              • #8
                Originally posted by Panix View Post
                Still can't use an Evergreen card in Linux?

                Wow, such great ATI support (in Linux)!

                Can't use the binary drivers or the open source. Ubuntu 10.04? Nope. So much for the connections with Ubuntu... anyway, maybe in Catalyst ver. 11, they'll be supported...maybe the open source driver will work in 2015.
                how ironically it may be but i think your right in some way

                it would take a very long time with this kind of developing to get a fully functionally driver :S

                Comment


                • #9
                  Originally posted by Panix View Post
                  Still can't use an Evergreen card in Linux?

                  Wow, such great ATI support (in Linux)!

                  Can't use the binary drivers or the open source. Ubuntu 10.04? Nope. So much for the connections with Ubuntu... anyway, maybe in Catalyst ver. 11, they'll be supported...maybe the open source driver will work in 2015.
                  maybe you 'panix' is the second accound of kano ;-)

                  right now i'm here with the opensource driver because catalyst is a madhouse right now.. but i think 10-8 will be better (yes yes yes i'm a liar yes yes yes no comment please )

                  bridgman wrote in my threat about the R800 mesa 3d driver Q3 is the release date means next month.

                  and then the madhouse'catalyst' is obsoleted for R800 users.

                  Comment


                  • #10
                    Originally posted by Auroraa9420 View Post
                    NOOOOO!!!

                    it works teribly i cant see no difrence between without and with the catalyst :O
                    You should probably describe what the problem is exactly and report it in the fglrx bug tracker if you are sure it's a driver bug.

                    Also check that you are actually using the driver; if 3D is slow, perhaps it's using software rendering due to the driver not being installed properly.

                    Comment


                    • #11
                      Originally posted by Qaridarium View Post
                      maybe you 'panix' is the second accound of kano ;-)

                      right now i'm here with the opensource driver because catalyst is a madhouse right now.. but i think 10-8 will be better (yes yes yes i'm a liar yes yes yes no comment please )

                      bridgman wrote in my threat about the R800 mesa 3d driver Q3 is the release date means next month.

                      and then the madhouse'catalyst' is obsoleted for R800 users.
                      It sounds like it's best to just use the ATI/AMD website for the driver download but then you need all these tweaking and compiling? However, the binary driver isn't adequate anyway?

                      How's the open source driver (state) then with Evergreen cards? I guess you're restricted to a certain distro version, too?

                      And no, this isn't Kano. ;-) Kano's more specific with complaints?

                      P.S. The Nvidia Fermi have some more choices and the 460 is price competitive with 5770 and if some mid-grade cards get released, wanna bet they'll be supported and working before the Evergreen cards are optimized?

                      Comment


                      • #12
                        Originally posted by Panix View Post
                        It sounds like it's best to just use the ATI/AMD website for the driver download but then you need all these tweaking and compiling? However, the binary driver isn't adequate anyway?

                        How's the open source driver (state) then with Evergreen cards? I guess you're restricted to a certain distro version, too?

                        And no, this isn't Kano. ;-) Kano's more specific with complaints?

                        P.S. The Nvidia Fermi have some more choices and the 460 is price competitive with 5770 and if some mid-grade cards get released, wanna bet they'll be supported and working before the Evergreen cards are optimized?
                        kano just waste his time by buying his blueray's

                        bridgman talk something about a release in august for the mesa r800 3D part.

                        what do you mean with tweaking and compiling??? in my point of view the catalyst isn't ready for ubuntu 10.10 right now.

                        but on 10.04 you can install it and use it yes there are known bugs i thik they try to fix this in 10-8

                        i really don't understand you in the nvidia point if you don't wana a amd card get an intel gpu thats much better than nvidia!

                        nvidia is just the lame-duck.

                        Comment


                        • #13
                          can any one tell me how to properly install the catalist driver without that out of range

                          because it is terible...i have the 2.6.35-14-generic kernel (withch i think it made my graphic probem even worse) and tell me how to fix it (i know how it should be installed :P)

                          Comment


                          • #14
                            Originally posted by Auroraa9420 View Post
                            can any one tell me how to properly install the catalist driver without that out of range

                            because it is terible...i have the 2.6.35-14-generic kernel (withch i think it made my graphic probem even worse) and tell me how to fix it (i know how it should be installed :P)
                            2.6.35 ? do you use ubuntu 10.10 ?

                            catalyst do not support 10.10 anylonger because of xserver1.9

                            catalyst only can handle 1.8

                            Comment


                            • #15
                              Originally posted by Auroraa9420 View Post
                              can any one tell me how to properly install the catalist driver without that out of range

                              because it is terible...i have the 2.6.35-14-generic kernel (withch i think it made my graphic probem even worse) and tell me how to fix it (i know how it should be installed :P)
                              What's the exact issue? It's unlikely that someone will be able to help if you don't specify it precisely...

                              If it does not compile, add "#include <linux/slab.h>" to the file that doesn't compile (I think it is kcl_wait.h).

                              You might indeed need to use the X server from Lucid if using Maverick.
                              In that case, just add Lucid too to the apt sources, and either use "/lucid" on the apt-get command-line, or add package pins to /etc/apt/preferences.

                              Alternatively, use a supported released distribution.

                              Also try aticonfig --initial to setup a clean xorg.conf.

                              10.6 seems to work better than 10.7 (haven't tried the 10.7 update linked from the OpenCL SDK).

                              Comment

                              Working...
                              X