Announcement

Collapse
No announcement yet.

Catalyst driver causing hang on shutdown

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst driver causing hang on shutdown

    I've posted this issue in the Arch Linux forums and seem to have everyone there stumped.

    It appears that something about fglrx is causing my system to hang when shutting down. Its all the way to "Power off" and then freezes. I ran some tests.

    If I modprobe fglrx and try to shutdown without ever running an X server, it shuts down okay.

    If I modprobe fglrx, run an X server, kill the X server and rmmod fglrx, the hang still occurs when I try to power down.

    If I only run an X server on the vesa driver, everything works fine on shutdown.

    Restarts of the computer always work fine -- it is only shutdowns that cause the hang.

    I've looked through the logs and nothing seems to be different in them between a restart and shutdown. I believe the the hang may be occurring after logging has already stopped.

    Running on Mobility Radeon 5830 (HP Envy 15 laptop Core i5) with Catalyst 10.7 -- Arch Linux x64, kernel 2.6.34. Any ideas?

  • #2
    So, no ideas as to what could cause this? I can't figure out why this only seems to be happening to me.

    Comment


    • #3
      I have an idea, try slightly older kernels, it might be a problem that was introduced in a newer revision of the kernel.

      Comment


      • #4
        I'll give it a shot, though this has been going on since I purchased and first installed Linux on this laptop at kernel 2.6.32 in late March.

        Comment


        • #5
          I have the same problem. I've been using openSUSE 11.2 with Catalyst 10.5, 10.6, and 10.7. I tried with openSUSE 11.3 with the same Catalyst versions and get the same hangups during shutdown or rebooting. I can't remember what the outcome was for earlier versions of Catalyst or openSUSE. Would use the non prorietary drivers but two monitor in extended desktop mode doesn't work. I haven't tried the modprobe trick but will give it a try and see if that works for me. I have ATI 4870 x2 with Intel i7.

          Comment


          • #6
            Originally posted by infinidhi View Post
            I have the same problem. I've been using openSUSE 11.2 with Catalyst 10.5, 10.6, and 10.7. I tried with openSUSE 11.3 with the same Catalyst versions and get the same hangups during shutdown or rebooting. I can't remember what the outcome was for earlier versions of Catalyst or openSUSE. Would use the non prorietary drivers but two monitor in extended desktop mode doesn't work. I haven't tried the modprobe trick but will give it a try and see if that works for me. I have ATI 4870 x2 with Intel i7.
            The modprobing I did was more for trying to trace what the problem was, than finding a workaround (which I didn't, other than to not use catalyst). Bascially it allowed me to identify that having the X server run on the fglrx driver was the root cause of my hang. Your hang may be different, so you can give it a shot though.

            Comment


            • #7
              My issue was finally resloved with a BIOS update.

              Comment

              Working...
              X