Announcement

Collapse
No announcement yet.

Catalyst 10.7 and Eyefinity

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Well im running Catalyst 10.7 with a new amdpcsdb and a clean xorg.conf so this must be distro specific.

    Have also created a bug entry here: http://ati.cchtml.com/show_bug.cgi?id=1864

    Comment


    • #12
      How can I tell if eyefinity is working? The only ati card I have right now is a 5670. On windows I tried creating a display group across two monitors to verify that eyefinity worked that way. Under linux I did not see an option to create a group anywhere.

      What I did was create a single desktop with two monitors and that activated both of them but xdpyinfo showed that xinerama was active however randr seemed to be still actived also which on nvidia gets disabled if xinerama is active. Composite also showed as active in xdpyinfo but xinerama should disable that normally, however the kde compositing stuff kept disabling whenever I turned it on.

      Mostly if I can get this working and verify it is working for two monitors on a 5670 card I plan to get an eyefinity 6 card to replace my dual 8800 GTS cards in my main machine.

      Comment


      • #13
        Eyefinity is about using 3 displays or more.. not 2.

        There is nothing more to Eyefinity than that..

        Comment


        • #14
          Eyefinity is about using 3 displays or more without xinerama and the system shows that xinerama is still active in Xdpyinfo. So I wanted to know how to find out if it is really working. That way I have a good idea if an eyefinity 6 card will work for me to run 4 monitors.

          Comment


          • #15
            run aticonfig --xinerama=off and restart X

            it should be disabled after that

            Comment


            • #16
              I have now tested everything I can think of to enable Eyefinity under RHEL 5.5 and have yet to get an answer if this should even work on RHEL 5.5.

              Big desktop on two screens and trying to add a third in CCC is impossible as it is listed as "Disabled display"

              Running in single desktop mode with xinerama lets me add both screens and I can even choose to add the third screen left or right of the two others. But doing so requires a reboot and when restarted screen 1 reverts to 640x480 screen 2 runs at native res (1920x1200) and the third goes to standby. Booting always display on DV1 and Displayport connected screen.

              This can't have been tested on this "Supported" Distro...

              Comment


              • #17
                Originally posted by bridgman View Post
                What did you use for aticonfig parameters ?
                I have tried
                aticonfig --initial -f (and then setting up all screens in CCC)

                aticonfig --initial --heads=3 --adapter=1 (no change)

                and also
                aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"

                and
                aticonfig --set-pcs-str="DDX,EnableRandR12,TRUE"

                No luck...

                Comment


                • #18
                  Originally posted by Fluggo View Post
                  I have now tested everything I can think of to enable Eyefinity under RHEL 5.5 and have yet to get an answer if this should even work on RHEL 5.5.

                  ...

                  This can't have been tested on this "Supported" Distro...

                  Perhaps tweet this dude about it? http://twitter.com/CatalystMaker
                  Sounds like he is involved in making the Catalyst driver.

                  Comment


                  • #19
                    Well I dont have a twitter account but I managed to get a response from ATI customer support on my question about eyefinity and rotation support on RHEL 5.5:

                    At the present time, no this is not supported, support will be introduced with a future driver, but until it is officially released there is no way to confirm when this will happen.

                    In order to update this service request, please respond, leaving the service request reference intact.

                    Best regards,

                    AMD Global Customer Care
                    A confirmation from Bridgman is more than welcome on this Really hope this is true and that it will be fixed soon enough. I must say that im really impressed that AMD answered this question in just 10 hours..

                    Comment


                    • #20
                      Well, I did a little test it works on the 5800 , but it does not work on my 5450. Using same config. It appears to me that cards with dsub do not work, yet...

                      Comment

                      Working...
                      X