Announcement

Collapse
No announcement yet.

How The ATI Catalyst Driver Has Matured Since The RV770 Launch

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    What card did you get, mugginz?

    I object to Q's assertion that you're buying based on the future. Unless he's the 2nd coming of Nostradamus, I'm not sure you can assess what will be supported, what will work etc. etc. You can try to predict or more accurately, ANTICIPATE what the state of things will be but that's all.

    Even if ATI/AMD is reporting A or B will work, that doesn't guarantee... it's just a framework. The other problem with 'buying based on future guarantees' is that you are waiting for X amount of time that you may or may not know the waiting period. Also, you have a card that is not working 100% or is not optimized despite the hardware potential or attributes of said card.

    I still don't see AMD/ATI illustrating any type of priority or dedication towards Linux. It's not changed much from, say, a year ago. Regressions in the benchmarks or tests confirm this. I don't care what resolution they used. The other problem that people keep shrugging off is the number of complaints or posts of their difficulties with their card and the drivers. It seems the drivers are difficult to deal with. There's artifacts, tearing, black screens etc. etc. and it seems like it's difficult to solve or work on. I'm not sure if recent Nvidia cards and drivers deliver such complications but given the number of posts both here and in specific-distro forums (e.g. Ubuntu Forums), one can only assume that there's still major problems that need to be dealt with. There needs to be a priority to address these instead of the constant focus on Windows.

    Comment


    • #17
      Originally posted by Panix View Post
      What card did you get, mugginz?
      You'll never guess.

      Comment


      • #18
        Originally posted by mugginz View Post
        You'll never guess.

        Comment


        • #19


          I bought a 5870. I hope I don't regret it.

          I'll be running it through it's paces and will have a full report of what I find.

          Comment


          • #20
            Originally posted by mugginz View Post
            I bought a 5870. I hope I don't regret it.

            I'll be running it through it's paces and will have a full report of what I find.
            I hope you don't either. I'll be reading your report.

            I don't think I'd go higher than a 5770... although I think a 5850 is the best overall buy for the money but that's just my opinion. But, I don't have that kind of money for a card right now, unfortunately. I'm stuck building a budget system right now that became necessary out of the blue.

            'Hope your card works out for you... I would like to change my mind on my perspective still... always have.

            Comment


            • #21
              Originally posted by Panix View Post
              ... although I think a 5850 is the best overall buy for the money but that's just my opinion.
              I agree. The 5850 is great value... if it works


              Originally posted by Panix View Post
              'Hope your card works out for you... I would like to change my mind on my perspective still... always have.
              I hope I can provide a good indication of what you can expect with an ATI card and whether or not you should buy one.

              Comment


              • #22
                Sadly it would seem that fglrx is indeed full of fail.

                Comment


                • #23
                  I'm a 5850 owner on Catalyst 10.6. Sadly, it's not the best buy. Suffering from tearing when dragging around windows. Have a horizontal tear on my secondary screen when movement starts occurring (playing video etc...).

                  If I had a chance to buy a graphics card again, I would buy a nVidia. If I had a chance to buy only an ATI card, I'd buy an old card that the open source drivers support.

                  Comment


                  • #24
                    thats why i use opensource drivers for radeons, its ok imho, yea 3d is kind slow in some games via vine, but they are good in normal use [not gaming]

                    Comment


                    • #25
                      ATI 5870 on Ubuntu 10.04, The Saga Begins.

                      • Boot system while the nVidia 9800GT is installed.
                      • Downlod the ATI 10.6 fglrx driver.
                      • Removed its driver.
                      • Rebooted to confirm it's thoughorly removed.
                      • Shutdown the system.
                      • Removed the 9800GT and installed the 5870.
                      • Power on the system
                      • Machine boots to GDM and then onto the desktop using the open drivers with no problems.
                      • Launch a shell.
                      • Execute the fglrx installer.
                      • Its GUI is displayed.
                      • I select build packages and follow the prompts.
                      • The environment is correctly identified as Ubuntu/Lucid.
                      • Says it built the package but it doesn't actually build them.
                      • I exit the GUI.
                      • It then autostarts the installer in text mode in the shell I launched it from for some reason.
                      • I go through it again just for laughs.
                      • It crashes due to a double free. WTF?
                      • I look at the log. It says there's no dpkg-buildpackage so I install dpkg-dev and try again.
                      • This time the installer does something but still fails.
                      • Installer log says it needs the dh command.
                      • I install debhelper and try again.
                      • Fails again due to not having execstack available.
                      • I install execstack and try again.
                      • This time it builds the packages.
                      • I install the packages. They install without issue.
                      • I remove the old xorg.conf and execute '/usr/bin/aticonfig --initial -f'.

                      And here it gets interesting.
                      I'm presented with this wonderful output:

                      Code:
                      mugginz@mugginz-desktop:~/Downloads/fglrx$ sudo /usr/lib/fglrx/bin/aticonfig --initial -f
                      Unable to open /etc/ati/control, please reinstall the driver.
                      /usr/lib/fglrx/bin/aticonfig: No supported adapters detected
                      lspci -v provides this output:

                      Code:
                      01:00.1 Audio device: ATI Technologies Inc Cypress HDMI Audio [Radeon HD 5800 Series]
                      	Subsystem: Giga-byte Technology Device aa50
                      	Flags: bus master, fast devsel, latency 0, IRQ 17
                      	Memory at e5020000 (64-bit, non-prefetchable) [size=16K]
                      	Capabilities: <access denied>
                      	Kernel driver in use: HDA Intel
                      	Kernel modules: snd-hda-intel
                      At this stage I wonder if I've got a card that fglrx doesn't have PCI ids for.

                      Comment


                      • #26
                        ATI 5870 on Ubuntu 10.04, The Saga Continues.

                        On further investigation, the packages built by the installer are full of fail. Note to others, be wary of that path.
                        • Just for laughs I decide to remove the built packages, reboot and re-run the installer but this time I choose to install the drivers directly from the installer.
                        • This succeeds.
                        • I run '/usr/bin/aticonfig --initial -f' and this time it succeeds as well.
                        • I reboot and get to a desktop with cloned displays. (Both screens display the same image)
                        • I run 'gksudo amdcccle' and configure the system for one desktop accross two displays.

                        After a restart I'm presented with one screen correctly displayed and one screen which is black. The mouse pointer happily moves onto and around that screen and back to the other one but when dragging a window onto it it is not displayed. This 'black screen' issue is not unheard of unfortunately.

                        • After various bits of mucking around I shut down the system,
                        • install another hard drive,
                        • do a clean install,
                        • install all available updates,
                        • reboot,
                        • Install the distro provided 10.5 drivers,
                        • reboot,
                        • configure the display for one desktop accross two screens,
                        • Log out, and back in.
                        • I'm presented with what I'm after.

                        At this stage, with the 10.5 drivers the system displays the well known slow maximise behaviour but other than that during this very short bit of the test no other bad behaviour is encountered. I should stress though that I didn't spend much time in this environment.

                        After satisfying myself that the hardware is able to provide this dual screen functionality that I'm after, at least with the 10.5 drivers, I'm a bit happier.
                        • I remove the 10.5 drivers,
                        • reboot,
                        • install the 10.6 drivers,
                        • reboot,

                        After the system successfully boots to the cloned desktop with the 10.6 drivers I configure the system for one desktop accross two screens.
                        After a reboot for thoughourness I'm presented with a desktop with one desktop accross two screens. Just what I'm after.
                        Compiz is functional and fast.

                        At this stage I'm even happier and now decide to correct my original install on the SSD.

                        Comment


                        • #27
                          ATI 5870 on Ubuntu 10.04, Finally success.

                          • I shut down the system and remove the HDD,
                          • install the SSD, configure the machine to boot from it,
                          • boot to my original desktop
                          • am again presented with the black screen issue.

                          I re-install the 10.6 drivers and muck around a bit, fight some with amdcccle and then after a few reboots I'm presented with a correctly behaving one desktop accross two monitors configuration within my original system installation.
                          • I now enable vsync.
                          • I make sure compiz is configured to use vsync.

                          At this stage I can confirm that vsync for multi-monitor configurations is indeed broken in 10.6
                          I'm unable to get the system to vsync. Not for the desktop, and not for GL ouput of video from player. I was aware that this would be likely from previous posters. It's a problem that afflicts multi-monitor configurations with 10.6 but not with single screen configs.

                          vsynced video was not a problem from these screens on the 9800GT. That lack of vsync is one issue I'm prepared to live with for a short while. I hope it's fixed in 10.7 or 10.8.

                          The slow maximise behaviour is no longer here. A win for 10.6

                          The random black bits in windows is however here. Again, I'm prepared to live with this for a while as I was aware that it was happening to others.

                          So a bit of a summary.

                          Aside from the random black window and vsync issues I'm currently satisfied with the outcome. I was prepared for some breakage though and a new Linux user may not be so forgiving of these issues as I am.

                          One thing I will say though is that this card is really, really, really fast. Stupidly fast in fact.

                          It was able to roughly double the frame rate of the 9800GT for the Unigine Heaven Demo. That is, the demo was running in a window (@1024x768) on a composited desktop on one screen, while the other screen was playing a full screen video stream, it doubled the 9800GT unredirected full screen @ 1024x768 doing only this frame rate.


                          More on performance to come.

                          Comment


                          • #28
                            Originally posted by emergence View Post
                            If I had a chance to buy a graphics card again, I would buy a nVidia. If I had a chance to buy only an ATI card, I'd buy an old card that the open source drivers support.
                            If I didn't need to run three screens I to would've bought an nVidia card. I now need to acquire an active DP to DVI adapter to light up the third screen. Hopefully it works well.

                            Comment


                            • #29
                              Originally posted by mugginz View Post
                              ATI 5870 on Ubuntu 10.04, The Saga Begins.

                              [LIST][*]Boot system while the nVidia 9800GT is installed.[*]Downlod the ATI 10.6 fglrx driver.[*]Removed its driver.[*]Rebooted to confirm it's thoughorly removed.[*]Shutdown the system.[*]Removed the 9800GT and installed the 5870.
                              in my point of view you should to an fresh install of ubuntu.

                              because i think cloused source drivers damange the linux system and this is not a nvidia only problem the catalyst 10-4/10-5/10-6 can not handle (normal install no .debs) the install and remove functions of ubuntu 10.04
                              to be clear you tainted your linux by installing a cloused source driver.

                              i think catalyst 10-7 is the first one without 'tainted' the ubuntu 10.04 system.

                              Comment


                              • #30
                                Originally posted by mugginz View Post
                                [U][SIZE="4"][*]Machine boots to GDM and then onto the desktop using the open drivers with no problems.[*]Launch a shell.[*]Execute the fglrx installer.[*]Its GUI is displayed.[*]I select build packages and follow the prompts.[*]The environment is correctly identified as Ubuntu/Lucid.[*]Says it built the package but it doesn't actually build them.
                                i have the same problem ;-)

                                but you don'T need to build packages to install it.

                                the normal install works.

                                Comment

                                Working...
                                X