Announcement

Collapse
No announcement yet.

ATI Drivers 10.6 / Radeon HD 5000 series - no compositing?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ATI Drivers 10.6 / Radeon HD 5000 series - no compositing?

    Hi,

    I have KDE 4, Xorg 1.7 and ATI's 10.6 catalyst drivers.

    I used to use an nVidia card, and compositing worked fine, but now no matter what I do, I can't get it to work.

    Am I right in assuming that KDE compositing does not work on ATI hardware? Or just on the 5000 series?

    Thanks

    My Xorg.conf:

    http://gist.github.com/445782

    Output of xdpyinfo:

    http://gist.github.com/445783

    /var/log/Xorg.0.log:

    http://gist.github.com/445784

  • #2
    According to your log file, there is no reason for it not to work. Have you tried compiz? If I had to guess, I would say this is a bug in KDE.

    Adam

    Comment


    • #3
      Should be a bug in Catalyst, not in KDE. I cannot enable it, too, but it works with the opensource-driver without a problem.

      And I have a HD4650.

      Afaik I couldn't enable compositing since 10.4.

      Comment


      • #4
        it's a combination of fglrx and kde >4.4.x (IIRC) that doesn't work. Other compositing window managers work fine, older kde versions work fine etc.

        There's a bug-report on bugs.kde.org about it, but nobody seems interested in investigating the actual cause.

        You can set kde 4.4's compositioning mode to "Xrender". Some effects aren't available and others are a bit slower, but it'll work.

        Comment


        • #5
          If other opengl compositing managers (such as compiz) work fine, I'm not sure how it could be anything but a bug in kwin, frankly, since kwin uses the exact same Xorg and OpenGL extensions as compiz.

          Adam

          Comment


          • #6
            If other opengl compositing managers (such as compiz) work fine, I'm not sure how it could be anything but a bug in kwin, frankly, since kwin uses the exact same Xorg and OpenGL extensions as compiz.

            Adam

            Comment


            • #7
              Not sure if this would be of any help, but I have a Mobility Radeon HD 5730. When I first open my KDE desktop (4.4.2 on Lucid), it 'thinks' that compositing is on, but it really isn't. I can then turn off compositing, then turn it back on...and it works fine after that. There's a widget to put a compositing on/off button on your desktop I just use that when I login - a bit of a nuisance.

              Other than that (and slight video tearing), I've had no problems with 10.6. Moving/resizing windows even happens fast now.

              Comment


              • #8
                Originally posted by ayqazi View Post
                Hi,

                I have KDE 4, Xorg 1.7 and ATI's 10.6 catalyst drivers.

                I used to use an nVidia card, and compositing worked fine, but now no matter what I do, I can't get it to work.

                Am I right in assuming that KDE compositing does not work on ATI hardware? Or just on the 5000 series?

                Thanks

                My Xorg.conf:

                http://gist.github.com/445782

                Output of xdpyinfo:

                http://gist.github.com/445783

                /var/log/Xorg.0.log:

                http://gist.github.com/445784
                Same here, I have tried kde a couple of times recently. I have a 4870 and I've tried kubuntu 10.04 64 bit. Compositing works out of the box with the oss driver but as soon as I install fglrx it wont activate no matter what. And I did do sudo aticonfig --initial. When I install fglrx in ubuntu 10.04 64 bit compiz activates with no issue.
                Originally posted by mikeuw View Post
                Not sure if this would be of any help, but I have a Mobility Radeon HD 5730. When I first open my KDE desktop (4.4.2 on Lucid), it 'thinks' that compositing is on, but it really isn't. I can then turn off compositing, then turn it back on...and it works fine after that. There's a widget to put a compositing on/off button on your desktop I just use that when I login - a bit of a nuisance.

                Other than that (and slight video tearing), I've had no problems with 10.6. Moving/resizing windows even happens fast now.

                I tried that but it just says it cant be activated.

                I still need to try it with cat 10.6, but I ahd this issue with cat 10.4 and 10.5.

                Comment


                • #9
                  Personal not having any problems apart from the firefox an bug in 10.6, which brigman sorted for us.

                  Tried 10.4 to 10.6 all seem to work with Kwin, That's on a 5870.

                  Xorg 1.7

                  kde 4.3 to 4.4.3

                  Mandriva. 2010

                  My xorg conf looks very different to yours, Maybe due to distro's though


                  Pete.

                  Comment


                  • #10
                    I noticed in your xorg.conf you have 3 device sections 1 for the vesa driver, 1 for nvidia and 1 for fglrx... any reason in particular you need vesa ? Also are you trying to run both an Ati and a nvidia card in the same rig ?

                    Like pete910 above I'm on Mandriva, 2010.1 Rc3 64 bit to be precise,
                    and I've had no issue enabling kwin on kde 4.4.3 with the cat 10.4-10.6 drivers.
                    Those who would give up Essential Liberty to purchase a little Temporary Safety,deserve neither Liberty nor Safety.
                    Ben Franklin 1755

                    Comment


                    • #11
                      Originally posted by DarkFoss View Post
                      I noticed in your xorg.conf you have 3 device sections 1 for the vesa driver, 1 for nvidia and 1 for fglrx... any reason in particular you need vesa ? Also are you trying to run both an Ati and a nvidia card in the same rig ?

                      Like pete910 above I'm on Mandriva, 2010.1 Rc3 64 bit to be precise,
                      and I've had no issue enabling kwin on kde 4.4.3 with the cat 10.4-10.6 drivers.
                      His ServerLayout section is only using a single screen tied to the fglrx driver. There's no harm in having extra Device sections if they aren't being used.

                      Adam

                      Comment


                      • #12
                        I am using compositing with metacity.
                        After an upgrade to cat 10.6 transparency is OK and overall delay decreased. But. Cairo-dock stopped render correctly.
                        Going to downgrade until stuff works again.

                        Comment


                        • #13
                          Originally posted by DarkFoss View Post
                          I noticed in your xorg.conf you have 3 device sections 1 for the vesa driver, 1 for nvidia and 1 for fglrx... any reason in particular you need vesa ? Also are you trying to run both an Ati and a nvidia card in the same rig ?

                          Like pete910 above I'm on Mandriva, 2010.1 Rc3 64 bit to be precise,
                          and I've had no issue enabling kwin on kde 4.4.3 with the cat 10.4-10.6 drivers.
                          I leave multiple device sections lying around for when I switch video cards / need to enable the VESA driver in an emergency. I'm very protective about my xorg.conf, and am a bit annoyed that aticonfig goes in and screws up the order of the sections... oh well.


                          Thanks for all the replies guys, looks like I can stop trying to get KDE 4.4 and fglrx working together, and can use the radeon driver to get OpenGL compositing instead.... and I was having such fun with the Unigine demo and hardware tessellation using fglrx, oh well

                          Thanks

                          Comment


                          • #14
                            Originally posted by ayqazi View Post
                            Thanks for all the replies guys, looks like I can stop trying to get KDE 4.4 and fglrx working together, and can use the radeon driver to get OpenGL compositing instead....
                            Except that you can't. Not on an HD5xxx card. There's only 2D modesetting available in the radeon driver.

                            What happens if you put this in the [Compositing] section of your ~/.kde4/share/config/kwinrc file:

                            Code:
                            AnimationSpeed=3
                            Backend=OpenGL
                            CheckIsSafe=true
                            DisableChecks=false
                            Enabled=false
                            GLDirect=false
                            GLMode=TFP
                            GLTextureFilter=0
                            GLVSync=true
                            HiddenPreviews=5
                            XRenderSmoothScale=false
                            And then restart KDE?

                            Adam

                            Comment


                            • #15
                              Originally posted by adamk View Post
                              Except that you can't. Not on an HD5xxx card. There's only 2D modesetting available in the radeon driver.
                              Hrm.. didn't pick that up from the talk on the thread......

                              And XRender mode crashes if I try to use it, so that's a no-go as well..

                              Originally posted by adamk View Post
                              What happens if you put this in the [Compositing] section of your ~/.kde4/share/config/kwinrc file:

                              Code:
                              AnimationSpeed=3
                              Backend=OpenGL
                              CheckIsSafe=true
                              DisableChecks=false
                              Enabled=false
                              GLDirect=false
                              GLMode=TFP
                              GLTextureFilter=0
                              GLVSync=true
                              HiddenPreviews=5
                              XRenderSmoothScale=false
                              And then restart KDE?

                              Adam

                              I will try that soon...... thanks.

                              Comment

                              Working...
                              X