Announcement

Collapse
No announcement yet.

ATI Drivers 10.6 / Radeon HD 5000 series - no compositing?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by DarkFoss View Post
    I noticed in your xorg.conf you have 3 device sections 1 for the vesa driver, 1 for nvidia and 1 for fglrx... any reason in particular you need vesa ? Also are you trying to run both an Ati and a nvidia card in the same rig ?

    Like pete910 above I'm on Mandriva, 2010.1 Rc3 64 bit to be precise,
    and I've had no issue enabling kwin on kde 4.4.3 with the cat 10.4-10.6 drivers.
    His ServerLayout section is only using a single screen tied to the fglrx driver. There's no harm in having extra Device sections if they aren't being used.

    Adam

    Comment


    • #12
      I am using compositing with metacity.
      After an upgrade to cat 10.6 transparency is OK and overall delay decreased. But. Cairo-dock stopped render correctly.
      Going to downgrade until stuff works again.

      Comment


      • #13
        Originally posted by DarkFoss View Post
        I noticed in your xorg.conf you have 3 device sections 1 for the vesa driver, 1 for nvidia and 1 for fglrx... any reason in particular you need vesa ? Also are you trying to run both an Ati and a nvidia card in the same rig ?

        Like pete910 above I'm on Mandriva, 2010.1 Rc3 64 bit to be precise,
        and I've had no issue enabling kwin on kde 4.4.3 with the cat 10.4-10.6 drivers.
        I leave multiple device sections lying around for when I switch video cards / need to enable the VESA driver in an emergency. I'm very protective about my xorg.conf, and am a bit annoyed that aticonfig goes in and screws up the order of the sections... oh well.


        Thanks for all the replies guys, looks like I can stop trying to get KDE 4.4 and fglrx working together, and can use the radeon driver to get OpenGL compositing instead.... and I was having such fun with the Unigine demo and hardware tessellation using fglrx, oh well

        Thanks

        Comment


        • #14
          Originally posted by ayqazi View Post
          Thanks for all the replies guys, looks like I can stop trying to get KDE 4.4 and fglrx working together, and can use the radeon driver to get OpenGL compositing instead....
          Except that you can't. Not on an HD5xxx card. There's only 2D modesetting available in the radeon driver.

          What happens if you put this in the [Compositing] section of your ~/.kde4/share/config/kwinrc file:

          Code:
          AnimationSpeed=3
          Backend=OpenGL
          CheckIsSafe=true
          DisableChecks=false
          Enabled=false
          GLDirect=false
          GLMode=TFP
          GLTextureFilter=0
          GLVSync=true
          HiddenPreviews=5
          XRenderSmoothScale=false
          And then restart KDE?

          Adam

          Comment


          • #15
            Originally posted by adamk View Post
            Except that you can't. Not on an HD5xxx card. There's only 2D modesetting available in the radeon driver.
            Hrm.. didn't pick that up from the talk on the thread......

            And XRender mode crashes if I try to use it, so that's a no-go as well..

            Originally posted by adamk View Post
            What happens if you put this in the [Compositing] section of your ~/.kde4/share/config/kwinrc file:

            Code:
            AnimationSpeed=3
            Backend=OpenGL
            CheckIsSafe=true
            DisableChecks=false
            Enabled=false
            GLDirect=false
            GLMode=TFP
            GLTextureFilter=0
            GLVSync=true
            HiddenPreviews=5
            XRenderSmoothScale=false
            And then restart KDE?

            Adam

            I will try that soon...... thanks.

            Comment

            Working...
            X