Announcement

Collapse
No announcement yet.

How do you disable direct2d acceleration method?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do you disable direct2d acceleration method?

    I'd like to revert to XAA because direct2d just seems to be too buggy:

    http://68.45.22.62/thunderbird.jpg

    See the folder list? Sometimes it's that gray color, sometimes it's black, sometimes it's white, and sometimes it displays just fine. This isn't just limited to the folder list. It happens with the message list and the message pane itself.

    However, this command:

    # aticonfig --del-pcs-key=DDX,Direct2DAccel

    Doesn't seem to do it. Even after running that and restarting X, the log file still shows:

    (==) fglrx(0): ATI 2D Acceleration Architecture enabled

    Any ideas how I can disable this till all the kinks have been worked out? Anyone else think it was made the default too soon?

    Adam

  • #2
    The option name to disable is something like ForceXAA - might be in the aticonfig -help output, not sure.

    Comment


    • #3
      XAA doesn't show up in the 'aticonfig --help' output. Just in case, I tried 'aticonfig --forcexaa' and 'aticonfig --ForceXAA' but aticonfig just gave an error that it was an unrecognized option.

      Comment


      • #4
        Also, I'm not seeing an option for it in amdcccle, nor does anything about XAA show up in any of the documents in /usr/share/doc/fglrx

        Comment


        • #5
          Also, interestingly enough, the problem doesn't happen if I enable a compositing manager (compiz or xcompmgr).

          Adam

          Comment


          • #6
            Try something like :

            aticonfig --set-pcs-str=DDX,ForceXAA,TRUE

            Comment


            • #7
              That did it...

              (--) fglrx(0): ATI 2D Acceleration Architecture disabled, using XAA

              And now thunderbird looks just fine.

              Should I file this as a bug report somewhere?

              Adam

              Comment


              • #8
                Yes please; ati.cchtml.com would be ideal. Mentioning that the problem only appears with compositing off would be very helpful...

                Thanks !

                Comment


                • #9
                  Also the devs asked me to pass along that the Cat 10.6 drivers aren't ready for old vs new benchmarking yet, ie we enabled the new accel code by default as soon as it appeared the stability was there, we didn't wait for performance optimization.

                  Comment


                  • #10
                    Originally posted by bridgman View Post
                    Also the devs asked me to pass along that the Cat 10.6 drivers aren't ready for old vs new benchmarking yet, ie we enabled the new accel code by default as soon as it appeared the stability was there, we didn't wait for performance optimization.
                    "we didn't wait for performance optimization. "

                    10-6 is the fastest catalyst ever... wait for performance optimization's is like waiting for the Jewish Messiah......

                    Comment


                    • #11
                      Security hazard

                      I really don't think that pointing us to a picture on your home network is really smart...

                      Comment


                      • #12
                        thanks for the xaa option, I have got the same problems with the new 2d accelerator and with thunderbird AND firefox on kde4 (without compositing)

                        Comment


                        • #13
                          Hmpf I already re-created my config files and then set it again to true, but it is still enabled :/

                          exez:~# aticonfig --get-pcs=DDX,ForceXAA
                          No protocol specified
                          Boolean: True


                          me@exez:~$ grep 2D /var/log/Xorg.0.log
                          (==) fglrx(0): ATI 2D Acceleration Architecture enabled

                          Comment


                          • #14
                            I think it's a string variable not a boolean, can you check the command on the previous page ? It's different from what you ran.

                            Comment


                            • #15
                              Originally posted by bridgman View Post
                              I think it's a string variable not a boolean, can you check the command on the previous page ? It's different from what you ran.
                              Oh sorry, I wanted to paste both tryouts from me, I also tried out the orignal cmd from here, without any success, too (and I also restarted my whole PC after this)!

                              Using my Debian packages from debian

                              Comment

                              Working...
                              X