Announcement

Collapse
No announcement yet.

ati catalyst 10.6 released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by Qaridarium View Post
    there are some AGP fixes in kernel 2.6.35 .......
    I'm not sure I understand the reply, so let me rephrase my original question: Has AMD dropped linux drivers for Radeon HD agp cards, or is this just some kind of oversight and the same release will work on both agp and pcie cards, as they have in the past?

    Comment


    • #92
      Originally posted by vvk1 View Post
      Anyone else have this issue?
      openSUSE 11.2 64bit too, though HD4670 (desktop).
      Working fine so far.

      cd /usr/share/ati
      ./fglrx-uninstall.sh
      *reboot*
      rm /etc/ati/amdpcsdb
      cd /to/folder/with/catalyst/10.6
      sh ati-[tab]
      "Enter" multiple times
      *reboot*
      Happy camper

      Comment


      • #93
        Originally posted by quintesse View Post
        Any chance this driver will work on Fedora 13?
        I'd like to know this as well. Some posts hint at "patching Xorg to report version 1.7" - is it possible to do so on F13?

        Comment


        • #94
          Wow, this driver is SO AWESOME!

          I have a Radeon HD 2600 which I haven't been using due to slow compositing and issues with video playback. I've installed the 8.6 driver in openSUSE 11.2 x86_64, and the performance is so much better! Now I can use my quite fast graphics card and still get sweet performance on the desktop! Now I'm considering buying more AMD graphics cards now that the driver works better.

          - The Xtreme Kommander

          Comment


          • #95
            Originally posted by dsmithhfx View Post
            I'm not sure I understand the reply, so let me rephrase my original question: Has AMD dropped linux drivers for Radeon HD agp cards, or is this just some kind of oversight and the same release will work on both agp and pcie cards, as they have in the past?
            mmh is pulling AGP fixes the way to drop support ?

            Comment


            • #96
              Originally posted by rohcQaH View Post
              I didn't notice any graphical corruption on kde3 so far. fglrx 10.6, HD5770, kernel 2.6.32, Xorg 1.7.6.



              <ot>
              There are at least two fan-less netbooks on the market. Both use intel-CPUs (atom) and have glossy displays, and I'm not touching that. But they exist.

              My current notebook is on the brink of death due to a semi-dead and unreplaceable fan (possibly induced by higher-than-intended load to mask a defective nvidia GPU), which means two out of three notebooks became unusable because of a fan. I'd like to prevent my next purchase from suffering the same fate.
              </ot>
              be sure i don't touch a Intel-cpu based notebook

              but yes i'm very interested in passive cooled notebooks.

              Comment


              • #97
                Originally posted by vvk1 View Post
                An ATI developer has just updated the bug report at ati.cchtml.com. The suggested workaround is to add the following to the Device section of xorg.conf:

                BusID "PCI:1:0:0"
                Thanks a lot. That fixed the driver problem for me. PCI:1:5:0 for my notebook.

                I don't know if there is really a performance gain, but I only have an Radeon HD 3200 in my notebook.

                Comment


                • #98
                  Well, video playback is still a very weak point of fglrx. Especially with Evergreen cards. So I'll probably remove the Evergreen tomorrow and wait for the open source code to be released.

                  Comment


                  • #99
                    Originally posted by Qaridarium View Post
                    mmh is pulling AGP fixes the way to drop support ?

                    Yeah, whatever "mmh".

                    To answer my own question, the 10.6 driver does work on my agp 4650 card.

                    Comment


                    • Hello all,
                      I need help with Ubuntu Lucid and Kernel 2.6.34-5 PAE downloaded from PPA.
                      I've successfully builded Catalyst 10.6 deb but with sudo dpkg -i *.deb i get this error on
                      gedit /var/lib/dkms/fglrx/8.741/build/make.log

                      Code:
                      DKMS make.log for fglrx-8.741 for kernel 2.6.34-5-generic-pae (i686)
                      ven 18 giu 2010, 02.20.38, CEST
                      AMD kernel module generator version 2.1
                      doing Makefile based build for kernel 2.6.x and higher
                      rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
                      make -C /lib/modules/2.6.34-5-generic-pae/build SUBDIRS=/var/lib/dkms/fglrx/8.741/build/2.6.x modules
                      make[1]: ingresso nella directory «/usr/src/linux-headers-2.6.34-5-generic-pae»
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/firegl_public.o
                      In file included from /var/lib/dkms/fglrx/8.741/build/2.6.x/firegl_public.c:451:
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/drm_proc.h: In function ‘FGLDRM__vma_info’:
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/drm_proc.h:497: warning: format ‘%08lx’ expects type ‘long unsigned int’, but argument 5 has type ‘phys_addr_t’
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/firegl_public.c: In function ‘KCL_MapPageToPfn’:
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/firegl_public.c:1636: warning: unused variable ‘bus_addr’
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_acpi.o
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_agp.o
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_debug.o
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_ioctl.o
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_io.o
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_pci.o
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_str.o
                        CC [M]  /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.o
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c: In function ‘KCL_WAIT_Add’:
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c:52: error: implicit declaration of function ‘kmalloc’
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c:52: warning: initialization makes pointer from integer without a cast
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c: In function ‘KCL_WAIT_Add_Exclusive’:
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c:71: warning: initialization makes pointer from integer without a cast
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c: In function ‘KCL_WAIT_Remove’:
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c:95: error: implicit declaration of function ‘kfree’
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c: In function ‘KCL_WAIT_CreateObject’:
                      /var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.c:112: warning: initialization makes pointer from integer without a cast
                      make[2]: *** [/var/lib/dkms/fglrx/8.741/build/2.6.x/kcl_wait.o] Errore 1
                      make[1]: *** [_module_/var/lib/dkms/fglrx/8.741/build/2.6.x] Errore 2
                      make[1]: uscita dalla directory «/usr/src/linux-headers-2.6.34-5-generic-pae»
                      make: *** [kmod_build] Errore 2
                      build failed with return value 2
                      Someone can help me?

                      Comment


                      • With the simply installation from .run, I get:
                        Code:
                        Detected configuration:
                        Architecture: i686 (32-bit)
                        X Server: X.Org 7.5
                        DKMS part of installation failed.  Please refer to /usr/share/ati/fglrx-install.log for details
                        /usr/share/ati/fglrx-install.log
                        Code:
                        Errors during DKMS module removal
                        Errors during DKMS module removal
                        [Error] Kernel Module : Failed to add fglrx-8.741 to DKMS

                        Comment


                        • Did you comipletely uninstall the previous fglrx version, restore the previous xorg.conf and reboot before installing the new driver ?

                          Comment


                          • Originally posted by psychok9 View Post
                            Hello all,
                            I need help with Ubuntu Lucid and Kernel 2.6.34-5 PAE downloaded from PPA.
                            You are using an unsupported kernel. Your best bet is to downgrade to the stock 2.6.32 kernel. Someone around here might have a patch for you to enable 2.6.34.. Good luck.

                            Comment


                            • Whoops, I only saw psychok9's last post. Good catch.

                              Comment


                              • Kudos to the ATI Linux team for 10.6!

                                I'm running Mandriva 2010.0 kernel 2.6.31, HD 5670 (on a 785G mobo)

                                Here's what I can do that I couldn't do before:

                                google-earth no longer crashes when I close it down.

                                I can run celestia (this is really cool because it would hang up my system I had to reboot with alt-sys_req-b)
                                .
                                No more wireframes and jerky rendering for HL2 EP1.

                                This is all coming from a hard-core nVidia guy since 3DFX went away.

                                Until recently, I only ever recommended nVidia, now because of work the ATI/AMD guys are doing on the catalyst drivers, I'll recommend ATI; good job ATI-Linux!

                                Comment

                                Working...
                                X