Announcement

Collapse
No announcement yet.

Ati radeon x1200 rotation problem with CentOS

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    My recollectdion is that rotation requires acceleration, and acceleration with 6xx or higher requires the kernel driver, and that the kernel driver has not been backported to RHEL5-era kernels. Something like that anyways.

    Comment


    • #17
      Originally posted by bridgman View Post
      My recollectdion is that rotation requires acceleration, and acceleration with 6xx or higher requires the kernel driver, and that the kernel driver has not been backported to RHEL5-era kernels. Something like that anyways.
      Bridgman can you please confirm if fglrx requires randr 1.2 to support rotation and if so RHEL / CentOS will never support this as they only ship randr 1.1. I looked at Xorg.0.log and it says something along the lines "found randr 1.1 using bultin randr 1.2" or something similar. This makes me confused.

      Comment


      • #18
        probably. You might get around that by configuring the rotation using amdcccle instead of xrandr.

        Comment


        • #19
          Originally posted by rohcQaH View Post
          probably. You might get around that by configuring the rotation using amdcccle instead of xrandr.
          I have never seen any settings for rotation in amdcccle. Maybe because CentOS does not support it.. Can you tell me where I should see that setting ?

          Comment


          • #20
            when I run amdcccle, I click "Display Manager" and select the tab "Display Properties" at the lower right. There's settings for Resolution, Refresh Rate, Rotation and Desktop Area.

            Of course that's 10.6. I can't vouch for ancient driver versions.

            Comment


            • #21
              Originally posted by rohcQaH View Post
              when I run amdcccle, I click "Display Manager" and select the tab "Display Properties" at the lower right. There's settings for Resolution, Refresh Rate, Rotation and Desktop Area.

              Of course that's 10.6. I can't vouch for ancient driver versions.
              Nope do not have any options beside Desktop area and Refresh rate. Im running in big desktop mode. Dont know if that matters.

              Comment


              • #22
                Fluggo, which driver version are you running ? IIRC you have an Evergreen card, despite the thread title

                Comment


                • #23
                  Originally posted by bridgman View Post
                  Fluggo, which driver version are you running ? IIRC you have an Evergreen card, despite the thread title
                  Have tried 10.5 and now 10.6 with this card.

                  Comment


                  • #24
                    I know im not running the same card but we are running the same OS ( CentOS ) which runs RandR 1.1 and maybe that is the problem ? I have yet to find any info about this but it seems that people running RandR 1.2 have rotation support under fglrx or is it simply because they are running a different card?.
                    IE:

                    It is a RandR 1.1 problem and fglrx requires 1.2 for rotation support.
                    Or will fglrx support rotation under CentOS with Randr 1.1 in an upcoming driver?

                    RandR 1.1 says it supports rotation on my box but it freezes instantly or reboots if you try enabling that with 10.6. In 10.5 the screen went black but was still responding.

                    I also have a bug filed about this here: http://ati.cchtml.com/show_bug.cgi?id=1841
                    Still waiting a response on that.

                    Comment


                    • #25
                      @bridgman could you please shed som light on this for me and many others and tell me which statement is true.?

                      1. RHEL 5 /CentOS 5 runs RandR 1.1 and because of this rotation will never be supported in fglrx. It needs RandR 1.2 for this.

                      2. It should work and we know about the problem.

                      3. We know about the problem but it is not prioritized at the moment.

                      4. It could possibly be fixed in a future version of fglrx (no guarantees)

                      5. Rotation is supported but not with evergreen cards at the moment.

                      Thank you for all your time here at the forums it is very appreciated.

                      Regards / Alex

                      Comment


                      • #26
                        6. I don't know

                        You've got the 5770, right ? Not the x1200 from the thread title ?

                        Comment


                        • #27
                          Originally posted by Fluggo View Post
                          5. Rotation is supported but not with evergreen cards at the moment.
                          certainly not true. My HD 5770 works fine with rotation.

                          I'd bet large amounts of shiny things that number 1 is true.

                          Comment


                          • #28
                            Originally posted by rohcQaH View Post
                            certainly not true. My HD 5770 works fine with rotation.

                            I'd bet large amounts of shiny things that number 1 is true.
                            And i believe you are right.

                            @ bridgman Yes a HD5770 and CentOS 5.5 running big desktop. Can you please check if RandR 1.2 is a requirement for Rotation? That will answer the question in this thread. A rotation option does not show up in CCC even though RandR says rotation is possible. And from my Xorg.0.log below leads me to believe fglrx works around randr 1.1 with builtin randr 1.2 ?

                            Xorg.0.log

                            Code:
                            (II) fglrx(0): Disabling in-server RandR and enabling in-driver RandR 1.2.
                            (--) RandR disabled
                            (II) Initializing built-in extension MIT-SHM
                            (II) Initializing built-in extension XInputExtension
                            (II) Initializing built-in extension XTEST
                            (II) Initializing built-in extension XKEYBOARD
                            (II) Initializing built-in extension XC-APPGROUP
                            (II) Initializing built-in extension SECURITY
                            (II) Initializing built-in extension XINERAMA
                            (II) Initializing built-in extension XFIXES
                            (II) Initializing built-in extension XFree86-Bigfont
                            (II) Initializing built-in extension RENDER
                            (II) Initializing built-in extension RANDR
                            (II) Initializing built-in extension COMPOSITE
                            (II) Initializing built-in extension DAMAGE
                            (II) Initializing built-in extension XEVIE

                            Comment


                            • #29
                              There used to be an option to disable the driver's use of RandR1.2, not sure if it is still supported though. Cheick aticonfig -help to see if there's any info there, or try running :

                              sudo aticonfig --set-pcs-str="DDX,EnableRandR12,FALSE"

                              with X stopped.

                              Comment


                              • #30
                                If you want to play it safe try running the following command first, to see if the key still exists :

                                sudo aticonfig --get-pcs-key="DDX,EnableRandR12"
                                Don't know if sudo exists on the current RH distros, so run as root if not. Again, X should be stopped before you run these.

                                Comment

                                Working...
                                X