Announcement

Collapse
No announcement yet.

Catalyst 10.5 For Linux Is Out: Nothing Exciting

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Eve Online via Wine 1.2rc1

    Game is now almost playable with all graphics options turned down. There's cursor corruption whenever you mouse over anything (white box). The game no longer crashes or locks the machine (5 minutes of play)

    Turning up the graphics options (HDR, all dropdowns to highest) completely locks the machine (Radeon 5770).

    So a big step forward, and a couple baby steps back. We might even be able to play Eve in 6 months.

    Frank

    Comment


    • #17
      "nothing exciting" ?

      you gotta be kidding

      "fixed" problems with 10.5 compared to 10.2-10.4 on my Gentoo system:
      - no libGL.so.1.2 error 7 problem anymore with opengl accelerated apps & compositing
      - no problem of broken downclocking (high temperatures and thus noise) from 10.4 compared to the 10.4pre-release of Ubuntu Lucid

      so after 10.1 finally another working catalyst / fglrx release

      with

      - working compositing
      - opengl

      yay !

      thank you - thank you - thank you SO MUCH

      AMD/ATI devs & especially to John Bridgman who seemingly must have read my bothering questions and posts and forwarded the information

      Comment


      • #18
        I can't take any credit for this one

        I suspect what you're seeing is all of the different bits (OpenGL 4, Lucid support, something else I forget) coming together in a single tree for the first time. Anyways, nice to see it working well.

        Comment


        • #19
          I'm very disappointed. I came here expecting to find the usual high-intensity bashing that accompanies every new FGLRX, and all I see is some lukewarm jabs about features that don't apply to the wide population, anyway.

          Come on guys...where's the venom? Do we have to get Gordboy back on to give lessons? This is FGLRX after all. Let's try harder.

          Comment


          • #20
            Awesome! I updated and (after breaking things [remove old ati driver from hardware drivers first]) wine is working much better!

            Vice city no longer crashes after cut-scenes making it fully playable!
            Fallout 3 no longer crashes (not tested too much) and get a much better framerate (still not as good as windows but it's actually playable now!

            and opengl 4 and working tessellation unigine heaven, now that I've seen it first hand I can say it (tessellation) is overhyped but kind of cool. I get an about ~22 fps instead of ~30 at 1024x768 everything max except no AA, on an HD 5770.

            Nothing Exciting?! you mean Lots Exciting!
            (unless you are comparing to the unstable build which I didn't try)

            Comment


            • #21
              Still couldn't install this on Kubuntu 10.04. Nightmare.

              ATI programmers are so pathetic. They should be making their driver A1 installable before they even spend 1 second on OpenGL4 or other features.

              Comment


              • #22
                Lagging with compositing desktop fixed in 10.5?
                https://bugs.launchpad.net/ubuntu/+s...er/+bug/568988

                Comment


                • #23
                  Originally posted by 7oby View Post
                  Lagging with compositing desktop fixed in 10.5?
                  https://bugs.launchpad.net/ubuntu/+s...er/+bug/568988
                  That will be fixed by the new 2d acceleration backend that is supposedly coming soon. Someone mentioned the June driver, but I don't know if that was ever official or just a guess.

                  Comment


                  • #24
                    Originally posted by Pfanne View Post
                    guildwars now crashes for me and has some weird looking bugs in the character selection menu
                    do your 3d games flicker too, if you use a virtualdesktop in wine?
                    I didn't got any crashes, but sometimes I get the weird looking bug in the character selection menu. But in-game is perfect.

                    Comment


                    • #25
                      EDIT:
                      Not weird looking bugs, but weird looking artifacts
                      Phanne, how did you manage to fix it? It didn't work setting catalyst A.I. to standard.

                      Comment


                      • #26
                        Originally posted by Hans View Post
                        EDIT:
                        Not weird looking bugs, but weird looking artifacts
                        Phanne, how did you manage to fix it? It didn't work setting catalyst A.I. to standard.
                        I found the solution myself. Disabling catalyst A.I. fix the character menu problem. But I still get the good performance with every settings to highest (not AA though).

                        Comment


                        • #27
                          Originally posted by Hans View Post
                          I found the solution myself. Disabling catalyst A.I. fix the character menu problem. But I still get the good performance with every settings to highest (not AA though).
                          I still get the 10.4 on the website, why?

                          Comment


                          • #28
                            Originally posted by fabioamd87 View Post
                            I still get the 10.4 on the website, why?
                            Try push F5 on their webpage. Firefox trends to cache too much sometimes.

                            Comment


                            • #29
                              Originally posted by 0e8h View Post
                              Still couldn't install this on Kubuntu 10.04. Nightmare.
                              Shame.

                              ATI programmers are so pathetic. They should be making their driver A1 installable before they even spend 1 second on OpenGL4 or other features.
                              This isn't their call. It's upper management's. They have only so many people and they were short headcount to realistically do much for people back some 4-5 years ago- and I can't envision them being able to up headcount enough to make a difference during the time from then to now.

                              Oh, by the way, don't call them "pathetic". There's some of the best and brightest doing work over there and they're fighting with one arm and one leg tied behind their back right at the moment.

                              Comment


                              • #30
                                Originally posted by Hans View Post
                                Try push F5 on their webpage. Firefox trends to cache too much sometimes.
                                same error with Chrome and never used Opera!

                                I've some problem with my connection today (Alice) is possible that dns are not updated? (anyway I can't change it on my alice router)

                                (Archlinux x64)

                                PS: solved with epiphany, but this is absurd!

                                Comment

                                Working...
                                X