Announcement

Collapse
No announcement yet.

Ubuntu 10.4 | Catalyst | Missing files

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu 10.4 | Catalyst | Missing files

    Hey guys,

    a friend needs the files "/etc/ati/inst_path_default" and "/etc/ati/inst_path_override". Could someone upload those two files please? That would be very nice.

  • #2
    Those are not "missing", you should NEVER run the ati-installer on U 10.04. Because as soon as jockey tries to install fglrx you will have problems.

    Comment


    • #3
      Originally posted by Kano View Post
      Those are not "missing", you should NEVER run the ati-installer on U 10.04. Because as soon as jockey tries to install fglrx you will have problems.
      Is "missing" the wrong word in this context? Sorry, my English isn't very good.

      I know that there could appear some problems but he just want to give it a try. He already asked in an Ubuntu forum and they said him he should test the method I wrote in my first post.

      Comment


      • #4
        Ok, here i am.

        This is the german ubuntuusers thread.
        http://forum.ubuntuusers.de/topic/fg.../#post-2493097

        My Dell Studio XPS 1650 has a Mobility Radeon HD4670.
        When i try to install fglrx + flgrx-amdcccle in synaptic the following error occurs:
        Code:
        E: /var/cache/apt/c/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb: Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück
        details:
        Code:
        (Lese Datenbank ... 190788 Dateien und Verzeichnisse sind derzeit installiert.)
        Entpacke fglrx (aus .../fglrx_2%3a8.723.1-0ubuntu3_amd64.deb) ...
        
        [Warning] Uninstall : inst_path_default or inst_path_override
         does not exist in /etc/ati.  This suggests that the ATI driver
         is not installed, the ATI driver is only partially installed,
         or the current ATI driver installed is an older version than the
         one this script was designed for.  Both files listed above are
         required for determining where installed files are located.
         To force uninstallation of the driver by guessing where the
         uninstallation files are located, set the FORCE_ATI_UNINSTALL
         environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).
        Then i tried:
        sudo env FORCE_ATI_UNINSTALL= apt-get install fglrx
        Code:
        Paketlisten werden gelesen... Fertig
        Abhängigkeitsbaum wird aufgebaut       
        Status-Informationen einlesen... Fertig
        Die folgenden NEUEN Pakete werden installiert:
          fglrx
        0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
        1 nicht vollständig installiert oder entfernt.
        Es müssen noch 0B von 29,2MB an Archiven heruntergeladen werden.
        Nach dieser Operation werden 100MB Plattenplatz zusätzlich benutzt.
        (Lese Datenbank ... 176849 Dateien und Verzeichnisse sind derzeit installiert.)
        Entpacke fglrx (aus .../fglrx_2%3a8.723.1-0ubuntu3_amd64.deb) ...
        
        [Warning] Uninstall : inst_path_default or inst_path_override
         does not exist in /etc/ati.  This suggests that the ATI driver
         is not installed, the ATI driver is only partially installed,
         or the current ATI driver installed is an older version than the
         one this script was designed for.  Both files listed above are
         required for determining where installed files are located.
         To force uninstallation of the driver by guessing where the
         uninstallation files are located, set the FORCE_ATI_UNINSTALL
         environment variable and re-run /usr/share/ati/fglrx-uninstall.sh (this is not recommended).
        
        dpkg: Fehler beim Bearbeiten von /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb (--unpack):
         Unterprozess neues pre-installation-Skript gab den Fehlerwert 1 zurück
        Fehler traten auf beim Bearbeiten von:
         /var/cache/apt/archives/fglrx_2%3a8.723.1-0ubuntu3_amd64.deb
        E: Sub-process /usr/bin/dpkg returned an error code (1)

        Comment


        • #5
          You must set it on a value like =1. currently you unset it.

          Comment


          • #6
            Which value do you mean?
            Sry, i am a Linux Noob^^

            Comment


            • #7
              add a 1 after the =

              Comment


              • #8
                sudo env FORCE_ATI_UNINSTALL=1 apt-get install fglrx solved my problems thanks.

                It take no effect, but then i removed the fglrx driver (which ends in an broken fglrx pakage^^) and then i can install it about "Hardware drivers" and now the driver is installed

                Thank you ware much

                Comment

                Working...
                X