Announcement

Collapse
No announcement yet.

Catalyst 10.4 fglrx support for HD 5830?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Good now you gave ATI even more money

    Comment


    • #12
      Originally posted by brouhaha View Post
      I returned the HD 5830 and got an HD 5850 instead. It works fine with Catalyst 10.4.
      a 5850 is much better because amd disable some key features in the 5830...

      the 5850 also have full-speed 64bit openCL support :-)

      Comment


      • #13
        Originally posted by Kano View Post
        Good now you gave ATI even more money
        kano you sould get more money from amd to. but yes its the same ;-)

        i run kernel 2.6.34+fglrx10.4 because of your install script runs well :-)

        thank you very much :-)

        the linus wine kernel bugfix works well now i can play heroes3 :-)

        magic :-)

        Comment


        • #14
          I did not create the needed patches, those are from arch, its mentioned in the script too:

          # http://aur.archlinux.org/packages/ca...x-2.6.33.patch
          # http://aur.archlinux.org/packages/ca...6.34-rc4.patch

          I just execute em on the fly when i detect that they are needed, which is simple, you only need to do

          grep -q generated/autoconf.h common/lib/modules/fglrx/build_mod/firegl_public.c || echo no 2.6.33+ support - patch needed

          Basically you could patch the already installed fglrx driver too. Just thats not automated. As soon as ATI has direct support the patches will not be applied.

          Comment


          • #15
            Originally posted by Kano View Post
            I did not create the needed patches, those are from arch, its mentioned in the script too:

            # http://aur.archlinux.org/packages/ca...x-2.6.33.patch
            # http://aur.archlinux.org/packages/ca...6.34-rc4.patch

            I just execute em on the fly when i detect that they are needed, which is simple, you only need to do

            grep -q generated/autoconf.h common/lib/modules/fglrx/build_mod/firegl_public.c || echo no 2.6.33+ support - patch needed

            Basically you could patch the already installed fglrx driver too. Just thats not automated. As soon as ATI has direct support the patches will not be applied.
            the real patch what i(we) need is the 10-6 catalyst ;-)

            Comment


            • #16
              Does not matter, the script checks it on the fly, independend of the version you install - you can use -v option to install any version you put into /usr/src before.

              Comment


              • #17
                Hi,

                May i have a quick how-to , to install it on ubuntu x64 10.04 ? i don't know how to patch, and it seems i'm the only one ubuntu user with a 5830...

                Thanks!

                Comment


                • #18
                  I don't know about Ubuntu, but my experience with Fedora was that the first step of getting it installed was to return to the store and exchange it for a 5850. AFAIK, that's not Fedora-specific.

                  Comment


                  • #19
                    Bought on the internet :/ I smelled the issue a few days ago so i mailed them to ask if i can change with a ATI 5850 they didn't even reply :/

                    Comment


                    • #20
                      As far as I was able to determine (and no one here has said otherwise), Catalyst 10.4 doesn't seem to support the 5830. Maybe 10.5 will. Since it uses the same chip as the 5850 and 5870, it's might just be a matter of adding the 5830's PCI device ID to the list.

                      Comment

                      Working...
                      X