Announcement

Collapse
No announcement yet.

So now that ATI 10.04 Driver is out how can i install kernel 2.6.33 properly?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • So now that ATI 10.04 Driver is out how can i install kernel 2.6.33 properly?

    the current fglrx driver is causing errors when i try to install 2.6.33 kernel
    is there a way to fix it or should i install it anyway and fix the problem within the kernel?

    thanks in advance.

  • #2
    I use those patches in my script:

    http://aur.archlinux.org/packages/ca...x-2.6.33.patch
    http://aur.archlinux.org/packages/ca...6.34-rc4.patch

    Those seem to work well. You should write what distro you use.

    Comment


    • #3
      ubuntu 10.04 rc/final i'm not sure because i didn't had much updates in the last few days.

      Comment


      • #4
        ok. run

        http://kanotix.com/files/install-fglrx-debian.sh

        then do to put fglrx on hold - the lucid package has not .33/.34 kernel support:

        Code:
        sudo -i
        echo fglrx hold|dpkg --set-selections
        echo fglrx-amdcccle hold|dpkg --set-selections

        Comment


        • #5
          But i need the fglrx driver why do i need to put it on hold and does this hold is just for 2.6.33 or also for current kernel?

          Comment


          • #6
            My script installs fglrx in a prepatched variant. Just execute it.

            Comment


            • #7
              Ok let me get it straight i install 2.6.33 boot into it download
              http://kanotix.com/files/install-fglrx-debian.sh

              and then
              Code:
              sudo -i
              echo fglrx hold|dpkg --set-selections
              echo fglrx-amdcccle hold|dpkg --set-selections
              or first i download this:
              http://aur.archlinux.org/packages/ca...x-2.6.33.patch

              and run it and how excecly do i run it because i tried and did not managed to do that.

              Comment


              • #8
                you dont need that extra patch, its included in my script. you need that only for other distros where my script can not used.

                Comment


                • #9
                  i'm now in 2.6.33 kernel i'm trying to run install-fglrx-debian.sh using sudo sh install-fglrx-debian.sh but i get

                  Error: No KANOTIX found. Do not ask for support!
                  Error: Can`t be run within X! Use a text console (ALT-CTRL-F1)

                  when i press alt-ctrl-f1 nothing happen it does not response and the strange thing is that it also didn't worked in 2.6.32-21 all i got was a black screen.

                  Comment


                  • #10
                    That is the problem when you have got fglrx installed but no kernel module, then you can not switch it. Best remove fglrx first:

                    Code:
                    sudo -i
                    apt-get remove --purge fglrx
                    rm -f /etc/X11/xorg.conf*
                    reboot

                    Comment


                    • #11
                      Well i managed to get it working but the downloading speed is incredibly small like between
                      3KB and 5KB and my download speed is 500KB so is there something i can do about it?

                      Comment


                      • #12
                        and i still get Error: No KANOTIX found. Do not ask for support!

                        Comment


                        • #13
                          after two percent it stop downloading maybe is there another server that i can edit in the script?

                          and this 1 minute edit is incredibly annoying.

                          Comment


                          • #14
                            That is not the problem, you can put the already downloaded installer to /usr/src.

                            Comment


                            • #15
                              still there is a problem here because it start in 500KB and slow down to several kb and now when i'm downloading directly it download again at 500KB so i don't think it's a problem with the ati server.

                              and what is this Error: No KANOTIX found. Do not ask for support! error?

                              Comment

                              Working...
                              X