Announcement

Collapse
No announcement yet.

10.4 Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by rohcQaH View Post
    Originally posted by mikeuw
    until I try maximizing flash video. Then it's basically unusable.
    same here, both with fglrx and with nvidia. That's adobe flash for you
    Is that with 1080p video? With both 480 and 720p I've got no issues with full screened Flash playback at 1920x1200 on nVidia.

    Comment


    • #17
      Quick note: can't enable Kwin in openSUSE 11.2 64bit.
      After the first login, windows decorations were missing and everything was plain old 2D, subsequent attempts have either resulted in an error message or getting kicked to the login screen.
      I've tried Option "XAANoOffscreenPixmaps" "on" in xorg.conf that helped with 10.2, but no-go this time as far as I can tell.
      Will try more tomorrow, bedtime :P

      Comment


      • #18
        mugginz: just checked, 1680x1050 with a 360p-video. Stutters as soon as I enter fullscreen mode.
        youtube-dl ftw.

        Comment


        • #19
          Originally posted by mugginz View Post
          Is that with 1080p video? With both 480 and 720p I've got no issues with full screened Flash playback at 1920x1200 on nVidia.
          The performance problems I'm having are with non-hd format...but it seems to be limited to flash video that (I think) has DRM associated with it (e.g., watch.ctv.ca or globaltv.com, if you're in Canada)...everything else I've tried (e.g., youtube or CBC) looks fine.

          Comment


          • #20
            Ok, I stand corrected...all flash video is now playing fine.

            The only thing I can say for sure that has changed is that I increased the amount of storage allowed in flash settings (up to 10mb). I have disabled/enabled hw acceleration in flash (it's currently enabled). I also added /etc/adobe/mms.cfg with one line in it: OverrideGPUValidation=1

            I don't know what could have made things start working, but something there did it.

            Comment


            • #21
              So I was running the unstable fglrx driver(think it was 10.3 or 10.4 prerelease) on Debian. Decided to install the official ATI package instead so removed the old stuff and installed.

              It appears I'm getting a slower framerate now though with glxgears. I'm getting about 1700fps on an HD 5470 card. I really don't want to remove and install the fglrx driver through apt again as its a pain. Anyone else notice anything like this? Maybe I remember the old framerate incorrectly so if that sounds normal, so be it.

              Comment


              • #22
                Originally posted by esheesle View Post
                It appears I'm getting a slower framerate now though with glxgears. I'm getting about 1700fps on an HD 5470 card.
                glxgears shouldn't be used as a benchmark, that's the first thing you need to know about linux 3D. Often a faster, more optimised driver will run glxgears slower than a basic one.

                If you're worried about performance, try some games or PTS

                Comment


                • #23
                  Originally posted by grantek View Post
                  glxgears shouldn't be used as a benchmark, that's the first thing you need to know about linux 3D. Often a faster, more optimised driver will run glxgears slower than a basic one.

                  If you're worried about performance, try some games or PTS
                  I was just surprised because I thought the official driver and the fglrx driver were supposedly the exact same.

                  Comment


                  • #24
                    Ubuntu has 8.723.1 but the "final" 10.4 is 8.723, so the driver in lucid is NEWER from the version, but OLDER from the date 8.723.1 (09-04) vs 8.723 (15-04).

                    Comment


                    • #25
                      Originally posted by Kano View Post
                      Ubuntu has 8.723.1 but the "final" 10.4 is 8.723, so the driver in lucid is NEWER from the version, but OLDER from the date 8.723.1 (09-04) vs 8.723 (15-04).
                      Which repo is this in? I'm still getting 8.660 for karmic.

                      Comment


                      • #26
                        I did not test karmic (nor intrepid) but my script should use intrepid target on karmic.

                        http://kanotix.com/files/install-fglrx-debian.sh

                        Test it if you like, i only tested it on Debian Lenny/Squeeze and Ubuntu Lucid.

                        Comment


                        • #27
                          So I hadn't used fglrx since several years back on my old Radeon 9800 AIW Pro. So many changes to the installer and the config generator now . And now I have a Radeon HD 2600 XT.

                          I was able to apply the patch to firegl_public.h for 2.6.33 kernels after symlinking the necessary files per that issue.

                          After that I was able to make Slackware packages just fine ;-). Backed up Mesa GL and installed the packages. Disabled KMS modesetting in lilo.

                          I was able to boot up x.org 1.7.0 after changing xorg.conf myself. xrandr 1.2 support works great for setting dual-head support.

                          2d support working, but 3d support wasn't. Couldn't open fglrx_dri.so (had an old version in the right place). The packager had it in /usr/xorg/lib/xorg/modules/dri/fglrx_dri.so but it should be /usr/lib/dri. After that fixed, running okay so far.

                          Comment


                          • #28
                            I have an error on package generation for Ubuntu/karmic target, some one have same issues?

                            dh_link -pfglrx-amdcccle
                            dh_installmime -pfglrx-amdcccle
                            execstack -c debian/fglrx-amdcccle/usr/lib/bin/amdcccle
                            execstack: cannot open "debian/fglrx-amdcccle/usr/lib/bin/amdcccle": No such file or directory
                            make: *** [binary-install/fglrx-amdcccle] Error 1
                            dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
                            Removing temporary directory: fglrx-install.q3NqxJ

                            Comment


                            • #29
                              @etreus

                              Use my script or update the packages dir after --extract with

                              http://phorogit.com/index.php?p=fglr...ing.git&dl=zip

                              if you prefer manual way. My script adds kernel .33/.34 support on the fly too. Did not test on karmic however - you can do

                              Comment


                              • #30
                                Originally posted by etreus View Post
                                I have an error on package generation for Ubuntu/karmic target, some one have same issues?

                                dh_link -pfglrx-amdcccle
                                dh_installmime -pfglrx-amdcccle
                                execstack -c debian/fglrx-amdcccle/usr/lib/bin/amdcccle
                                execstack: cannot open "debian/fglrx-amdcccle/usr/lib/bin/amdcccle": No such file or directory
                                make: *** [binary-install/fglrx-amdcccle] Error 1
                                dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2
                                Removing temporary directory: fglrx-install.q3NqxJ
                                ditto...

                                But I'm not at all surprised. This is AMD after all.

                                Comment

                                Working...
                                X