Announcement

Collapse
No announcement yet.

HDMI Audio with fglrx?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HDMI Audio with fglrx?

    Hi,

    tried to have HDMI audio with my ati-based mainboard graphics.

    It works out of the box with the open source drivers, but it doesn't work (same system) when switching to fglrx. Is there some setting for xorg that needs to be set for HDMI audio to work with fglrx?

    Thanks!

  • #2
    You don't happen to be using a DVI to HDMI adapter plug, do you?
    If that is the case, you need to be aware that AMD sells a couple of PROPRIETARY adapter plugs, which fglrx can DETECT in order to decide whether or not to enable HDMI audio.

    The open source driver uses the display's EDID to determine if it is HDMI capable, so any GENERIC DVI to HDMI adapter or cable will work.

    Also note: there are TWO DIFFERENT proprietary plugs that AMD sells. If you want to get one, make sure to get the correct one for YOUR CARD.

    Note2: It is *also* possible that your card VENDOR made adjustments, which would mean that you will need THEIR plug rather than AMD's plug.

    Yes, it is an ugly mess with the DVI plugs.

    Just use the open source driver.

    Comment


    • #3
      No, not using any adapter here, there is a HDMI connector on my system's mainboard with an integrated ATI graphics card.

      It's connected to the TV with a 2m HDMI cable (1.3b compliant, says the manufacturer) which works fine with the blu ray player on the same TV.

      Comment


      • #4
        My card is an 4850, this is all I need to get it to work:

        remco@mirage:~$ aplay -l
        **** List of PLAYBACK Hardware Devices ****
        card 0: SB [HDA ATI SB], device 0: ALC888 Analog [ALC888 Analog]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
        card 0: SB [HDA ATI SB], device 1: ALC888 Digital [ALC888 Digital]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
        card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
        Subdevices: 1/1
        Subdevice #0: subdevice #0

        HDMI is card 1, device 3.

        mplayer -ao alsa:device=hw=1.3 /path/to/file

        http://alsa.opensrc.org/index.php/Di...r_media_player has some info on it

        Comment


        • #5
          That doesn't solve my problem. In fact, aplay works without an error and "plays" something, but audio output to the TV is muted. There are instructions you can find via google telling me to unmute the alsamixer setting for HDMI out, but I did, and it doesn't solve the problem.

          And once again, the same system can play HDMI with the open source driver, but with fglrx, I get this strange problem of muted audio.

          Comment


          • #6
            Originally posted by Sockpuppet View Post
            That doesn't solve my problem. In fact, aplay works without an error and "plays" something, but audio output to the TV is muted. There are instructions you can find via google telling me to unmute the alsamixer setting for HDMI out, but I did, and it doesn't solve the problem.

            And once again, the same system can play HDMI with the open source driver, but with fglrx, I get this strange problem of muted audio.
            I would have to say then, that the solution is to use the open source driver. If you don't mind my asking, if the open source driver works, why would you even consider using fglrx?

            Comment


            • #7
              The open source driver still has incomplete power management (they say so themselves on their status page) and system load is far higher than with fglrx (0.5 compared to somewhere around 2 with the oss driver).

              Comment


              • #8
                Originally posted by Sockpuppet View Post
                The open source driver still has incomplete power management (they say so themselves on their status page) and system load is far higher than with fglrx (0.5 compared to somewhere around 2 with the oss driver).
                Unless you have a laptop, power management isn't worth a whole lot.
                And system load of 0.5 vs 2...? On WHAT METRIC? Percent CPU usage? If that's the case, then that is well within the realm of IMMEASURABLE DIFFERENCE.

                Fact is that unless you're using UVD or 3D, the open source driver's performance tends to actually be BETTER than fglrx (which means LOWER system load).

                Comment


                • #9
                  I have exactly the same problem. Old Dell desktop with HD 3650 AGP graphics card and Ubuntu 10.04. With open drivers video and audio works ok through DVI/HDMI adapter to Sony AV AMP/HD projector.

                  Only problem is that Firefox flash video is choppy even when not using full screen.

                  After changing to ati drivers, video is smooth, but no audio anymore. Same output from aplay -l, alsa mixer is not muted. Odd thing is that monitor setting says that audio output for RV-chip lists analog only..

                  What to do?

                  Comment


                  • #10
                    Do you use pulseaudio?
                    With ubuntu 10.04 sound over hdmi works fine with fglrx.

                    I got a hd 4650 mobility card.

                    Comment


                    • #11
                      Originally posted by Hans View Post
                      Do you use pulseaudio?
                      With ubuntu 10.04 sound over hdmi works fine with fglrx.

                      I got a hd 4650 mobility card.
                      Thanks for response Hans. I've been "out" from Ubuntu for the past few years.., how to check this and disable pulseaudio?

                      Comment


                      • #12
                        I can also confirm that pulse audio and hdmi work on ubuntu 10.04 running Catalyst 10.6 on a radeon hd 5770.
                        Code:
                        dandel@dandel-desktop:~$ aplay -l
                        **** List of PLAYBACK Hardware Devices ****
                        card 0: SB [HDA ATI SB], device 0: ALC889A Analog [ALC889A Analog]
                          Subdevices: 0/1
                          Subdevice #0: subdevice #0
                        card 0: SB [HDA ATI SB], device 1: ALC889A Digital [ALC889A Digital]
                          Subdevices: 1/1
                          Subdevice #0: subdevice #0
                        card 1: Generic [HD-Audio Generic], device 3: ATI HDMI [ATI HDMI]
                          Subdevices: 1/1
                          Subdevice #0: subdevice #0
                        also, if the device displays in the above settings, you can specify where the sound goes within "gnome-volume-control"

                        Comment


                        • #13
                          Originally posted by oneFinn View Post
                          Thanks for response Hans. I've been "out" from Ubuntu for the past few years.., how to check this and disable pulseaudio?
                          Well what I meant were, that it actually works with pulseaudio :-) All you have to do, is to select the right output (ATI hdmi) within the pulseaudio control-panel.

                          Comment


                          • #14
                            Originally posted by Hans View Post
                            Well what I meant were, that it actually works with pulseaudio :-) All you have to do, is to select the right output (ATI hdmi) within the pulseaudio control-panel.
                            I don't mean to hijack this person's thread, but I am having the same problem. I am running openSuSE 11.3 with PulseAudio. Sound was working fine before installing the fglrx drivers (10.6) from ATI, but afterwards the sound is not playing from video players. It still plays fine from other areas. In the KDE sound management, my sound card is still selected as the preferred method for playing sound, but this seems to have no effect on which device is actually used.

                            Comment


                            • #15
                              I have been banging my head against this wall for what seems like years. Open source radeon driver gives me HDMI video but no sound through the telly speakers. So I am trying fglrx but the same happens.

                              Kernel 2.6.35, which I built myself, fglrx 10.9, ALSA 1.0.23.

                              I have a radeon 4670 and lspci says I have a RV710/730 which I think is the HDMI soundcard. I see two soundcards in alsamixer and I have the one labelled "spdif" unmuted.

                              In Xorg.0.log I get

                              (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found

                              which I do not get with the radeon driver. Maybe it just needs a Device section in xorg.conf, but I have no idea what to put there.

                              Comment

                              Working...
                              X