Announcement

Collapse
No announcement yet.

HDMI Audio with fglrx?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Hans View Post
    Do you use pulseaudio?
    With ubuntu 10.04 sound over hdmi works fine with fglrx.

    I got a hd 4650 mobility card.
    Thanks for response Hans. I've been "out" from Ubuntu for the past few years.., how to check this and disable pulseaudio?

    Comment


    • #12
      I can also confirm that pulse audio and hdmi work on ubuntu 10.04 running Catalyst 10.6 on a radeon hd 5770.
      Code:
      dandel@dandel-desktop:~$ aplay -l
      **** List of PLAYBACK Hardware Devices ****
      card 0: SB [HDA ATI SB], device 0: ALC889A Analog [ALC889A Analog]
        Subdevices: 0/1
        Subdevice #0: subdevice #0
      card 0: SB [HDA ATI SB], device 1: ALC889A Digital [ALC889A Digital]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
      card 1: Generic [HD-Audio Generic], device 3: ATI HDMI [ATI HDMI]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
      also, if the device displays in the above settings, you can specify where the sound goes within "gnome-volume-control"

      Comment


      • #13
        Originally posted by oneFinn View Post
        Thanks for response Hans. I've been "out" from Ubuntu for the past few years.., how to check this and disable pulseaudio?
        Well what I meant were, that it actually works with pulseaudio :-) All you have to do, is to select the right output (ATI hdmi) within the pulseaudio control-panel.

        Comment


        • #14
          Originally posted by Hans View Post
          Well what I meant were, that it actually works with pulseaudio :-) All you have to do, is to select the right output (ATI hdmi) within the pulseaudio control-panel.
          I don't mean to hijack this person's thread, but I am having the same problem. I am running openSuSE 11.3 with PulseAudio. Sound was working fine before installing the fglrx drivers (10.6) from ATI, but afterwards the sound is not playing from video players. It still plays fine from other areas. In the KDE sound management, my sound card is still selected as the preferred method for playing sound, but this seems to have no effect on which device is actually used.

          Comment


          • #15
            I have been banging my head against this wall for what seems like years. Open source radeon driver gives me HDMI video but no sound through the telly speakers. So I am trying fglrx but the same happens.

            Kernel 2.6.35, which I built myself, fglrx 10.9, ALSA 1.0.23.

            I have a radeon 4670 and lspci says I have a RV710/730 which I think is the HDMI soundcard. I see two soundcards in alsamixer and I have the one labelled "spdif" unmuted.

            In Xorg.0.log I get

            (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found

            which I do not get with the radeon driver. Maybe it just needs a Device section in xorg.conf, but I have no idea what to put there.

            Comment


            • #16
              @fleebag What if you use pulseaudio as others suggested here? Pulseadio isn't the devil it used to be when it was introduced.

              Comment


              • #17
                Never had a problem with HDMI audio. Just switch the audio output to the HDMI one in the PulseAudio settings.

                Comment


                • #18
                  HDMI audio works here, too. You need to select the correct output in the pulseaudio manager (or instruct it to send audio to all available outputs, like I do). If you don't use pulseaudio, make sure your *digital* output is unmuted in alsamixer.

                  Comment


                  • #19
                    Bak to issue while using my system after a while. The problem persist, cannot get audio out while using fglrx.

                    Any other ideas to solve the problem.

                    aplay says:
                    **** List of PLAYBACK Hardware Devices ****
                    card 0: Live [Dell Sound Blaster Live!], device 0: emu10k1x [EMU10K1X Front]
                    Subdevices: 1/1
                    Subdevice #0: subdevice #0
                    card 0: Live [Dell Sound Blaster Live!], device 1: emu10k1x [EMU10K1X Rear]
                    Subdevices: 1/1
                    Subdevice #0: subdevice #0
                    card 0: Live [Dell Sound Blaster Live!], device 2: emu10k1x [EMU10K1X Center/LFE]
                    Subdevices: 1/1
                    Subdevice #0: subdevice #0
                    card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
                    Subdevices: 1/1
                    Subdevice #0: subdevice #0

                    Comment


                    • #20
                      Switched back to open drivers, sound worked ok, but video playback is jerky, especially with full screen.

                      THen back to fgrlx -> sound disappeared but video is smooth. System should be up-to-date according to package manager.

                      One thing taht wonders me is that Sound -A hw settings talk about Analog outputs in RV365 hw?. alsamixer -c1 also displays SPIF,, not HDMI?.

                      Comment

                      Working...
                      X