Announcement

Collapse
No announcement yet.

Ubuntu 10.04 Gets A New Catalyst Pre-Release

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Works well on my Vaio E too...

    also i have no problems with OGL software (well, I only tried Tux Racer, BillardGL and some others) either. Only activating Compiz freezes the settings window (but doesn't crash X).

    I am happy for now

    Comment


    • #32
      Originally posted by grigi View Post
      PAT has to still be disabled for 10.3 on my system, but since you are using Gentoo, the installer will barf if you try to install the driver through portage, and PAT is not disabled in the kernel config.

      So the nopat probably does nothing for you, since PAT suport is probably not built in your kernel.
      seems like it works without for me (at least with 10.1)

      also the PCI_LEGACY find doesn't seem to be needed anymore (it's been removed with 2.6.34 btw.)

      I still couldn't get 10.2, 10.3, 10.4 to work without segfaulting

      I've really gone through all changes that I can think of:

      completely install the system from scratch, switch from amd64 -> x86, switch from hardened -> non-hardened, down from 2.6.34-rc* to 2.6.33 / 2.6.32, conservative C/CXXFLAGS, etc.

      it HAS TO BE a regression - why would it work with 10.1 and out of a sudden stop with the following drivers (I've seen this kind of behavior with the drivers from nvidia, too - so I guess the catalyst driver is getting better what helped was to wait a few months until the devs / it got fixed by itself)

      Comment


      • #33
        finaly i managed to get games working with this driver.

        since i upgraded my system from 9.10 to 10.04 and installed new pre-released catalyst drivers it didnt have direct rendering somehow.

        only thing i had to do was:
        sudo rm /usr/lib/libGL.so.1
        sudo ln -s /usr/lib/fglrx/libGL.so.1.2 /usr/lib/libGL.so.1

        found this solution from somewhere in ubuntu forums.

        finaly i can play HoN now..and also Unigine heaven got nice fps boost with new drivers.

        Comment


        • #34
          I've prepared 2.6.34-rc4 patch: http://aur.archlinux.org/packages/ca...6.34-rc4.patch
          Use it along with fglrx-2.6.33.patch

          Comment


          • #35
            Thank you, added your patches to my script.

            Comment


            • #36
              Originally posted by Cuppa-Chino View Post
              I can report SUCCESS on Vaio E-Series HD 5650 mobility. Segfaults no longer.

              Thank you ATI/AMD!
              i have segmentation faults with that driver cat10-4 and wine 1.1.42 on a lot of apps for exampel farcry...

              i also report the bug here: http://www.codeweavers.com/support/t...cket_id=784736

              """
              wine FarCry.exe
              Segmentation fault (Speicherabzug geschrieben)
              """

              Comment


              • #37
                Are you unable to follow the simple bisect howto?

                http://wiki.winehq.org/RegressionTesting

                Just follow it and dont complain all the day!

                Comment


                • #38
                  Originally posted by Kano View Post
                  Are you unable to follow the simple bisect howto?

                  http://wiki.winehq.org/RegressionTesting

                  Just follow it and dont complain all the day!
                  really this is pointless.....

                  the different 1.1.37 vs 1.1.38/x.42

                  its 1.1.37 its in my point of view the last pur GSGL wine version without openGÖ-wine extensions.

                  38/42 is opengl3.2 use wine-extensions not only slow GSGL.

                  it can be a catalyst driver bug thats because pure GSGL in the past versions is bugfixed over years now in the catalyst but the newer exstensions never ever in use...

                  or mybe a wrong wine implementation of the extensions i think its the same old story the wine dev's use nvidia cards to dev on openGL3.2+

                  i think 'RegressionTesting' do not help anything because how wana a pure old GSGL slow working version? no one!

                  we all wana have a bug-free version of the new OpenGL3.2+ implementation!


                  i think its a driver bug!

                  Comment

                  Working...
                  X