Announcement

Collapse
No announcement yet.

why does fglrx suck so hard?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • why does fglrx suck so hard?

    Hi,

    I just installed fglrx again because I was bored and wanted to have some 3D. Then I tried to enable compositing in KDE4 and what happens? Right, it crashes.

    Why does fglrx suck so hard? WHY?

  • #2
    Well professional users do not need KDE 4 effects, therefore you will be a 2nd class customer as usual.

    Comment


    • #3
      Originally posted by bugmenot View Post
      Hi,

      I just installed fglrx again because I was bored and wanted to have some 3D. Then I tried to enable compositing in KDE4 and what happens? Right, it crashes.

      Why does fglrx suck so hard? WHY?
      Working just fine here, fglrx 10.2, openSUSE 11.2 64bit, KDE 4.3.5

      Added a line in xorg.conf, see http://www.phoronix.com/forums/showp...7&postcount=63
      (It is actually taken from a sticky thread on the Compiz forums regarding fglrx, I simply gave it a shot )
      Without that line, X hangs when trying to turn compositing on.

      Comment


      • #4
        I also use KDE 4.3.5 and fglrsux 10.2, added that line, restarted X, but it still crashes. :/

        Comment


        • #5
          Working fine here with KDE4.4.1. Did have to revert to fglrx 10.1 though, since the latest is not letting me use composition (it's fixed in 10.3 as fas as I can tell, so don't worry).

          Comment


          • #6
            Originally posted by bugmenot View Post
            Hi,

            I just installed fglrx again because I was bored and wanted to have some 3D. Then I tried to enable compositing in KDE4 and what happens? Right, it crashes.

            Why does fglrx suck so hard? WHY?
            fglrx's development focus is too narrow, imho. Their quality standard for non workstation related functionality is considerably sub par to nvidia's.

            Comment


            • #7
              Originally posted by bugmenot View Post
              I also use KDE 4.3.5 and fglrsux 10.2, added that line, restarted X, but it still crashes. :/
              Did you tell aticonfig to use your hand-edited xorg.conf?

              Comment


              • #8
                Do you talk to aticonfig now? Must be a monolog

                Comment


                • #9
                  Well, I also tried "aticonfig --disable-suckhard-mode", but this is all I get:

                  aticonfig: unrecognized option '--disable-suckhard-mode'
                  aticonfig: parsing the command-line failed.

                  Comment


                  • #10
                    Heh.

                    I dunno, I have to say, I'm not a big fan of either ATI's or nVidia's drivers. Right now, I can't get either of them to work as well as I'd like, but I found a set of video options that let things work with the nVidia card, while I've found nothing that keeps the ATI card from locking up hard enough that I need to hit the reset button.

                    Comment

                    Working...
                    X