Announcement

Collapse
No announcement yet.

Ati Radeon 4850 driver error SuSE 11.2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ati Radeon 4850 driver error SuSE 11.2

    Hi all,

    I bought myself a Radeon 4850, but getting it to work in SuSE 11.2 is not going very well.

    This what happens,

    I downloaded the appropriate driver shown here,



    I also the installed minimal and the recommend system requirements as shown in the installation pdf from the ati driver site.

    But after installation my videosystem runs very slow.
    When i startup the catalyst control center ( only possible after a reboot) it shows that i installed a 2D driver version





    And so i cant choose/activate some of the 3D options.
    I think thats also the why reason my system runs so slow after installing the driver.

    any help very much appreciated.

  • #2
    I do not think that is what that means. Mine also says "2D Driver Version" (8.70.something), and runs 3D decently.

    So I think you are mistaken. That's not telling you "given a choice between a 2D driver and a 3D driver, you picked the 2D driver". It's telling you "the version of the part of the driver which handles 2D calls is 8.69.4."

    This doesn't help with the speed issues, but it does tell you where NOT to look, which may narrow things down.

    Comment


    • #3
      Oke, i thought that could the reason.

      But what is the real reason my system runs so slow when the driver is installed ? Hope someone can help me out.

      Comment


      • #4
        I think the driver is installed wrong since it doesn't show anything for OpenGL (no version/provider/renderer).

        You need to follow specific instructions to install this driver. Just downloading it from AMD's site and running it usually breaks your system.

        Comment


        • #5
          I did that, i read the included pdf file carefully and did what they recommended, at least i think so, and dubble checked.

          I also installed the 32bit versions of some files as recommended.

          Comment


          • #6
            Originally posted by KrAaY View Post
            I did that, i read the included pdf file carefully and did what they recommended, at least i think so, and dubble checked.

            I also installed the 32bit versions of some files as recommended.
            The included instructions are not guaranteed to work. You better find some docs specific to openSUSE 11.2. The openSUSE Wiki might be a good place to start.

            Comment


            • #7
              Oh, that's right. I hadn't noticed the OpenGL part.

              Yeah, sounds like it hasn't got your driver installed. I know nothing about OpenSuSE. On my Ubuntu box, I ran the provided driver script, it installed, and everything worked.

              Comment


              • #8
                Hmmmm, i have the feeling this is gonna keep me busy for a while.

                Comment


                • #9
                  Solved,


                  Solution:

                  In /etc/X11/xorg.conf

                  for Radeon HD 4850/4870

                  Section "Device"
                  BoardName "RV770"
                  Driver "radeon"
                  Identifier "Device[0]"
                  VendorName "ATI"
                  Option "BusType" "PCIE"
                  Option "PCIEMode" "8"
                  Option "AccelMethod" "XAA"
                  Option "EnablePageFlip" "off"
                  Option "ColorTiling" "on"
                  Option "AccelDFS" "on"
                  EndSection

                  Comment


                  • #10
                    Originally posted by KrAaY View Post
                    Solved,

                    Solution:

                    Driver "radeon"

                    In /etc/X11/xorg.conf

                    for Radeon HD 4850/4870
                    Driver "radeon" means you're using the open source xf86-video-ati driver, not Catalyst.

                    Comment

                    Working...
                    X