Announcement

Collapse
No announcement yet.

Initial impressions of ATI's drivers...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Followup: Yes, indeedy, vsync was on in amdccle.

    The behavior observed can be expanded, now:

    vsync off, antialiasing 8x: Frame rates anywhere from 8-72fps.
    vsync off, no antialiasing: Frame rates anywhere from 8-72fps. (No difference I can measure.)
    vsync on, antialiasing 8x: Frame rates noticably lower, absolutely capped at precisely 30.
    vsync on, no antialiasing: Frame rates noticably lower, seem to peak somewhere around 45.

    Note that the frame rate I get with 8x antialiasing and vsync is not half of the frame rate with no vsync, and that rates are not in general even divisors of 60.

    Comment


    • #12
      Interesting followup:

      No setting I make in amdcccle allows the in-game selection of vsync/not-vsync to affect results. However, if I set amdcccle to force vsync on or off, it seems to work.

      On further study, I'm pretty sure that the frame rate issues here are wine/opengl/WoW -- it appears that WoW has a single primary worker thread that does ALL of the rendering, and that in practice it consumes at most a tiny fraction past a single core's time, which means that as the amount of geometry work for it to do increases, it slows down quite a bit. There does not appear to be an obvious way to fix this, short of massive reworking of the opengl libraries or something comparable.

      So my best bet will be to hope that wine's directx translation improves, since apparently that engine is better in WoW.

      Comment


      • #13
        Hmm, two or three times today, crashed hard enough that there was no way I could find to recover except rebooting, and one where it needed a physical reset... That's not encouraging.

        Is there any kind of temperature sensor or similar stuff I can use to figure out why it's being so crashy?

        Comment


        • #14
          aticonfig something. Can't remember the exact command, but just running aticonfig without any arguments dumps a list of valid arguments.

          My guess is that you're just hitting driver bugs though.

          Comment


          • #15
            Have you tried playing wow in openGL? I know for at least wheni played wow with an ATI card in wine the performance was much much better through openGL.

            Comment


            • #16
              Originally posted by pfunkman View Post
              Have you tried playing wow in openGL? I know for at least wheni played wow with an ATI card in wine the performance was much much better through openGL.
              Yup. I did try directx, but I ran into a fatal flaw -- the 3D parts of the screen were drawn upside down. (Yeah, I know, that's a pretty weird bug.) It's specific to turning on the "Full Screen Glow" effect, which I think just enables bloom.

              I turned off "Catalyst A.I.", and things have improved some (not so many crashes), but in big open areas with large effects, I still get a lot of random brightly colored polygons in front of other stuff sometimes.

              Comment


              • #17
                Originally posted by monraaf View Post
                aticonfig something. Can't remember the exact command, but just running aticonfig without any arguments dumps a list of valid arguments.
                Thanks! Looks like --odgt is the right magic. Stable around 35 degrees C while just poking at firefoix. I'll leave it running every few seconds for a bit, log in, and see what it does.

                Comment


                • #18
                  Okay, followup. I've had some video glitches, so I ran aticonfig in the background every 2 seconds for a while. I was getting those glitches when the card reported a temperature of about 43 degrees. Haven't seen anything much higher. That makes sense to me; this card is lower power than the GeForce 9800 I replaced with it, but has a bigger heat sink.

                  That said, I'm having one issue that's really a problem for me. With the GeForce drivers, I had a fair number of crashes, but they always resulted in a window being popped up saying that the application was being killed, and then it was killed.

                  The typical failure mode for the ATI drivers is that the display locks up, and nothing short of ssh'ing in and rebooting will recover it. I can kill X, and everything stops running, but I still can't cause the video driver to reset.

                  Or is there a command for resetting the card, too?

                  At least now I know it's not overheating.

                  Comment


                  • #19
                    Originally posted by seebs View Post
                    Or is there a command for resetting the card, too?
                    In theory, removing and reloading the kernel module should reinitialize the hardware. In practice, it doesn't work and I ended up rebooting anyway.
                    I'd guess that fglrx leaves some kernel structures broken when crashing, thus reinitializing the hardware isn't enough. Reinitializing the kernel means rebooting.

                    Comment


                    • #20
                      Messing around, I've noticed that in most circumstances, the "GPU load" value is always 0%, even when the card's rendering full-screen 3D and running at its full clock speed. I'm not sure what that means, but I'm guessing that number isn't very accurate. ("aticonfig --od-getclocks"). That said, it does look as though the card has PLENTY of spare time -- the issues I'm having with performance look like they're CPU-bound.

                      Comment

                      Working...
                      X