Announcement

Collapse
No announcement yet.

AMD Catalyst 10.2 For Linux Gets Direct2D

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • AMD Catalyst 10.2 For Linux Gets Direct2D

    Phoronix: AMD Catalyst 10.2 For Linux Gets Direct2D

    This morning we reported on AMD revealing forthcoming Catalyst driver changes, particularly a set of new features that applied to Windows users. However, we hinted that there might be some changes coming to the Linux driver and now Catalyst 10.2 for Linux is out there so we have the first confirmation of what may be to come. The release notes for the Catalyst 10.2 Linux release are not yet available nor is the AMD web-site updated, but savvy readers have located the 10.2 download link...

    http://www.phoronix.com/vr.php?view=Nzk5MQ

  • #2
    I haven't tried the driver as I am running... another version, but Michael, are you really sure you haven't mixed up something? Because, without going into much detail, for a certain group of people, the experimental Direct2D acceleration was only avaible with a Catalyst release newer than the 10.2.

    Comment


    • #3
      Direct2D...

      It is too hard to understand why AMD do it.

      Comment


      • #4
        I'd rather have Direct3D in their Linux driver. Surely they cannot make it worse than their buggy OpenGL implementation.

        Comment


        • #5
          Originally posted by d2kx View Post
          I haven't tried the driver as I am running... another version, but Michael, are you really sure you haven't mixed up something? Because, without going into much detail, for a certain group of people, the experimental Direct2D acceleration was only avaible with a Catalyst release newer than the 10.2.

          Yeah, 10.2 and newer. Funny thing is that the new accel. method is supposed to finally fix the issues with slow window 2D operations under composite managers (slow window resizing and all that), but the driver is having problems with said managers. The problem doesn't seem to be related to the new accel. mechanism (on or off, Kwin effects still cause a black screen), but maybe they messed up something with the changes.

          Comment


          • #6
            Is there support for kernels > 2.6.31?

            Comment


            • #7
              Originally posted by liangsuilong View Post
              Direct2D...

              It is too hard to understand why AMD do it.

              Easier to "port over" from the Windows Catalyst driver than implementing EXA? Both driver sets do share a lot of their base. Mr. B also lets us constantly know that since fglrx is mostly targeted to their workstation clients, I would imagine that implementing something that would require a drastic change in support would not be a great idea.

              Originally posted by mibo View Post
              Is there support for kernels > 2.6.31?
              2.6.32 works since the 10.1 driver.

              Comment


              • #8
                Modern 2d rendering APIs like Cairo, Direct2D, XRender and Quartz are all very similar. A lot of code in display drivers these days is shared. It is easy to figure out what this code is for ...

                Comment


                • #9
                  Maybe the 2 articles Tom's Hardware has done on Windows 2D performance got them thinking? Note that ATI followed up with them and gave them a new driver with a 2D hotfix (see the last page):
                  http://www.tomshardware.com/reviews/...-gdi,2547.html

                  Comment


                  • #10
                    Originally posted by Melcar View Post
                    Easier to "port over" from the Windows Catalyst driver than implementing EXA? Both driver sets do share a lot of their base. Mr. B also lets us constantly know that since fglrx is mostly targeted to their workstation clients, I would imagine that implementing something that would require a drastic change in support would not be a great idea.



                    2.6.32 works since the 10.1 driver.
                    support for newer kernels has greatly improved (thanks to the community hackers - still not much love from ATI/AMD in this area):

                    with a patch it even works with 2.6.33-rc*/2.6.33 !

                    Comment

                    Working...
                    X