Announcement

Collapse
No announcement yet.

Catalyst 10.1 randomly locks Xorg

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Catalyst 10.1 randomly locks Xorg

    My notebook runs Fedora 11, with Mobile Radeon 4650 card. I've used Catalyst 9.11 since it was out, and it was perfectly stable. After updating to Catalyst 10.1, X hung two times already in two days in plain desktop with no compositing. Both times I was just moving the mouse.

    The symptoms: the system is still running, I can ssh to it and reboot, but X is locked hard - no cursor movement, even Capslock not working, and there is nothing suspicious either in the logs or in dmesg.

    Stracing X shows:
    --- SIGALRM (Alarm clock) @ 0 (0) ---
    and that's all.

    What can I do to diagnose the issue? Is there a way to enable some debugging while I'm logged in remotely? Or should I just stick to randomly turning off various X/fglrx options and hoping that it helps?

    My xorg.conf is below.
    Code:
    Section "ServerLayout"
            Identifier     "aticonfig Layout"
            Screen      0  "Screen0" 0 0
    EndSection
    
    Section "Files"
            ModulePath   "/usr/lib/xorg/modules/extensions/catalyst"
            ModulePath   "/usr/lib/xorg/modules"
    EndSection
    
    Section "ServerFlags"
            Option      "AIGLX" "on"
    EndSection
    
    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
    EndSection
    
    Section "Device"
            Identifier  "Videocard0"
            Driver      "fglrx"
            Option      "OpenGLOverlay" "off"
            Option      "VideoOverlay" "on"
            BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
            Identifier "Screen0"
            Device     "Videocard0"
            Monitor    "aticonfig-Monitor[0]-0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    
    Section "Extensions"
            Option      "Composite" "Enable"
    EndSection

  • #2
    If Catalyst 9.11 works for you I would suggest sticking to that instead of trying to track down eventual bugs that ATI/AMD may have introduced in their 10.1 release.

    Really there's not much you can do.

    Comment


    • #3
      I had the same problem since I updated from 9.8 to 9.10 under fedora 11. Because catalyst 10.1 didn't fixed it, I've updated to fedora 12 with open source drivers, 3D is not really usable but my Xorg is not randomly freezing

      Comment


      • #4
        i can confirm this behaviour, i'm back at 9.11 because of this.

        Comment


        • #5
          The problem is that I'm using a Catalyst build from RPMFusion, and it's tied to a particular kernel version. I now have to either downgrade both kernel and Catalyst (which is a hassle since I have to manually search for the kernel version have 9.11 kernel module prebuilt), or use AMD's own installer that I don't trust.

          I'm wondering if that hang maybe another incarnation of the hardware cursor hang/crash that plagued fglrx up to 9.10. I'll try disabling hardware cursor.

          Comment


          • #6
            Originally posted by figvam View Post
            The problem is that I'm using a Catalyst build from RPMFusion, and it's tied to a particular kernel version. I now have to either downgrade both kernel and Catalyst (which is a hassle since I have to manually search for the kernel version have 9.11 kernel module prebuilt), or use AMD's own installer that I don't trust.

            I'm wondering if that hang maybe another incarnation of the hardware cursor hang/crash that plagued fglrx up to 9.10. I'll try disabling hardware cursor.
            I am having the same problems as you (and I too use the RPMFusion build).
            Switching to software cursor has stopped the hanging, but it makes a mess of an OpenGL application I'm writing :-(
            Device is an HD 4350.
            PeterO

            Comment


            • #7
              That's what I ended up doing (enabling SWCursor). It's stable so far. There's some mouse pointer flickering when moving it too fast, but I can live with it.

              Comment


              • #8
                I'm wondering why this hardware cursor bug just can't be fixed for good. If an fglrx build has it fixed, in the next it will be broken again.

                p.s. What's up with this crap? IMHO 1 minute is just for mocking the members who happen to click on the edit button - you may as well remove it altogether!
                The administrator has specified that you can only edit messages for 1 minutes after you have posted. This limit has expired, so you must contact the administrator to make alterations on your message.

                Comment


                • #9
                  Unfortunately enabling SWCursor broke the cursor in the main Quake Live menu that is showing before joining the match. Anyone has any idea how it could be fixed? Maybe some obscure Quake console setting?

                  Comment

                  Working...
                  X