Announcement

Collapse
No announcement yet.

me too :fglrx underscan problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • me too :fglrx underscan problem

    Hi folks,

    first I have ti admit that I'm not that god in english. So be indulgent ;-)
    I have a Jetway JNC81-LF witch a radeon hd3200.
    When I configured my HTPC (with this Mainboard) in my Office with a FullHD Monitor I had a Slider in amdccc which changed the value of the underscan down to zero.
    But after I connected the PC with my Plasma-TV in my living-room there was no slider any more.
    The Problem is no, my TV has a fixed Overscan (you can't turn it of) na dthe Underscan of the driver is overcompensating it. So I have a Black Frame around the Desktop.
    So I tried several things like :

    Code:
     aticonfig --query-monitor Error: option --query-monitor is not supported when RandR 1.2 is enabled!
    --> to get some Info
    Code:
    aticonfig --set-pcs-val=MCIL,DigitalHDTVDefaultUnderscan,0 Set key MCIL,DigitalHDTVDefaultUnderscan
    --> No effect after restarting the X-server

    Code:
    aticonfig --set-dispattrib=DFP5,positionX:0 aticonfig --set-dispattrib=DFP5,positionY:0 aticonfig --set-dispattrib=DFP5,sizeX:1920 aticonfig --set-dispattrib=DFP5,sizeY:1080
    --> which led to

    Code:
    Try to Set positionX adjust of monitor DFP5 value : 0 failed.  It may not supported by monitor or the value beyond the range.  
    Try to Set positionY adjust of monitor DFP5 value : 0 failed.  It may not supported by monitor or the value beyond the range.  
    Try to Set sizeX adjust of monitor DFP5 value : 1920 failed.  It may not supported by monitor or the value beyond the range.  
    Try to Set sizeY adjust of monitor DFP5 value : 1080 failed.  It may not supported by monitor or the value beyond the range.
    So now I'm stuck
    What can I do get this Slider back ?
    Or do I have to use the radeonhd driver ?
    In case yes, what should I write into Xorg.conf to bypass tho overscan of the TV.

    BTW : The TV is a HDready Panasonic TH-42PV60EH

    Thanks a lot

  • #2
    Oh I forgot, I'm using latest fglrx driver

    Comment


    • #3
      Hey Guys,

      there must bo someone out there who knows how to configure a radeon card with an overscanning Monitor !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1

      Comment


      • #4
        I don't think anyone has ever seen a digital monitor whose overscan can't be turned off. Probably worth going through the manual again - the option usually has a wierd name, like "show all pixels" rather than something useful like "overscan on/off".

        Comment


        • #5
          Originally posted by batesman View Post
          Hi folks,
          BTW : The TV is a HDready Panasonic TH-42PV60EH
          According to google the native res of that is 1024x768, so maybe it would work better if you tried 1024x768.

          Comment


          • #6
            @legume
            Yes, you're right it's 1024x768. But this resolution works only at the vga-input of the TV. If you're using hdmi you're set with the usual HD-resolutions. And because I whant to use my PC as a PVR ....

            @bridgman
            I can assure that checked every Option bevor. There is NO pssibility to switch Overscan off. Not in the user menu and even not in the service menu. This is only an Optionin the later Models of Panasonic.
            But, what would this help. My Problem is the underscan of the fglrx-driver. If I could turn Overscan off, the undescan Problem would even be greater.
            The mentioned Slider was my main reason to buy this MB. FRom my understanding fglrx is getting somy information via EDID which leads to turn off this Option.
            Is there no way to store the EDID information local, edit something in there which brings back the slider and tell xorg to load the EDID info from there ?
            Or second but less good idea. Is there no way to turn underscan off ?

            Comment


            • #7
              There should be a checkbox to turn off the underscan in CCC-LE; I haven't used it for a while but IIRC there's a tab for TV etc and the checkbox is on that tab.

              Comment


              • #8
                Hi bridgeman,

                I'm not sitting in front of the PC.
                Isn't this Checkbox available at the same Tab like this Slider ?
                As I told, I can't see both of them. Could it be a problem that I moved the PC from Office to living room, so that the config files where created at my office Monitor but it'S now connected to tha Plasma-TV.
                Should I probably delete all Config files and run "aticonfig --initial" again ?
                Ideally I would not completely turn of the underscan. I just want to reduce the value of it.

                Comment


                • #9
                  Could be s slider these days, not sure.

                  Yeah, running aticonfig --initial again might help.

                  The underscan used to be enabled by default when the driver detected an HDMI-connected display running at any of the standard HD TV resolutions, and stayed on until turned off by the user via CCC-LE.

                  Comment


                  • #10
                    Ok, I'll try that again when I'm back home.
                    Is there no way to turn this Option on/off in a config file or something ?

                    Comment


                    • #11
                      If there is it would be in the amdpcsdb file, but I don't remember seeing it mentioned as a user-editable option.

                      Comment


                      • #12
                        Originally posted by batesman View Post
                        Ok, I'll try that again when I'm back home.
                        Is there no way to turn this Option on/off in a config file or something ?
                        aticonfig --help | grep -i overscan shows an option.

                        In the past I used to have my S-Video overscan settings stored in xorg.conf by aticonfig --tv-geometry=.....

                        I haven't tested for ages (use OSS driver), but at some time fglrx started ignoring them, so I had to redo them with amdcccle. I don't know what the behavior of more recent fglrx is.

                        Comment


                        • #13
                          Yes I saw this option,

                          but when I remember correct it was just for TV-OUT.
                          From my memory, I believe, HDMI (or in this case DFP-5) is not handled as TV-OUT. But I will check later again.
                          BTW: You told you'er using OS-Driver. If you can tell me how to configure xorg.conf to get a screen that fits I'll prbably try radeon or radeonhd (are they providing XV now for a hd3200 ?)

                          Comment


                          • #14
                            Originally posted by batesman View Post
                            Yes I saw this option,

                            but when I remember correct it was just for TV-OUT.
                            From my memory, I believe, HDMI (or in this case DFP-5) is not handled as TV-OUT. But I will check later again.
                            You may be right I don't have any digital displays to test with.

                            I notice that you used 1920 and 1080 for your size adjust commands - if it's anything like TV then those should be percentages so + or - some small number, though as you got an error on the position 0s I guess it still may not work.

                            BTW: You told you'er using OS-Driver. If you can tell me how to configure xorg.conf to get a screen that fits I'll prbably try radeon or radeonhd (are they providing XV now for a hd3200 ?)
                            Xv should work with both drivers. I can't tell you how well your HDMI TV will work, but if you try with the radeon driver and have problems you can always ask in the OSS forum/file a bug and the devs can help.

                            You won't get UVD for h264 though, which may be a consideration for HTPC - but then with fglrx I suppose you won't know if it works for your hardware until you try.

                            Comment


                            • #15
                              It's running now.
                              After deleting all "config" files and a new installation of the driver the situation was like before. BUT the "set X position and size" commands worked. Except I had to change "DFP-5" to "tmds2i". I think it's because the name assignment changed.
                              I don't know why this "slider" ist still not available (will ever be a ATI secret) but now I can use it like I want

                              Comment

                              Working...
                              X