Announcement

Collapse
No announcement yet.

Setting up my MTRR correctly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Well, I was under the impression that if this happens (IE: Graphics card driver not working while 4 gb of ram is in, but does work with only 2 gb of ram) that is a problem with the MTRR. If it isn't a problem with mtrr, then where, exactly, is the problem going to be?

    Comment


    • #12
      ressource conflict? Bios screwing up memory map? without dmesg impossible to say.

      Comment


      • #13
        Well then, here is dmesg (Way too long to post on these forums)

        My attempts to "dmesg | grep TOM" return nothing.

        Comment


        • #14
          one question - why that kernel command line?

          (and ugh... distro kernels. Full of crap. Oh well...)

          Comment


          • #15
            Lets break it down:
            Code:
            root=UUID=71c43e66-6b6d-4fb1-8b23-918433c9ebec ro quiet splash
            All there before.
            Code:
            enable_mtrr_cleanup mtrr_spare_reg_nr=0 pci=usr_crs
            These three lines helped get the mtrr to where it is.
            Code:
            video=vga=792,
            Default.
            Code:
            nomtrr,
            Was there when I started
            Code:
            vram:512
            Memory of my Graphics card.

            Comment


            • #16
              root=UUID=71c43e66-6b6d-4fb1-8b23-918433c9ebec ro quiet splash

              but why ro?

              enable_mtrr_cleanup mtrr_spare_reg_nr=0 pci=usr_crs

              shorten that to:
              enable_mtrr_cleanup mtrr_spare_reg_nr=1

              video=vga=792

              and scrap the rest and see what happens

              Comment


              • #17
                Originally posted by energyman View Post
                root=UUID=71c43e66-6b6d-4fb1-8b23-918433c9ebec ro quiet splash

                but why ro?
                No idea, it was there to start with.

                enable_mtrr_cleanup mtrr_spare_reg_nr=0 pci=usr_crs

                shorten that to:
                enable_mtrr_cleanup mtrr_spare_reg_nr=1

                video=vga=792

                and scrap the rest and see what happens
                Trying now.
                No change to it working, but cat /proc/mtrr now gives
                Code:
                reg00: base=0x000000000 (    0MB), size= 2048MB, count=1: write-back
                reg01: base=0x080000000 ( 2048MB), size= 1024MB, count=1: write-back
                reg02: base=0x0bfe00000 ( 3070MB), size=    2MB, count=1: uncachable
                reg03: base=0x100000000 ( 4096MB), size= 1024MB, count=1: write-back
                reg04: base=0x0c0000000 ( 3072MB), size=  512MB, count=1: write-combining
                dmesg pastebin with changed settings

                Comment


                • #18
                  I am too lazy to check the memory ranges, but I am pretty sure that from 3584 to 4096 lies your video memory and the 2mb uncachable are pci space.

                  Which is normal for a board with a bios that can not remap pci space or has an intel chipset.

                  So.. it doesn't look bad at all from a first glance.

                  Comment

                  Working...
                  X