Announcement

Collapse
No announcement yet.

ATI Driver 4 Video Playback

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Yesterday i upgraded to kernel 2.32.7 and 10.1 fglrx i got a drop of cpu usage to 90-100% instead of 120 % and above. But also teh output over hdmi is much(!) brighter than before.. wonder why..

    I fouind some xorg settings but i donīt know if they are still needed:

    Section "Module"
    ...
    Load "GLcore"
    Load "glx"
    Load "dri"
    ...
    EndSection

    Section "Extensions"
    Option "Composite" "Disable" #make DRI work with fglrx.
    EndSection

    Option "VideoOverlay" "True" and Option "OpenGLOverlay" "False"

    Comment


    • #32
      It's best to remove all options and let aticonfig generate the xorg.conf. Color configuration can be done in Catalyst Control Center.

      Comment


      • #33
        Originally posted by bridgman View Post
        Yeah, true. Point sampling is really cheap, bilinear has some cost, and bicubic (which is what Xv tries to run) more so.
        I just found out that bicubic filtering isn't supported by radeon on my hardware (RV770). Is this corrent? It's from the radeon manpage:

        Textured XVideo acceleration including anti-tearing support (Bicubic filtering only available on R/RV3xx, R/RV/RS4xx, R/RV5xx, and RS6xx/RS740);

        Comment


        • #34
          Is there a way to find out if enabled? Logs or something?
          I left my xorg.conf completely blank, only thing inside is what aticonfig initial wrote..

          btw: does fglrx so scale the gpu freq by default(powerplay)?

          cheers

          Comment


          • #35
            Originally posted by bolzerrr View Post
            Is there a way to find out if enabled? Logs or something?
            Enabled what exactly?

            I left my xorg.conf completely blank, only thing inside is what aticonfig initial wrote..

            btw: does fglrx so scale the gpu freq by default(powerplay)?
            Yes, fglrx will lower both clocks and voltages when the GPU is not highly loaded. This reduces power consumption and temps by quite a big amount. You can check that with aticonfig (I don't remember the option out of my head, try aticonfig --help). There's an option that shows you the current clocks in MHz.

            Comment


            • #36
              The command to show the current clock is:
              Code:
              aticonfig --adapter=0 --od-getclocks

              Comment

              Working...
              X