No announcement yet.

Mobility HD 5xxx series linux driver

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by TheWretched View Post
    Hey, Cuppa... I have the same laptop (save the i5, but an i3). I guess we'll have to wait for another driver update, sadly.

    I've only tried Ubuntu 10.4 Beta as of yet (no time to try anything else) and my system also segfaults at the EDID. Posted this error also at Launchpad. Dunno if that'll help, though.
    I am just slightly worried that it will never get fixed ... as I cannot read out the edid / ddc connection properly in windows either it is all a bit mysterious -- oddly mesa automatically uses my FullHD resolution.

    To make matters worse, the reason I actually bought the laptop -- the keyboard really is nice and I have another on order for my wife, not sure if I should kill that order but does anyone know of a laptop with more than HD ready 1328x768 resolution and a chiclet style keyboard plus new hardware specs??


    • #32
      Originally posted by Cuppa-Chino View Post
      I am just slightly worried that it will never get fixed
      Don't give up.
      What is your exact model?
      On windows I was able to read and save the EDID, but still xorg doesn't work. Officially ati mobility HD5xxx is not supported by catalyst 10.3, so for some HD5xxx the driver works, for others don't. I'll wait for the 10.4 stable release, maybe they could fix the problem.

      I work with 3D apps, and I spent a lot of money for this laptop, so I hope for a solution in a short time.


      • #33
        the exact model is VPCEB1C5E -- still fearful though -- really do not get why and what Sony has done to the poor screen on this thing....


        • #34
          I have the VPCEB1M1E/WI (not Full HD and i3, but lower price).

          I don't think we'll never get a fix (we are talking open source here too), but it might take time... I've had a Samsung before (with an x700), which took months to work properly in linux. Plus, the GPUs are brand new, even the official drivers don't work with Ubuntu 10.4 yet, either.


          • #35
            some updates

            Some updates here.


            • #36
              So a couple of things that we should try to do:

              a) take the WIN EDID, its saved and use it ... the one installed in my win7 config claimed it to be a microsoft display so its a reg key no more
              b) really disable DDC, I have no idea how, see my earlier posts
              c) as suggested below your post on archlinux use xorg.conf as an override for ddc but I do not think that causes the xorg ddc call to be overriden (as prob as in b) )
              d) pester Sony for a firmware flash for the system ???? I have no idea if this simply a problem somewhere there.....

              all this is kind of as I feared from the beginning for some unholy Sony-reason they decided to save a millionth of a penny by not putting DDC in
              which again makes me worry that proper functionality will not be there without fiddling...

              oh one side note I tried booting using a second screen attached to either hdmi or vga and disabling the primary screen to avoid the ddc but again I think that is not possible, I have not even managed to boot up windows using external display but failed even on that front......

              on a side note... if I could get a
              * core i5m
              * mobility hd 56xx hd 57x
              * chiclet keyboard
              * 1080p display or (1600x900+)
              * NO internal cd/dvd/blueray

              laptop that works then the sony could be wonderfully replaced


              • #37
                apparently someone got fglrx working on Ubuntu 9.10 .

                if this were the case (have asked for more info) then it would seem its a xorg / driver incompatability....

                can anyone confirm this (sorry do not have the time to install 9.10 at the mo)


                • #38
                  Well, 10.4 use 1.7.5, which 9.10 does not. And the official AMD drivers (10.3) don't support the newer yet... so no dice yet.

                  As the GPU is still new and 10.4 isn't even officially released I expect bugs like these.


                  • #39
                    lets see, I have asked him to check if he can do EDID scan under windows to check what he gets

                    @ TheWretched: you have a HD Ready display right? could you run softMCCS and check what your screen identifies as?

                    I will try and post the screen shots in U-forum later


                    • #40
                      see details here : ultiva seems to have it working on karmic



                      • #41
                        problem fixed with new pre-release from today!


                        • #42
                          Ooooohhh, nice!

                          Thx for the info, Cuppa... gonna try it now!


                          • #43
                            Works^^ (tried Tux Racer and some other OGL games), but enabling compiz crashes the window (though not the x-server or anything).


                            • #44
                              Originally posted by Cuppa-Chino View Post
                              problem fixed with new pre-release from today!
                              I'm gonna testing with my pc!