Announcement

Collapse
No announcement yet.

AMD Catalyst 10.1 Driver For Linux Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by ogreinside View Post
    I have to use F12 because it recognizes my Intel ICH "fake raid" RAID0 contaier properly with mdadm. F11 tries to map it to /dev/mapper/isw_<some_string><my_raid_name>, but I might try that next. I guess I can try Ubuntu too, but I've never used Debian based systems, and I use RHEL all the time at work, so Fedora is my preference.

    Any suggestions?
    Use "nodmraid" option when installing. As for your first question, uhm.. stick with F11.

    Comment


    • #92
      Originally posted by marks View Post
      Somebody tells me how to install ATI Catalyst 10.1 to Arch Linux??
      Thanks.
      If you want to install catalyst on Arch Linux you have to downgrade xorg-server first. Downgrading xorg-server is not very complicated on Arch Linux, just do the following:

      Downgrading xorg-server
      1. edit the file /etc/pacman.conf; add the line "Server = ftp://mirror.pacific.net.au/linux/archlinux/$repo/os/x86_64/" at the [extra] entry or if you have a 32bit version "Server = ftp://mirror.pacific.net.au/linux/archlinux/$repo/os/i686/" and put # before "Include = /etc/pacman.d/mirrorlist" (mirror.pacific.net.au is the only server which still have such a old Arch xorg-server package https://users.archlinux.de/~gerbra/mirrorcheck.html)
      2. pacman -Scc
      3. pacman -Syy
      4. pacman -S xorg-server xf86-input-evdev xf86-video-ati xf86-video-vesa xf86-video-vmware xf86-video-v4l xf-86-video-chips
      (if there is any conflict with another xf86-* package you can probably remove it or downgrade it too)
      5. after the downgrading change the file /etc/pacman.conf again like it was before, if you want to update your system you have to ignore the packages above: "pacman -Syu --ignore xorg-server --ignore xf86-input-evdev --ignore xf86-video-ati --ignore xf86-video-chips --ignore xf86-video-v4l --ignore xf86-video-vesa"

      installing catalyst 10.1

      - download the catalyst AUR package from http://aur.archlinux.org/packages.php?ID=29111 make a package with makepkg and install it with pacman -U catalyst*.pkg.tar.gz
      - run the command "aticonfig --initial" to build or change the xorg.conf file

      I downgraded xorg-server like above and it runs fine with catalyst 10.1

      Comment


      • #93
        it is so much easier with gentoo
        just pmask xorg-server 1.7 and everything else falls into places :P

        Comment


        • #94
          hi,
          sorry about my poor english.

          I run 10.1 release on ubuntu 9.10 with an HD4670 graphic card.
          This release is not really stable on my desktop but this is the only one with less tearing.

          Why can't I switch normally to my videoprojector and come back to my display with amdcccle? It results on corruption of my xorg.conf (particulary when I come back to my screen), and has to do reboot to complete.

          This is not the only one, but the most boring.
          Can you give me some help?

          Comment


          • #95
            This new driver doesn't work on Radeon HD 5xxx cards? What if you try a hotfix or downgrade to ver. 9.12?

            Is there any estimates when 10.1 will work?

            I dual boot Debian, Ubuntu and Fedora. I would be satisfied with a fix/solution for Ubuntu and/or Fedora.

            What about Radeon HD 4xxx cards? I am considering one of these and I could boot up Windows for games if need be but I was wondering if there is a plan or schedule for having these cards optimized with the newest drivers and most recent distros (e.g. bleeding edge Fedora 12 and Ubuntu 10.04).

            I am looking at cards from ATI HD 4670 to HD 5770 (limit).

            Sorry to interrupt the detailed and very technical discussion here on the specific cards. I hope my post is okay.

            Comment


            • #96
              the new driver works with 5XXX cards. Who told you otherwise?
              It works.

              Comment


              • #97
                Originally posted by energyman View Post
                the new driver works with 5XXX cards. Who told you otherwise?
                It works.
                Some posters here?

                Um, practically anyone who has a card in the Fedora Forums including admins.

                Comment


                • #98
                  then let me tell you that my 5770 works quite well on 10.1.

                  AFAIK there have been some packaging changes in 10.1, looks like whoever made the fedora packages didn't notice and messed up.

                  Comment


                  • #99
                    The driver doesn't work on Fedora. Fglrx only "officially" supports a few distros, and the driver works fine in those.

                    Comment


                    • Originally posted by Panix View Post
                      Some posters here?

                      Um, practically anyone who has a card in the Fedora Forums including admins.
                      one poster here claimed - and got shot down.

                      And Fedora is broken by design. Use ubuntu, opensuse (or gentoo) and you will be fine.

                      Comment


                      • My question smell bad?

                        I put the corruption of my Xorg.conf by amdcccle:Section "Monitor"
                        Code:
                        	Identifier   "0-DFP4"
                        	Option	    "VendorName" "ATI Proprietary Driver"
                        	Option	    "ModelName" "Generic Autodetecting Monitor"
                        	Option	    "DPMS" "true"
                        	Option	    "Disable" "true"
                        	Option	    "]„	i)i)" "true"
                        	Option	    "Position" "0 0"
                        	Option	    "Rotate" "normal"
                        	Option	    "ql
                        ll" "true"
                        EndSection
                        
                        Section "Monitor"
                        	Identifier   "0-DFP1"
                        	Option	    "VendorName" "ATI Proprietary Driver"
                        	Option	    "ModelName" "Generic Autodetecting Monitor"
                        	Option	    "DPMS" "true"
                        	Option	    "LL" "true"
                        	Option	    "Position" "0 0"
                        	Option	    "Rotate" "normal"
                        	Option	    "Disable" "false"
                        	Option	    "€y	`O|Q|" "true"
                        	Option	    "{	p€" "true"
                        	Option	    "€	`" "true"
                        	Option	    "ƒ" "true"
                        	Option	    "PreferredMode" "1280x1024"
                        	Option	    "TargetRefresh" "60"
                        EndSection
                        And just 30 minutes to go back to my screen after videoprojection. I'm a little bit angry because of that....

                        Comment


                        • Do you think it's normal: I have to do log off or reboot to switch to the next screen?

                          PS: I can't edit my post...

                          Comment

                          Working...
                          X