Announcement

Collapse
No announcement yet.

AMD Catalyst 10.1 Driver For Linux Released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    @jamey0824

    I only use hardy + intrepid target, but intrepid should work as well. Basically the latest karmic target would use external qt4 libs, intrepid target uses internal ones, that does not matter. Also karmic would use execstack protection which is usually not preinstalled on older systems.

    Comment


    • #52
      lets see - driver was 'done' in december. What do you expect?

      Comment


      • #53
        Let us hope, that they fix this driver and give us a hotfix.

        Comment


        • #54
          Originally posted by unimatrix View Post
          Could you guys test Compiz's Window Blur? I wanna know if they really broke it.
          They really broke it.

          The question is imho what makes Compiz blur so special? I read in the "Compiz blur with fglrx"-thread that it requires OpenGL 2.0 to work. This should be no problem for fglrx. So I'd really like to know, why fgrlx has such problems with Compiz blur. By the way, is it just the blur-implementation within Compiz or is it really impossible to get alpha blur working on e.g. OGL 1.5 or even 1.4?

          Originally posted by unimatrix View Post
          Another thing, did they at least fix the issue where it was not possible to have two X sessions to run at the same time? (for example starting the guest session concurrently)
          No, it does not work.

          Another thing which still does not work is netbook-launcher while running compiz. It simply results in garbage:
          http://img109.imageshack.us/img109/5...reenshotwr.png

          Can this be reproduced on other systems?

          The xserver-backclear patch is still needed as well as it seems.

          3D performance and Power management are looking OK to me though. I still don't know, why aticonfig does not allow me to set the clocks as low as the windows driver offers it, but as long as the fan is quiet, I am pretty much satisfied.

          Comment


          • #55
            what 'hotfix'? what is broken?

            Comment


            • #56
              It's very disappointing that packages don't build on Ubuntu 9.10 x86_64. Production support added... yeah sure.

              Anyway, this worked for me:

              chmod +x ./ati-driver-installer-10-1-x86.x86_64.run

              ./ati-driver-installer-10-1-x86.x86_64.run --extract

              cd fglrx-install.xxxx/arch/x86_64/usr/lib64/
              (Replace "fglrx-install.xxxx" with the name of the directory that the installer created on your system)

              ln -s libatiuki.so.1.0 libatiuki.so.1

              cd ../../../..

              sudo ./ati-installer.sh 10.1 --buildandinstallpkg Ubuntu/karmic

              Done!

              Happy building,

              -- Andrés

              Comment


              • #57
                Originally posted by aromanos View Post
                ln -s libatiuki.so.1.0 libatiuki.so.1


                -- Andrés
                yeah, that same thing was fixed to let the arch linux AUR build work. when the author of the AUR build file got report of this problem. it was fixed and made working in less than a day. http://aur.archlinux.org/packages.php?ID=29111

                Comment


                • #58
                  Originally posted by energyman View Post
                  what 'hotfix'? what is broken?
                  The driver itself might work okay. fglrx usually work fine with my computer. But the driver broke the deb packaging :S Thats quite important for most Ubuntu / Debian users, who wants to keep their system clean.

                  I expect a hotfix for this driver, because of the "Ubuntu 9.10 production support" label. Don't get me wrong, I like fglrx. But labeling a driver production ready, when it even can't be packaged for the system is kinda unprofessional.

                  Comment


                  • #59
                    Originally posted by elmo23x View Post
                    and does it have OpenCL? or we still have to use 9.12 hotfix?
                    10.1 doesn't work with opencl. Just tried :-). You have to use 9.12 hotfix.

                    Comment


                    • #60
                      Originally posted by storma View Post
                      Amidst all this rambling, I would just like to mention that I've seen a fps increase in my Unigine tropics/sanctuary benchmarks.

                      *ducks for cover..
                      Yeah, I also got a 3.5fps boost in Unigine tropics benchmark.

                      Comment

                      Working...
                      X