Announcement

Collapse
No announcement yet.

Fglrx locks after startup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fglrx locks after startup

    I have just built a new system and the X server is locking up after the window manager draws the screen and the xserver has drawn the mouse pointer. Fglrx is cataylist 9-7, kernel is 2.6.28.9 the same kernel and fglrx is working OK on another system but this does have an early xserver (7.3) this one is 7.4. No monitor details or mode lines are in xorg.conf so it is not that.
    I beleive I have seen this problem reported before but a search did not find anything.

    Help would be much apreciated. I have found fglrx OK once you get it going but getting it going on a new system...... Oh dear...

    I may not be able to reply to this message, in the past the forum for some reason will not let me post into a thread I have posted to before. May have to get a new login and see if that helps, May be it does not like Blacksmiths.

  • #2
    Why do you use 9-7 and not 9-12 hotfix?

    Comment


    • #3
      Thanks for replying Kano much thanks.
      I tend to use what I know works, I have had significant amount of trouble getting new releases to work and these days will only upgrade if the release notes say there is a major improvement. I have never had any real complaints on the what fglrx does.
      On this system I did have a crack at getting the debian *9-12-1_i386.deb packages to work but did not have any luck quite possibly because the monitor a Mag MXP17F was to old and the driver could not read the EDID data it was sending out. I have now replaced it with a much latter NEC 19 inch.
      Going to have another crack tonight.

      Comment


      • #4
        Can it be assumed that the debian packages are using Hotfix. The date on AMD's Hotfix message is Dec 16, time stamp on the files inside the debian packages is Dec 20. Going into town this morning will drop by the Internet cafe and grab 9-12-Hotfix any way.
        Note: Dialup internet access only out here.

        Real good news the forums are allowing me repeat posts at last.

        Comment


        • #5
          Just use my script.

          http://kanotix.com/files/install-fglrx-debian.sh

          Comment


          • #6
            The script did not work,I am on dialup the script spent 8 hours down loading Hotfixs then exited with an error message some thing to the order of
            "Cannot find ati-driver-installer-8.682.2-x86_64.run"
            Note: Do not know if I have the name quite right.

            The script then erased everything and said try again.

            I find this EXTREMELY frustrating the Linux developers do a wonderfull job particularly the Debian people but they do not appear to understand that some of us do NOT have broadband and cannot download such LARGE files (80Megbytes) at will.

            I will consider the situation I have an ASUS Nvidia 9600 may give that a try. :-(

            Note: I have been using Linux since 1993 (kernel 0.96d). I am familiar with building my own kernel and have submitted and had excepted bug fixes on a variety of projects including the FB driver in the kernel so I am prepared to give something advanced a try If I can find the right direction to face, but simply cannot keep running 9 hour scripts at will (My line time is $1.10 an hour).

            Comment


            • #7
              Sorry, but i can not help you with download errors, it really only deletes the file when it can not be extracted. You can dl it somewhere else and put it in /usr/src - that's the position where it is expected. Btw. it is a zip file that contains the run file.
              Last edited by Kano; 01-20-2010, 12:43 PM.

              Comment


              • #8
                I may go into town to the internet cafe and download the hotfixes file the script was trying to get and put it in /usr/src which is where wget was putting it, That should mean the script will skip the downloading stage but what is this
                "ati-driver-installer-8.682.2-x86.x86_64.run"
                the script wants............ are, I see, its inside the Hotfix zip file.

                May be hope yet....... Does not inspire to much confidence in FGLRX though.

                Blacksmith

                Comment


                • #9
                  Luckyly i have got broadband as the driver is really huge... Nvidia got bigger too with latest 195.xx series 32 bit from 15 to 24, 64 bit from 23 to 40 mb.

                  PS: best fetch latest Kanotix Excalibur too while you use broadband, i would visit a friend however...
                  Last edited by Kano; 01-20-2010, 12:48 PM.

                  Comment


                  • #10
                    The Local town is 24 kilometers away, the cafe however does 160Kbtyes/sec on a good site so that up to around a cd's worth is OK. Anything more than around 8 to 10 meg at home I regard as hopeless. As usual I will keep pressing on, does get frustrating though from time to time.
                    One thing is that I need antaliasing for a project (Note: 1) I am currently working on so I am sort of stuck with the closed src drivers although I way prefer Open source.

                    Note: 1, The fine detail it produces being critcal for the app.

                    Comment


                    • #11
                      Kanotix Excalibur appears to be a cd's worth...... Hmmmmm I do have though rather very strange and individual (who said archaic?) taste in Linux though...... FVWM 4ever.

                      Comment


                      • #12
                        Still no joy.....

                        Obtained the Hotfix file placed into /usr/src and ran the script. When wget tried to fetch the file failed with a 404 error "file not found"

                        This happened twice, third time OK but script failed because it could not find any packages to install. A bit of clairvoyance then came up with the following. I have three kernels in the boot directory the debian installed kernel and two others I have compiled my self, first one being 2.6.28.9 2nd being 2.6.30 both have sources availible to them. The system was running on 2.6.28.9 but the script was building the packages for 2.6.30 but trying to install packages for the first.

                        Lilo changed to boot 2.6.30 script then ran OK and installed everything.
                        Unfortuantely system still locks up on starting X. What happens exactly is the X starts draws the mouse pointer the window manager starts draws all its graphics then the system locks.

                        I have had this with RadeonHD which was caused by there being modelines in the xorg.conf file.

                        All versions of FGLRX behave the same way, I have tried 9-7, 9-12 and 9-12 Hotfix.
                        The system is the following
                        Motherboard ASUS P7P55D-E-Deluxe
                        Processor I5 750
                        Graphics Sapphire Radeon HD4870

                        The Graphics card and the 2.6.28.9 kernel both were OK in the previous motherboard this being an Gigabyte GA P35 DS03 and running Catalyst 9-7.

                        It is appearing that FGLRX does not like the P7P55

                        On the weekend will try an ASUS Nvidia EN9600 and see what happens
                        Last edited by Blacksmith; 01-21-2010, 03:23 AM.

                        Comment


                        • #13
                          Because FGLRX is intended to be a stable enterprise driver not with all the latest and greatest I wonder if the problem could hardware (the ASUS MB) is to new and untested.

                          Comment


                          • #14
                            Just install Kanotix and try again. You must be using a hell of a hacked system even using LILO??! Nobody uses that anymore usually.

                            Comment


                            • #15
                              Stupid forums is stopping me from posting again,
                              The system at this stage is standard minimum install of Debian testing, I usually hack Debian around but at this stage have not got the system running properly.
                              I use lilo because I know EXACTLY how it works and I dislike complexity greatly. The more complex something is the easier it is to break it. See the current situation!!!!!!!!
                              Problem with getting Kanotix is the download is 835 meg this will be pushing the three hour limit at the cafe.

                              I will consider the situation at this stage will try the Nvidia to see if it works. I need antaliasing for a project I am working on and therefore require a closed src driver does not bother me which one.

                              I will be getting a full set of DVD's for testing in a few weeks may wait till then.

                              I believe FGLRX should work in the current instance (standard debian testing install) but does not!

                              Lindsay
                              (Blacksmith)
                              Last edited by Blacksmith; 01-21-2010, 03:39 PM.

                              Comment

                              Working...
                              X