Announcement

Collapse
No announcement yet.

Overdrive not working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Overdrive not working

    Hi all,

    I've got an Ati Radeon HD3650 AGP, and overdrive doesn't work. I have Arch Linux installed with kernel 2.6.31 and Catalyst 9.11 (9.12 has a bug in Warcraft 3, so I'm waiting for a fix).

    $ aticonfig --odgc

    Default Adapter - ATI Radeon HD 3650 AGP
    Core (MHz) Memory (MHz)
    Current Clocks : 300 400
    Current Peak : 725 400
    Configurable Peak Range : [725-750] [400-500]
    GPU load : 0%

    So, it should be possible to get a 750,500 if I'm right, but as you can see it doesn't work:

    $ aticonfig --odsc=750,500
    ERROR - Set clocks failed for Default Adapter - ATI Radeon HD 3650 AGP
    Please check that input values were valid


    I've tried many other values, but only 0,0 seems to work, which is doing nothing.

    Any ideas?

  • #2
    --od-enable
    Unlocks the ability to change core or memory clock values by
    acknowledging that you have read and understood the ATI Overdrive (TM)
    disclaimer and accept responsibility for and recognize the potential
    dangers posed to your hardware by changing the default core or memory
    clocks
    --od-disable
    Disables ATI Overdrive(TM) set related aticonfig options. Previously
    commited core and memory clock values will remain, but will not be set
    on X Server restart.

    Comment


    • #3
      Thanks for the quick reply.
      Already tried that. At least 10 times.

      Comment


      • #4
        Same for me (I am a uber n00b when it comes to linux btw - slowly getting my head around terminal commands)

        Is it something to do with the '/etc/X11/xorg.conf' file?

        here is my terminal output - please note overdrive is enabled, then decides that it isn't any more, and the input clock values should be valid

        adam@adam-desktop ~ $ aticonfig --od-enable
        No layout section was found in the file: '/etc/X11/xorg.conf'.
        Please run 'aticonfig --initial' first or modify your configurationfile manually and run aticonfig again.
        aticonfig: parsing the command-line failed.
        adam@adam-desktop ~ $ aticonfig --initial --od-enable
        Found fglrx primary device section
        ATI Overdrive(TM) enabled
        adam@adam-desktop ~ $ aticonfig --od-getclocks
        No layout section was found in the file: '/etc/X11/xorg.conf'.
        Please run 'aticonfig --initial' first or modify your configurationfile manually and run aticonfig again.
        aticonfig: parsing the command-line failed.
        adam@adam-desktop ~ $ aticonfig --initial --od-enable --od-getclocks
        Found fglrx primary device section
        ATI Overdrive(TM) enabled

        Adapter 0 - ATI Radeon HD 3650 AGP
        Core (MHz) Memory (MHz)
        Current Clocks : 300 400
        Current Peak : 725 400
        Configurable Peak Range : [725-750] [400-500]
        GPU load : 0%
        adam@adam-desktop ~ $ aticonfig --initial --od-enable --od-setclocks=700,500
        Found fglrx primary device section
        ATI Overdrive(TM) enabled
        ERROR - Set clocks failed for Adapter 0 - ATI Radeon HD 3650 AGP
        Please check that input values were valid
        adam@adam-desktop ~ $


        Any help would be greatfully appreciated. Thank you

        Comment


        • #5
          Sorry, running LinuxMint 7 (gloria) main edition (P4 3.0 @ 3.75 (1000MHz FSB), 3gb Ram DDR 400 @ 400, MSI-NEO II m/b, ASUS DVD, Saffhire ATI HD3650 AGP

          Proprietary AMD/ATI driver installed (says catalyst 2.6 on CCC)

          Comment


          • #6
            Actually, since I'm asking questions, how do I install the latest drivers for my card? I have downloaded the file "ati-driver-installer-10-2-x86.x86_64.run" from the AMD/ATI website (apparently the latest version for my HD3650, for linux).

            It is sitting on my desktop (default login, as per installation setup). if I double-click, or select & press enter .... nothing happens

            through terminal:
            adam@adam-desktop ~ $ dir
            Desktop Music Projects Vuze\ Downloads
            Documents My\ Spore\ Creations Videos Windows\ Games
            DOS Pictures vuze
            adam@adam-desktop ~ $ cd Desktop
            adam@adam-desktop ~/Desktop $ dir
            107458-atioc_x86_32_105 atioc_x86_32 eob1.zip
            ati-driver-installer-10-2-x86.x86_64.run english_7.0.pdf eobsjr.zip
            adam@adam-desktop ~/Desktop $ ati-driver-installer-10-2-x86.x86_64.run
            bash: ati-driver-installer-10-2-x86.x86_64.run: command not found

            running the command "su" (which changes the adam@adam from green to red, admin? I don't know what the relivance of the colour change is) makes no difference.

            Again, any help is very much appreciated!

            Comment


            • #7
              bash: ati-driver-installer-10-2-x86.x86_64.run: command not found
              You need to run the installation script as a command, which is done by
              ./ati-driver-installer-10-2-x86.x86_64.run
              More importantly, though, you should look up a tutorial for how to do it all properly. A good starting place, since you're using Mint, would be here: https://help.ubuntu.com/community/BinaryDriverHowto/ATI

              Comment


              • #8
                Have you made it executable yet?

                $ chmod 700 ati-driver-installer-10-2-x86.x86_64.run

                $ ./ati-driver-installer-10-2-x86.x86_64.run

                Comment


                • #9
                  Originally posted by Fer Servadu View Post
                  You need to run the installation script as a command, which is done by


                  More importantly, though, you should look up a tutorial for how to do it all properly. A good starting place, since you're using Mint, would be here: https://help.ubuntu.com/community/BinaryDriverHowto/ATI
                  Thank you! And I will definately go through the link.

                  Cheers!

                  Comment


                  • #10
                    Originally posted by storma View Post
                    Have you made it executable yet?

                    $ chmod 700 ati-driver-installer-10-2-x86.x86_64.run

                    $ ./ati-driver-installer-10-2-x86.x86_64.run
                    Thank you very much!

                    Cheers!

                    Comment


                    • #11
                      Originally posted by Fer Servadu View Post
                      You need to run the installation script as a command, which is done by


                      More importantly, though, you should look up a tutorial for how to do it all properly. A good starting place, since you're using Mint, would be here: https://help.ubuntu.com/community/BinaryDriverHowto/ATI
                      Thank you very much! And I will definitely check out that link!

                      Cheers!

                      Comment


                      • #12
                        Do either of you fine people know the cause of the overdrive fail?

                        Comment


                        • #13
                          Apparently aticonfig thinks the module is not loaded. After you install the driver you need to perform:

                          Code:
                          aticonfig --initial
                          .. as root. That writes all the necessary sections to your xorg.conf, which is what aticonfig looks for when it performs certain operations.

                          Comment


                          • #14
                            Originally posted by Melcar View Post
                            Apparently aticonfig thinks the module is not loaded. After you install the driver you need to perform:

                            Code:
                            aticonfig --initial
                            .. as root. That writes all the necessary sections to your xorg.conf, which is what aticonfig looks for when it performs certain operations.
                            I have run aticonfig:
                            adam@adam-desktop ~ $ sudo aticonfig --initial
                            Found fglrx primary device section
                            Using /etc/X11/xorg.conf
                            Saved back-up to /etc/X11/xorg.conf.fglrx-1
                            adam@adam-desktop ~ $ sudo aticonfig --initial --od-enable
                            Found fglrx primary device section
                            ATI Overdrive(TM) enabled


                            And then...
                            adam@adam-desktop ~ $ aticonfig --odgc

                            Default Adapter - ATI Radeon HD 3650 AGP
                            Core (MHz) Memory (MHz)
                            Current Clocks : 300 400
                            Current Peak : 725 400
                            Configurable Peak Range : [725-750] [400-500]
                            GPU load : 0%
                            adam@adam-desktop ~ $ aticonfig --odsc=300,400
                            ERROR - Set clocks failed for Default Adapter - ATI Radeon HD 3650 AGP
                            Please check that input values were valid

                            any ideas? (I used the current clock values & no luck, same for other settings 750,500 etc)

                            it is a clean install of LinuxMint 7 main & catalyst 10.1 (just installed from AMD/ATI website)

                            Comment

                            Working...
                            X