Announcement

Collapse
No announcement yet.

AMD Catalyst 9.12 Hotfix released

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I finally decided to try the 9.12 hotfix release on my 64-bit Ubuntu 9.10 installation with an HD4870. Building the deb-files went just fine, and so did installing them. But when I start X my two monitors (connected via DVI) goes to sleep. "Hmmmm. Funny." I thought, so I tried the real 9.12 release; the same thing.

    Going back to 9.11 solved the problem.

    Has anyone else seen this problem? I tried searching ati.cchtml.com but it hasn't been updated with new versions of Catalyst since 9.7.

    Comment


    • Originally posted by albatorsk View Post
      I finally decided to try the 9.12 hotfix release on my 64-bit Ubuntu 9.10 installation with an HD4870. Building the deb-files went just fine, and so did installing them. But when I start X my two monitors (connected via DVI) goes to sleep. "Hmmmm. Funny." I thought, so I tried the real 9.12 release; the same thing.

      Going back to 9.11 solved the problem.

      Has anyone else seen this problem? I tried searching ati.cchtml.com but it hasn't been updated with new versions of Catalyst since 9.7.
      Have you tried removing /etc/ati/amdpcsdb?

      Comment


      • Originally posted by Saphy View Post
        Have you tried removing /etc/ati/amdpcsdb?
        I just tried it, and guess what? It worked. Thanks.

        Going from earlier 9.x, I've never had to do that before. Very strange.

        Comment


        • Originally posted by albatorsk View Post
          I just tried it, and guess what? It worked. Thanks.

          Going from earlier 9.x, I've never had to do that before. Very strange.
          Actually it's a very common problem. Linux-only of course

          Comment


          • Did you uninstall the previous fglrx driver before installing the new one ?

            Comment


            • Files in /etc are usually not removed when uninstalling stuff so that settings don't get lost. And that's a good thing; imagine what would happen if you had to redo all settings of all software you upgrade. Welcome to hell.

              What's not a good thing, however, is fglrx chocking on the /etc/ati stuff of previous versions, for no apparent reason. Yeah I know, you'll say "did you report it in the bug tracker", but you know my answer so lets not derail another thread
              Last edited by RealNC; 01-17-2010, 11:13 AM.

              Comment


              • OK.....

                Comment


                • Originally posted by bridgman View Post
                  Did you uninstall the previous fglrx driver before installing the new one ?
                  Well, basically what RealNC said.

                  But just to clarify; I let my package manager handle the installation and uninstallation by simply running "dpkg -i *.deb" in the directory where I built the deb packages. This has worked fine before, and as far as I can remember this was the first time I had to meddle in /etc/ati/ after upgrading the driver.

                  Comment


                  • "dpkg -P" will purge the configuration files, but because amdpcsdb isn't part of the package it isn't removed (dpkg -P does give a warning about this though)

                    Comment

                    Working...
                    X