Announcement

Collapse
No announcement yet.

Getting 9.3 Legacy to work on newest release

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Yeah so I just gave r300g a try again with linux-kernel 2.6.33-rc4 and the very latest mesa, libdrm and radeon from git master.
    HoN starts up, and you get to see the version information in the bottom right of the display and even a part of the title-background, but then it crashes.
    Well, I guess it's slowly getting there.

    Comment


    • #62
      Mobile x700 128mb, what do I do?

      Hallo everyone, first post, but long time phoronix reader.

      I was about to start a new thread, but this one looks like it's the right place to ask for help with legacy AMD-ATI cards.

      I have a an MSI megabook m635, which was a great laptop for its time and price-point, but now it's a little long in the tooth and has replaced the old home desktop from 2001!

      However old this laptop was perfectly capable of running DOOM3 and Quake 4 full throttle, as well as being able to play stalker via wine without too much pain. That was with the fglrx 9.3 driver.

      I'm now running ubuntu 9.10 (yes the lazy distro), and using the free drivers. These do give adequate functionality for everyday tasks: desktop effects, video playback, web surfing etc ... But they are not good enough for real 3D work, even nexuiz has become a slide show. To give you an idea, I get better video performance from my acer d150 netbook on q3a based games ...

      I can live without games, hell I went and bought a PS3, to escape the infinite hardware upgrade loop, but I started doing some 3d modelling and rendering work for an augmented reality project, and the drivers don't cut it, while fglrx does the job on even older hardware.

      My question is, what is my best course of action? Is there an up-to-date distro ubuntu 9.10, 10.04, fedora 12, arch etc ... That supports the legacy fglrx driver? Or is there an up to date free driver that gives comparable HW acceleration on my card say through a ppa or svn repo?

      I thought about moving back to debian stable (does 9.3 still work there?), but I'd rather not have to because it would be so much of a functionality regression to be close to unbearable.

      TIA

      P.s. I went and bought a new laptop (asus ul30-vt) with hybrid video setup from nvidia, and that ain't working either ... Will I ever learn ?!?

      Comment


      • #63
        Originally posted by randomas
        [...]I started doing some 3d modelling and rendering work for an augmented reality project, and the drivers don't cut it, while fglrx does the job on even older hardware.

        I thought about moving back to debian stable (does 9.3 still work there?), but I'd rather not have to because it would be so much of a functionality regression to be close to unbearable.
        Hi, randomas

        Based on those two comments I'd say that you should go for something like Debian stable. You probably don't need the very last kernel to run your old hardware, so the functionality regression you mention is limited to not having the latest version of your favourite software. It seems that this is not your primary machine, and that you want to do something 3D-related on it: the lack of proper drivers therefore outweights any other consideration given the intended use.

        If you really need more recent software you can always enable both testing and unstable repositories and cherry pick what you want (avoiding new kernels and X servers, of course). A lot of us do it and we don't get in any more trouble than your average Ubuntu passerby.

        It sucks a bit, but you may even come to appreciate the piece of mind of not having to update your crap every so often (leave that for your modern, juicy stuff).

        Comment


        • #64
          Thanks for the prompt answer!

          Debian stable (or ubuntu 8.04 for that matter) seem to be the obvious solutions, but I'm really trying to see if I can find an alternative course of action before giving in to the obvious.

          I used to run debian sid (in pre ubuntu times) and it did get kind of ugly, and my experience with running stable with backports from testing and unstable left me a little scarred ... At the moment I have a second partition with a debian stable on it (is there a way to get grub to update automatically or do I have to keep cutting and pasting to the menu file?), but I really don't like the idea of distro-hopping between tasks ... "Work and games over here, while web surfing, time wasting, media consumption, statistical analysis and knowledge working go over there!".

          I'm kind of hoping to get pointers to a more "technical" workaround in the form of an updated radeon driver that performs, a modified 9.3 that works with the new kernels and x-servers, or a workable manner to downgrade x.org and kernel on modern distros (I tried locking versions between 8.10 and 9.04, but it didn't work for me).

          If there ain't one, I guess I'll have to grovel back to debian and try and make friends again ...

          Comment


          • #65
            If "Nexuiz is a slideshow" then it sounds like there's something wrong with your open source driver configuration. The open source drivers are definitely slower than fglrx but "slideshow" sounds like either SW rendering or some serious SW fallback.

            If you have a spare partition, then first step should probably be installing Lucid or F13 alpha to get onto a current KMS stack. If that doesn't help, then you'll probably need to fall back to an older distro and fglrx for a bit longer until the Gallium3D mesa paths are far enough along for you to use.

            It's probably worth learning to build the mesa-over-gallium3d binary anyways - there has been a lot of progress in the last couple of months. Note that the Gallium3D driver isn't actually *faster* than the classic Mesa HW driver yet, but it does expose most of the GL2 functionality which may allow certain apps to run *much* faster than they would otherwise.

            so...

            1. Try Lucid or F13 to see what the latest "production" stack does

            2. Try overlaying the Gallium3D Mesa driver on (1) to get an idea of how close to ready it is for you

            3. If neither is enough, go back to a stable distro and fglrx for a bit longer

            Comment


            • #66
              Thanks bridgman.
              Ok so first off I was still using 9.04 ...
              I upgraded to 9.10 and ran a few qualitative tests:
              First up I ran open arena and it ran fine before and after the upgrade, but nexuiz was still a no go.
              Iupdated the kernel to 2.6.32 and used the edgers ppa for updated x server,drivers and mesa, tryed again and no change.

              I started fooling around with the effects settings on the games and it turns out that any attempt to use bloom or blur effects reduces the games to a standstill. Once I discovered that and noticed that blur settings were on in nexuiz, everything started running normally!

              So I take it that advanced shader and lighting effects are not implemented for r300 cards yet.

              Do you think doom3 or quake4 will run?

              Thanks again, now lets see if I can get that pesky AR app to work again ...

              Comment


              • #67
                The bloom features work if you use KMS and a recent enough version of mesa. And, yes, doom3 runs. Not great, but it runs. You want to have that recent version of Mesa and use the ARB2 render path in doom3. I get roughly 30 fps in the timedemo.

                Adam

                Comment


                • #68
                  Ok from glxinfo this is what I seem to be running.

                  OpenGL vendor string: DRI R300 Project
                  OpenGL renderer string: Mesa DRI R300 (RV410 5653) 20090101 TCL
                  OpenGL version string: 1.5 Mesa 7.8-devel

                  How do I know if I'm using kms or not?

                  Could you point me in a direction for a howto on getting this stuff to work?

                  I'm using the edgers ppa repo in ubuntu https://launchpad.net/~xorg-edgers/+archive/ppa there's package versions and dates and it all seems pretty recent.

                  ARB2 render path? Not knowing about these things makes me feel old ...

                  Comment


                  • #69
                    What is the output of 'dmesg | grep drm'?

                    Adam

                    Comment


                    • #70
                      Well there you go ... I thought the 2.6.32 kernel used kms but it's still using userspace modesetting ...

                      [ 23.045582] [drm] Initialized drm 1.1.0 20060810
                      [ 23.152282] [drm] radeon defaulting to userspace modesetting.
                      [ 23.153286] [drm] Initialized radeon 1.31.0 20080528 for 0000:01:00.0 on minor 0
                      [ 23.684124] [drm] Setting GART location based on new memory map
                      [ 23.684766] [drm] Loading R400 Microcode
                      [ 23.740891] [drm] Num pipes: 2
                      [ 23.740902] [drm] writeback test succeeded in 1 usecs

                      Will upgrading to 2.6.33 change it to kms, or does it depend on other stuff too?

                      Comment


                      • #71
                        If you want KMS the easiest route is probably an early build of Lucid. I think it's at Alpha 3 right now...

                        Comment


                        • #72
                          The kernel only enables KMS by default if it's compiled to. Otherwise you can enable it by passing radeon.modeset=1 on the kernel boot line. However, 2.6.32 may not have the changes necessary to support accelerated blit, so I would suggest using 2.6.33 anyway.

                          Adam

                          Comment


                          • #73
                            What a difference a minor version number change makes

                            WOW!
                            the radeon modeset option at boot didn't work on 2.6.32, so I installed the 2.6.33 kernel and it switched to kms.

                            Now bloom and blur options don't phase the system at all!

                            There is however some form of regression with the lighting elaboration, because that seems to affect the system more heavily than before.
                            Still I'm very impressed!

                            Thanks for all the help!

                            Now to install something more taxing and getting openvrml to compile on a 64bit system ... Gulp!

                            Comment


                            • #74
                              Originally posted by randomas View Post
                              I thought about moving back to debian stable (does 9.3 still work there?), but I'd rather not have to because it would be so much of a functionality regression to be close to unbearable.
                              Maybe a little late but if another poor soul has the same problem: at the moment (see posting date) debian stable works fine with the 9.3 fglrx.

                              Comment

                              Working...
                              X