Announcement

Collapse
No announcement yet.

AMD's UVD2-based XvBA Finally Does Something On Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Originally posted by Green View Post
    Starting from (xvba-video_0.7.7.pre1-1_i386), ASS Karaoke effects used in conjunction with plain ASS subtitles, cause the plain ASS subtitles to flicker like crazy. This is on a HD4830, Ubuntu 10.10, Catalyst 10.11, & mplayer-vaapi-20100713.

    The subtitle flickering is not present using (xvba-video_0.7.6-1_i386).
    I released 0.7.7 normally without your flickering problem. That one could have been caused by a combination of obsolete driver or other bugs. XVBA_VIDEO_PUTSURFACE_FAST=0 to disable the feature in 0.7.7.pre. This is the default for final 0.7.7.

    Comment


    • Does the new sdk work better and allows opensource implementation?

      Comment


      • Originally posted by Kano View Post
        Does the new sdk work better and allows opensource implementation?
        XvBA has public libraries and private headers. OpenVideo has public headers and private (or inexistent) libraries for Linux. Ever seen something right at ATI?

        Comment


        • Are those libs not in there:

          http://developer.amd.com/gpu/ATIStre...ault.aspx#five

          Comment


          • Originally posted by Kano View Post
            apparently not AFAICS.

            the OVDecode.lib is there for the windows 32bit install, but OVDecode.so is not in the 32 bit linux lib/x86 dir, didn't check the 64bit packages.

            Comment


            • Originally posted by gbeauche View Post
              XvBA has public libraries and private headers. OpenVideo has public headers and private (or inexistent) libraries for Linux. Ever seen something right at ATI?

              LOL, also they have problems with the win32 install too, their SDK Installation Notes say that you can install it on a PC with a non supported OpenCL Gfx card installed, and still run the CL examples on the CPU, but they Dont

              Comment


              • So Bridgman any chance you can chase this down and find out who scewed up ? and why that OVDecode library is missing from the current Linux SDK

                as it seem's gbeauche or indeed anyone cant even begin to look into supporting Video decoding without All the required files in a fully self contained Direct download URL Update would be nice ASAP

                what a mess this chrismas SDK release is turning into, and just as the world's OSS Dev's are home for the holiday's and looking to contribute some new spare time and effort to projects.....

                Comment


                • So will support for UVD 1 cards ever be fixed? According to wikipedia UVD 2 cards are the only ones even supported by XvBA

                  Comment


                  • Originally posted by bwat47 View Post
                    So will support for UVD 1 cards ever be fixed? According to wikipedia UVD 2 cards are the only ones even supported by XvBA
                    apparently not, gbeauche cant work miracles if the long time bugs he's already reported under NDA to AMD Dont get fixed.

                    Bridgman, you didn't comment on my other post above , did you miss the request to sort that missing OVDecode library, so people can at least start to look at testing that for video decode on AMD at least...

                    Comment


                    • Btw, now I've a question: Since last friday, I'm not able to access to the official xvba-video download address anymore... (I've been trying to update xvba-video to version 0.7.7)

                      The site is giving a "404 not found" error...

                      Did it happen something to the address?

                      Cheers

                      Comment

                      Working...
                      X