Announcement

Collapse
No announcement yet.

AMD's UVD2-based XvBA Finally Does Something On Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Works!

    I've been reading around here for quite a bit, trying to get my HD5550 to work under Linux with XBMC vaapi enabled. I tried a number of suggested combinations (different xorg and catalyst versions), but in the end I also always ended up with the garbled screens as seen here in the screenshots.

    After some more searching on this forum, the conclusion seemed to be that XvBA support is "broken" for the Evergreen ATi GPU series (HD5xxx). Until now I guess .

    I decided to install everything from scratch today, and was surprised to see catalyst 10.12 being released - eventhough the link still said 10.11.

    Here is what I ended up with:
    • Ubuntu 10.10 AMD64 ("Maverick")
    • xvba-video_0.7.7.pre2-1 (AMD64)
    • libva 0.31.1-1+sds4 (AMD64)
    • XBMC PRE-10.5 r35635 (--enable-vaapi)
    • Ati Catalyst 10.12 (fglrx-8.801)

    Result? (screenshots are from an antique CRT monitor)





    No more distorted decoding. Very low CPU load (averages from 8 to 9%, with 10 to 11% peaks). Perfect image quality. I have not tried and tested lost of different videos, but so far the results seem great!

    Curious what others will get for result!

    Comment


    • So UVD1 cards are fucked for vaapi? I've been trying to get vaapi working with my hd2600 with mplayer-vaapi and vlc and ended up with the same libraries as you but unfortunately my output is always totally garbled.

      Comment


      • Originally posted by bwat47 View Post
        So UVD1 cards are fucked for vaapi? I've been trying to get vaapi working with my hd2600 with mplayer-vaapi and vlc and ended up with the same libraries as you but unfortunately my output is always totally garbled.
        bwat47, I don't know. From what I read here I gathered that non 'Evergreen' (UVD2) cards kind of do/did seem to work (saw some posts mentioning Xorg 1.8.2 and Catalyst 10.7). In the end I concluded that it was actually the HD5xxx series of cards that had troubles using xvba, and they did. Reported 'working' UVD1 software combinations never worked on my UVD2 card. Until catalyst 10.12 it seems. Works great now. So 10.12 gives you the same results as before?

        Comment


        • My HD5850 is working OK now, just by using XVBA_VIDEO_EVERGREEN_WORKAROUND=0

          Thanks everybody.

          Comment


          • When you use xvba-video 0.7.7+ this is default.

            Comment


            • OpenCL video decoding

              With the new Cat 10.12 driver for Windows there are OpenCL functions covering video decoding.
              Are these functions a standard that can be used (maybe in the future) with other vendors gpus, too?
              Will this replace the XvBA library?

              \bin\x86\OVDecode.dll
              \include\OVDecode\OVDecode.h
              \include\OVDecode\OVDecodeTypes.h
              \lib\x86\OVDecode.lib

              Comment


              • Originally posted by mibo View Post
                With the new Cat 10.12 driver for Windows there are OpenCL functions covering video decoding.
                Are these functions a standard that can be used (maybe in the future) with other vendors gpus, too?
                Will this replace the XvBA library?

                \bin\x86\OVDecode.dll
                \include\OVDecode\OVDecode.h
                \include\OVDecode\OVDecodeTypes.h
                \lib\x86\OVDecode.lib

                The Linux files are available here:
                http://download2-developer.amd.com/a...v2.3-lnx32.tgz
                http://download2-developer.amd.com/a...v2.3-lnx64.tgz

                They contain the same files. So yes, we can get rid of XvBA. The API looks like XvBA but I don't know if the same limitations apply.

                Comment


                • Originally posted by javonera View Post
                  My HD5850 is working OK now, just by using XVBA_VIDEO_EVERGREEN_WORKAROUND=0
                  Can you test xvba-video 0.7.7.pre2. If it works, I will make it final and switch to 0.8.x-series for probably OVDECODE_API.

                  Comment


                  • Originally posted by gbeauche View Post
                    Can you test xvba-video 0.7.7.pre2. If it works, I will make it final and switch to 0.8.x-series for probably OVDECODE_API.
                    :-)
                    Hopefully the video playing future with ovdecode_api is now brighter than with this buggy xvba.

                    Comment


                    • nich to watch the movement with catalyst11.1 we also get tearfree desktop and flash

                      just nice.

                      Comment

                      Working...
                      X