Announcement

Collapse
No announcement yet.

Unsupported Hardware watermark

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    so, in synaptic i search for fglrx and complety remove all package that was shown.
    rebooted my computer and i could change to my maximo and optical resolucion.
    open the terminal and write your code

    sudo -i
    wget -N http://kanotix.com/files/install-fglrx-debian.sh
    DISPLAY= sh install-fglrx-debian.sh -z

    and it geives this erro:


    root@magrinho-laptop:~# DISPLAY= sh install-fglrx-debian.sh -z
    Error: No KANOTIX found. Do not ask for support!
    Warning: /etc/X11/xorg.conf needs some modifications. Trying now.
    Warning: Adding "Configured Video Device" to "Screen" Section.
    patching file /etc/X11/xorg.conf
    Hunk #1 FAILED at 31.
    Hunk #2 FAILED at 41.
    2 out of 2 hunks FAILED -- saving rejects to file /etc/X11/xorg.conf.rej
    Error: Unable to patch. Please manually fix file!

    what shoul i do next?

    Comment


    • #22
      sudo rm -f /etc/X11/xorg.conf*

      before. your config file was not standard then try again.

      Comment


      • #23
        NICE! its done! 100% thanks KANO!

        Comment


        • #24
          I noticed this watermark reappearing, but recent fglrx_drv.so has a thing where it screws up the regex by inserting a special character into the input stream (sed expands the hex code to an ASCII character, which turns out to be a regex special character that then gives you a regex error).

          So I wrote a script that works even with recent fglrx:

          http://pastebin.com/kNuZwtNY

          Comment


          • #25
            Yes, quite annoying, there are a number of people reporting it(including me) for the new macbook pros, there has been 3 or 4 versions of fglrx out that work fine, but this logo prevents me from using them. Weirdly enough, the ubuntu packaged version of fglrx does not do this. Can anyone from ATI take a look at http://ati.cchtml.com/buglist.cgi?qu...tent=watermark ?

            Comment


            • #26
              Originally posted by dmbtech View Post
              Yes, quite annoying, there are a number of people reporting it(including me) for the new macbook pros, there has been 3 or 4 versions of fglrx out that work fine, but this logo prevents me from using them. Weirdly enough, the ubuntu packaged version of fglrx does not do this. Can anyone from ATI take a look at http://ati.cchtml.com/buglist.cgi?qu...tent=watermark ?
              Also, it appears that this script fixes the elusive problem where the person's mouse gets "stuck" in the exact area where the watermark would appear, even if they don't actually have hardware that triggers the watermark!

              So this is good news all around. My hack rocks. And it works where the original by Kano fails.

              Comment


              • #27
                Well at least the same replacement still works. You don't need to use it when there exists at least one driver which is officially for your card. In that case you would just extract the run installer and put the control file from it to /etc/ati, thats all you need.

                Comment


                • #28
                  Originally posted by allquixotic View Post
                  So this is good news all around. My hack rocks. And it works where the original by Kano fails.
                  Looks like you won't make it into the next Humble Bundle.
                  Do you sign autographs, btw?

                  Comment


                  • #29
                    Originally posted by Kano View Post
                    Code:
                    #!/bin/sh
                    DRIVER=/usr/lib/xorg/modules/drivers/fglrx_drv.so
                    for x in $(objdump -d $DRIVER|awk '/call/&&/EnableLogo/{print "\\x"$2"\\x"$3"\\x"$4"\\x"$5"\\x"$6}'); do
                     sed -i "s/$x/\x90\x90\x90\x90\x90/g" $DRIVER
                    done
                    Have fun
                    On Ubuntu 11.04 (Kernal 2.6.38-8) x86_64 w/ ATI 3870 x2, the above failed hard. It broke my drivers and I had to purge and reinstall stuff. Still brilliant considering it worked at one point in time.

                    Originally posted by dmbtech View Post
                    Yes, quite annoying, there are a number of people reporting it(including me) for the new macbook pros, there has been 3 or 4 versions of fglrx out that work fine, but this logo prevents me from using them. Weirdly enough, the ubuntu packaged version of fglrx does not do this. Can anyone from ATI take a look at http://ati.cchtml.com/buglist.cgi?qu...tent=watermark ?
                    Messing with a compiled module seems almost too hard core for me. I didn't learn my lesson and I don't actually know why I tried your script, but it worked. Although I must say I was super scared when my screen went black after running it, but a hard reboot fixed it and weeee no watermark. Thank you!


                    Side note for those in my boat, my version of Ubuntu didn't ship with ruby. I did:
                    apt-get install ruby
                    chmod 700 script
                    ruby script

                    Comment


                    • #30
                      hmm, both scripts fails with 11.7: kano's fails with "unmatched [" and allquixotic's completes OK but then the module hardlocks my box.
                      firepro v5800 + Fedora 15 & kernel-2.6.40-4.fc15.x86_64 here. As the official firepro driver doesn't support F15 kernels + Xorg, Im stuck with the watermark...

                      Any success someone ?

                      Comment

                      Working...
                      X